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Chapter 1 - Introduction 
This Software Guide describes using the Siemens i|config™ Graphical Configuration Utility 
(Version 4) to develop configurations for the Siemens 353 family of process automation 
controllers.1  Controller configurations are created on a personal computer (PC) by selecting, 
placing, and interconnecting function block and ladder logic graphic elements.  A controller does 
not need to be connected to the PC while building the configuration. An example of a 
configuration screen is shown in Figure 1-1. 
 
A completed configuration is downloaded from the PC to a controller using either COM, LIL2, or 
Ethernet communications. A configuration can also be uploaded from a controller and edited. 
Alternatively, a MultiMediaCard (MMC) can be used to transfer a configuration between the PC 
and a controller.3  
 

 
 

Figure 1-1  Typical configuration screen 
 
While developing a configuration, the User’s Manual for the controller model to be configured 
should be available for reference as it includes detailed information on function blocks, Factory 
Configured Options (FCOs), and controller configuration and operation. 
                                                 
1 Includes the Model 353 Process Automation Controller, Model 353R Rack Mount Process Automation Controller 
(i|pac™ Internet Control System), Model 352Plus™ Single-Loop Digital Controller, Model 354 Universal Control 
Station, and Model 354N Universal Loop Controller (model series 354 discontinued) from Siemens and Moore 
Products Co.  
2 Model 353 Design Level A supports LIL; Design Level B does not support LIL however Ethernet is standard. 
3 Requires Model 353, Design Level B; refer to the Model 353 User’s Manual, UM353-1B for details. 
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1.1  Menus and Toolbars 
i|config menus and toolbars are identified in Figure 1-2. Each menu selection and each toolbar 
button is discussed in this guide. 
 
 
 
 
 
 
 

 
 
 
 
 

Figure 1-2  Toolbars 
 
The i|config screen features familiar Windows® elements with application specific menus, 
toolbars and buttons: 

• Title Bar – Shows the name of the presently viewed configuration. 

• Menu Toolbar – Provides access to common Windows functions such as Open (a file or 
configuration), Save, Print, and Help. 

• Standard Toolbar – Contains a series of button to directly access many common Windows 
functions such as New (configuration), Open, Save, and Print. 

• Graphic Primitives Toolbar – Comprised of several toolbars with buttons to create drawing 
objects (e.g. lines, rectangles, arcs) and text, edit object attributes, and zoom in or out. 

• Line Connection Toolbar – Contains tools to select and place function blocks in a function 
block loop and to add interconnecting lines to function block loops and ladder logic loops. 

• 353 Objects Toolbar – Provides tools to create a new function block loop (either a custom 
loop or a loop based on a Factory Configured Option) or a new ladder logic loop. 

• Function Block Toolbar – Includes tools to select, find, and interconnect function blocks. 

• Ladder Logic Toolbar – Provides tools to select and place ladder logic elements (such as 
contacts, coils, and timers) in a ladder logic loop. 

Station 
Resources 

Alignment Toolbar 

Graphic Operations 
Toolbar 

Ladder Logic 
Toolbar 

353 Objects 
Toolbar 

Line Connection 
Toolbar 

Standard Toolbar Graphic Primitives Toolbar 

Function 
Block Toolbar 
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• Graphic Operations Toolbar (i.e. automatic placement) – Contains tools to move user-
created graphic objects to the front or to the back of overlapping objects. Objects can also 
be rotated or flipped, or grouped and ungrouped. 

• Alignment Toolbar – Contains tools to align user-created objects to a grid or to a dominant 
object to improve the appearance and readability of the loop drawing. 

• Station Resources Toolbar – Provides an indication of available controller memory and 
function block resources. 

• Monitor 353 Button – Enables uploading of active process data from a controller and viewing 
of that data within i|config, in the operating function block or ladder logic loop. 

1.2  Configuration Views 
i|config has four types of configuration views: 

• Station View4 

• Function Block View 

• Ladder Logic View 

• Report Views: 

o Function Block Parameters 
o Connection Identifiers 
o References 

 
Each of these views is briefly discussed below and in greater detail in subsequent chapters. 
 
In each view, colored buttons in the toolbars and black text in menu lists indicate available 
operations. Grayed buttons and grayed text in menu lists indicate operations that are not 
available in that view. 

1.2.1  Station View 
The Station view displays a tree control list of function blocks and ladder logic loops that have 
been created.  The station view automatically displays when a new or existing file is opened.  
Function block loops and ladder logic loops are created in this view. Figure 1-3 shows a station 
view for a configuration. 
 
The title bar of the station view specifies the following: 
 

Configuration File Name:  Controller Tag Name.....Database Revision 
 
The station view is discussed in more detail in Chapter 2 Working with the Station View. 

1.2.2  Function Block View 
The Function Block View provides workspace for developing a loop using function block 
objects.  In this view, function blocks are selected, placed, and connected to create a function 
block loop. The active screen in Figure 1-1 is a view of a function block loop. 
 
The title bar in the function block view specifies: 
 

                                                 
4 In this guide, Station and Controller are used interchangeably. 
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Configuration File Name: Controller Tag Name: Loop Name (zoom level) 
 
The function block view is discussed in detail in Chapter 3 Working with Function Block Loops. 
 

 
Figure 1-3  Station view 

1.2.3  Ladder Logic View 
The ladder logic view provides a four page workspace for developing a ladder logic loop. Ladder 
logic elements are selected, placed, and connected in this view. 
 
The title bar in the ladder logic view specifies: 
 

Configuration File Name: Controller Tag Name: Loop Name (zoom level) Page # 
 
The ladder logic view is discussed in detail in Chapter 4 Working with Ladder Logic Loops. 

1.2.4  Report View 
Three report views display lists of function block parameters, connections, and references, and 
how they are used.  These views include: 

• Function block parameters – displays a list of function blocks and their parameters used in 
the configuration.   

• Connection identifiers – displays a list of function block outputs and their connections in the 
configuration.  

• References – displays the reference name and the value for user-defined and fixed value 
references in the configuration. 

For more information on report views, refer to Chapter 2 Working with the Station View. 



SG15939-64V400 Chapter 1 - Introduction 

 1-5

1.3  Application Publications and Configurations 
A series of application oriented publications can be found on the Siemens Internet site. The 
configurations described in many of these papers can be downloaded and opened in i|config. 
These example configurations can make learning i|config even easier. See the link below. 
 

Process Application Data (AD) Publications and Downloadable Configurations: 
http://www2.sea.siemens.com/Products/Process-Instrumentation/Support/PI-Application-
Documents.htm 
 
The configuration file default installation path is C:\program files\cfg353\configs. 
 

IMPORTANT 
A configuration file is intended to provide a more complete understanding 
of the concepts put forth in the associated AD publication and is not 
intended for use in actual process applications without necessary 
modifications and/or testing by a knowledgeable user aware of actual 
system requirements. 

1.4  PC Requirements 
The PC on which i|config is to be installed should have: 

• Microsoft® Windows® 98, 2000, NT4.0, or XP operating system 

• 600 MHz or faster microprocessor 

• CD-ROM Drive 

• VGA (800x600) or higher display 

• 256 MB of RAM minimum (512 MB or more will improve performance) 

• Mouse 

• 1 GB available hard disk space 

• Adobe Reader to open the on-line Software Guide 

As needed: 

• Card reader for a MultiMediaCard (MMC) to transfer configurations5 

• Appropriate PC to controller cable to transfer configurations (dependent upon selected 
communications protocol and controller port) – Refer to Chapter 5 Communicating with the 
Controller for additional information. 

1.5  Configuration Prerequisites 
To be able to quickly and easily build controller configurations: 

1. Read and understand the i|config Software Guide. 

2. Understand the operation and configuration of the controller to be configured by reading the 
appropriate User’s Manual listed in Table 1-1. 

                                                 
5 Requires Model 353, Design Level B; refer to the Model 353 User’s Manual, UM353-1B for details. 
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Table 1-1  Controller design levels and manuals 
 

Controller Design Level User’s Manual 
A UM353-1 Model 353 
B UM353-1B 

Model 353R B UM353R-1 
A UMiPAC-1, Rev 1 and Rev 2 i|pac 
B UMiPAC-1, Rev 3 and later 

Model 352Plus A UM352P-1 
Model 354 A UM354-1 
Model 354N A UM354N-1 

 
Refer to the appropriate User’s Manual to determine the position of the Design Level letter 
in the controller model number and for the location of the model number. See Section 1.10 
Product Support to download the current revision of a manual. 

3. Have a working knowledge of the Windows operating system.  

4. Understand hexadecimal number formats. 

5. Know how to select items in a Windows program (for more information see Section 6.7.3 
Selection Mode in Chapter 6 Using the Toolbars). 

6. Be sure the PC and controller are correctly connected and are working properly.  The 353 
controller family supports Modbus, Local Instrument Link (LIL)6, and Ethernet 
communications7. 

1.6  Installation 
Before installing i|config, refer to Section 1.4 PC Requirements to be sure the personal 
computer meets or exceeds the minimum requirements.  
 
Insert the i|config CD-ROM in a CD or DVD disk drive. Installation should begin automatically. 
Follow the on-screen prompts to install i|config. 
 
Note: Read the readme.txt file on the CD before installing i|config for recommendations 
concerning uninstalling an earlier version of i|config and moving stored configurations. 
 
Note: If Windows Auto-run is not enabled and the installation program does not launch 
automatically, click Start > Run.  Type the command shown in Figure 1-4 below, replacing �d� 
with the letter of the disk drive in which the CD-ROM has been inserted.  Click OK. Follow 
the on-screen prompts to install i|config. 
 
The default installation path is c:\\program files\siemens\iconfig. 
 

                                                 
6 LIL is supported in Model 353 Design Level A, 353R and 352P; LIL is not supported in Model 353 Design Level B. 
7 Ethernet communications is standard in Model 353 Design Level B and optional in Model 353 Design Level A, 
Model 353R, Model 352P, and Models 354 and 354N. 
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Figure 1-4  Run dialog 

1.7  Registration 
Registration is highly recommended to ensure that you receive prompt notification of 
enhancements and operational issues. A registration card is included with the installation CD. 
Write the requested information on the card and mail it to the address provided. Alternatively, 
software can be registered at http://www.sea.siemens.com/instrbu/support/swregistration2.htm. 

1.8  Contents 
Chapter 1 – Introduction, provides an overview of i|config. It also contains an overview of this 
Software Guide and describes the conventions used in this guide. 
 
Chapter 2 – Working with the Station View, describes how to use the station view to develop a 
configuration. 
 
Chapter 3 – Working with Function Block Loops, describes how to create function block loops to 
develop configurations for control of continuous processes. 
 
Chapter 4 - Working with Ladder Logic Loops, describes how to create ladder logic loops to 
develop configurations for control of discrete processes. 
 
Chapter 5 – Communicating with the Controller, discusses configuring the various 
communication ports to download a configuration from the PC to the controller or to upload a 
configuration from the controller to the PC. 
 
Chapter 6 – Using the Toolbars, describes how to use the toolbars to perform many of the 
operations in i|config. 
 
Chapter 7 – Using the File Menu, discusses the basic file operations such as creating a new file, 
opening an existing file, saving a file, deleting a file, printing a file and other common Window 
functions.  
 
Chapter 8 – Using the Edit Menu, discusses operations that are performed on items, such as 
cut, copy, paste, delete, and editing item attributes.  This chapter also discusses editing 
references in the configuration. 
 
Chapter 9 – Using the View Menu, describes displaying the toolbars and other viewing options 
such as report views. 
 



Chapter 1 – Introduction  SG15939-64V400 

 1-8

Chapter 10 – Using the Loop Menu, discusses how to create and manipulate a function block 
loop or ladder logic loop. 
 
Chapter 11 – Using the Communications Menu, provides a serial port configuration procedure. 
Refer to Chapter 5 for detailed port configuration, upload and download procedures. 
 
Chapter 12 – Using the Tools Menu, describes how to set up a path for uploading a 
configuration and discusses loop resource information. 
 
Chapter 13 – Using the Windows Menu, discusses the arrangement of open windows and how 
to close an open window. 
 
Chapter 14 – Using the Help Menu, discusses how to access the online Software Guide and 
other information about i|config.  

1.9  Software Guide Conventions 
The following conventions are used throughout this guide. 
 
Steps in a procedure begin with an arrow at the left margin pointing right.  For example: 
 
! This indicates a set of steps to follow. 
 
Keys to press on the keyboard are bold and within (<) less than or (>) greater than symbols.  
For example, <Enter> means press the Enter key.  
 
Keyboard shortcuts appear in the following format <Ctrl + P>. This format means press and 
hold the “Ctrl” key and press the “P” key. 
 
Buttons to click on the screen are bold and within brackets.  For example [OK] means click the 
OK button on the screen. 
 
Items the user will select from a submenu are in bold and displayed by:  
 
Menu > Menu Option > Submenu option  
 
Notes appear in this font.  The word �Note:� appears before the explanation. 
 
“Select“ refers to clicking a menu option, an item in a list, a function block, a ladder logic 
element, a connection line, or a graphic item.  
 
“Click” refers to clicking the left mouse button on a toolbar or dialog button. 
 
“Double-click” refers to clicking the left mouse button twice consecutively. 
 
“Drag” refers to holding the left mouse button down on a selected item and moving it to a new 
location. 
 
“View” refers to the active window.  Views in i|config include the station view, function block 
view, ladder logic view, and report view.  
 
“Loop” refers to one function block or ladder logic view. 
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“Items” refer to function blocks, ladder logic elements, connection lines, and graphic items 
created from the Graphic Primitives toolbar. 
 
Whenever [Cancel] is an option on the dialog, the user can click this button or press <Esc> to 
cancel the operation. 
 
Pressing <Esc> ends any item or line operation. 
 
Listed below are the i|config keyboard shortcuts. 
 
Alt+I................Zoom In 
Alt+O..............Zoom Out 
 
Ctrl+N.............File New 
Ctrl+O ............File Open 
Ctrl+S.............File Save 
Ctrl+P.............File Print 
 
Ctrl+C.............Copy 
Ctrl+X.............Cut 
Ctrl+V.............Paste 
 
Ctrl+A.............Select All 
 

1.10  Customer/Product Support 
Support is available through an online Support Request service; a link is provided in the table at 
the end of this section. 
 
When contacting Siemens for support: 

• Please provide complete product information: 

! For hardware, this information is provided on the product nameplate (part number or 
model number, serial number, and/or version). 

! For most software, this information is given in the Help > About screen. 

• If there is a problem with product operation: 

! Is the problem intermittent or repeatable? What symptoms have been observed? 

! What steps, configuration changes, loop modifications, etc. were performed before 
the problem occurred? 

! What status messages, error messages, or LED indications are displayed? 

! What troubleshooting steps have been performed? 

! Is the installation environment (e.g. temperature, humidity) within the product’s 
specified operating parameters? For software, does the PC meet or exceed the 
minimum requirements (e.g. processor, memory, operating system)? 

• A copy of the product Service Instruction, User’s Manual, or other technical publication 
should be at hand. The Siemens public Internet site (see the table) has current revisions of 
technical literature, in Portable Document Format, for downloading. 
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• To send an instrument to Siemens for warranty or non-warranty service, call Repair Service 
and request a Return Material Authorization (RMA). 

 
IMPORTANT 

 
An instrument must be thoroughly cleaned (decontaminated) to remove 
any process materials, hazardous materials, or blood-borne pathogens 
prior to return for repair. Read and complete the Siemens RMA form(s). 

 
Technical Support 
 
For the location of your local Siemens representative, visit the Siemens Process Instrumentation 
product support page at http://www2.sea.siemens.com/Products/Process-
Instrumentation/Support/Customer-Support.htm. 
 
For technical support refer to the following table and click the appropriate link. 

Technical Support 
 Online Support 

Request 
http://www.siemens.com/automation/support-request 

 Telephone 1 800 333 7421 
 Hours of Operation 8 a.m. to 4:45 p.m. eastern time, Monday through Friday (except holidays) 
 Technical Publications 

in PDF 
http://www2.sea.siemens.com/Products/Process-
Instrumentation/Support/PI-User-Manuals.htm then click the product line 
(e.g. Control Solutions) 

Public Internet Site http://www2.sea.siemens.com/Products/Process-Instrumentation 
Repair Service 1 800 365 8766 extension 3187 (for warranty and non-warranty service) 
 
 
 
 



SG15939-64V400 Chapter 2 – Working with the Station View 

2-1 

Chapter 2 - Working with the Station View 
The station view represents a complete configuration to download to a controller.  It displays a 
tree of function block and ladder logic loops.  Figure 2-1 shows a new station view and a station 
view with configured loops, such as will be seen when opening a configuration example from the 
Siemens Web site (refer to Section 1.3 Application Publications and Configurations). 
 

  
 

A. New station view 
 

 
 

B. Station view with function block and ladder logic loops 
 

Figure 2-1  Station views 
 
As a configuration is created, the percent of station (controller) 
memory available is shown in the Station Resources toolbar. 
The bargraph will change color from green to yellow to red as 
controller memory is consumed. A configuration should not be so large that Station Resources 
shows red. Consider moving independent loops to another controller or split a very large 
configuration into two or more configurations. 
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Configuration File Management 
 
Keep careful track of each new configuration and subsequent edits so the latest version of the 
configuration can be easily identified by all involved personnel. Assigning a meaningful 
configuration file name will help identify a configuration. 
 
Secure the computer system and network on which configurations are created and stored.  
 
If you want to preserve your configuration notes and documentation, take steps to ensure that 
i|config™ does not need to auto-draw the configuration after an upload from the controller. For 
example, at the controller faceplate: 

• Allow only tuning and other soft parameter changes 

• Do not add or delete function blocks or loops 

• Do not change loop names 

• Do not add, delete or change any line connections. 

Except for tuning and soft parameter changes, make all changes in i|config and download the 
edited configuration to the controller. See Section 5.4 Upload for more information. 

2.1  Creating/Opening Configurations 
Begin a new configuration by creating a new station view.  The station view enables access to 
the function block and ladder logic views.  A new controller configuration is created from the File 
menu.  For more information, see Chapter 7 Using the File Menu. 
 
! To create a new configuration:  

1. Do one of the following: 

• Select File > New. 

OR 

• Click [New] on the Standard toolbar.   

OR 

• Press <Ctrl+N>. 

2. Select the database revision number (i.e. the firmware revision number of the controller 
to which this configuration will be downloaded). See Figure 2-2. 

 

 
 

Figure 2-2  Database Revision 
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A new station view appears on the screen; see Figure 2-1.  A new station view 
provides a blank workspace area.  The default configuration file name and controller 
tag name are defaulted to Station1. 

3. Right click the station icon  and select Configure Item Attributes; See 
Figure 2-3. In the New Value text box, type a meaningful controller tag name to 
replace “Station 1” and click [Accept] and then [OK]. 

 
 

Figure 2-3  Station/Loop Attributes 

4. Select each tab in turn and configure the parameters. Refer to the STATN – Station 
Parameter function block, SECUR – Security function block, and ETHERNET – 
Ethernet Communications Network function block in the controller User’s Manual as 
needed. 

5. Select File > Save As and type a meaningful name for the configuration. Click [Save]. 
The new names appear in the title bar. 

 Note: The file name should not exceed 20 characters. 
 
! To open an existing configuration: 

1. Do one of the following. 
 

• Select File > Open. 

OR 

• Click [Open] on the Standard toolbar.   

OR 

• Press <Ctrl+O>. 
 
The Select Database File opens.  See Figure 2-4. 
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Figure 2-4  Select Database File dialog 

2. To select and open a file, do one of the following. 
 

• Select a file from the list, click [Open]. 
OR 

• Type a file name in the File name text box, click [Open]. 
OR 

• Double-click a file in the list. 
 

The configuration opens in the station view.  If a database file (.V3C) is opened and a 
corresponding graphic file (.353) is not available, i|config will create a graphic file and 
auto-draw function block objects. 

2.2  Creating a Configuration from an FCO 
A Factory Configured Option (FCO) is a controller configuration file that has preconfigured 
function block loops.  The desired FCO is selected from the list box in Figure 2-5.  Each FCO is 
described and diagrammed in the controller User Manual.  An FCO is often used as a starting 
point to develop a needed configuration. 
 
! To create a configuration from a Factory Configured Option: 

1. Do one of the following. 
 

• Select File > New FCO. 

OR 

• Click [New FCO] on the Standard toolbar.    
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The Databases Revision dialog display opens; see Figure 2-2.  Select the revision 
level of the firmware in the controller to which this configuration will be downloaded.  
After selecting the revision level the Factory Configured Options dialog will open.  See 
Figure 2-5. 

 
Note:  The selected database revision number must match the firmware revision 
number of the controller for which the configuration is being developed. If the 
configuration may be downloaded to two or more controllers with different firmware 
revision numbers, select the lowest revision number of those controllers and save the 
configuration with that Revision level.  i|config can upgrade a configuration to a 
higher level.  You can then save the same configuration as a different file name for 
use in the controller with the higher Revision level. 
 
Use i|config to upgrade a configuration to a higher database level when replacing an 
installed controller with a newer controller that has a higher database level. 

 

 
 

Figure 2-5   Factory Configured Option dialog 
 

2. To select and open an FCO, do one of the following. 
 

• Select a Factory Configured Option from the dialog, click [OK]. 
OR 

• Double click a Factory Configured Option in the dialog. 
 

A station view of the Factory Configured Option will open. 
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2.3  Creating Loops 
Create and open a loop from the station view tree. A controller supports multiple loops. 
 
Loops consist of function block or ladder logic items.  Once all loops in the configuration are 
completed, the configuration is ready to download to the controller.  
 
! To create a Loop using the Menu: 

1. Do one of the following. 
 

• Select Loop > New > Function Block. 

OR 

• Select Loop > New > Ladder Logic. 
 

The Loop Name dialog displays.  “Loopxx” appears as the default in the Enter Loop 
Name text box.  See Figure 2-6.   

2. Type a meaningful name (up to 12 characters) in the Enter Loop Name text box.  Use a 
unique name for each loop in the controller.  (The last 6 characters will display on the 
controller faceplate; press TAG to scroll the entire loop name.) 

3. Click [OK] 
 

A function block or ladder logic icon appears with the name of the loop specified in the 
Loop Name dialog on the station tree.  See Figure 2-1.   

 

 
 

Figure 2-6  Loop Name dialog 
 

! To create a Loop using the toolbar, do one of the following: 
 

• Click [Function Block Loop]  in the 353 Objects Toolbar. 
OR 

• Click [Ladder Logic Loop]  in the 353 Objects Toolbar. 
 

A function block or ladder logic icon appears with the name of the loop specified in the 
Loop Name dialog on the controller tree.  See Figure 2-1.   
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2.4  Selecting the Station and/or Loop(s) 
An item must be selected before an operation can be performed on that item.  Items are 
selected individually or in a group. 
 
! To select the station and/or loop: 

1.  Click the station, function block loop, or ladder logic loop in the tree. The controller or 
loop icon and name are highlighted. 

2. To select two or more loops: 
 

• <Shift>-click on another item in the tree.  All items between the first loop clicked 
and the second are highlighted. 

OR 

• <Ctrl>-click on another item or multiple items in the tree.  Each item clicked is 
highlighted. 

 
! To deselect a selected item: 
 

• <Ctrl>-click the icon or name of the selected item in the tree.  The selected item is 
deselected. 

2.5  Changing the Station (Controller) or Loop name 
The controller and loop names are changed in the tree structure.   
 
! To change a controller or loop name: 

1. Click the controller or loop name in the tree.  See Figure 2-7. 

2. After a short pause, click the name again to select and edit the name. 

 
Figure 2-7  Loop name ready to change 

 

3. Type a name in the box.  Use a unique, meaningful name for each loop in the 
configuration.  A maximum of 12 characters is allowed. 

4. Press <Enter> or click on the workspace. 
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2.6  Changing the Station and/or Loop Attributes 
The attributes of the station and/or loops are edited one at a time or all at once.  Station 
attributes are available to edit when the station is selected, loop attributes are available to edit 
when the loop is selected, and both the station and the loop attributes are available to edit when 
they both are selected. 
 
! To edit station and/or loop attributes: 
 

Select the station and/or loop and do one of the following. 
 

• Select Edit > Item Attributes. 
 

• Right-click on the station and/or loop and select Edit Item Attributes from the 
pop-up menu. 

 
The Station/Loop Attributes dialog displays a tab for each item selected.  If the station 
was selected, a number of tabs may be available (e.g. Security, Ethernet).  See Figure 
2-8 to view the tabs that display when the station and a number of loops are selected.  

 

 
 

Figure 2-8  Station/Loop Attributes dialog 
 

The Station/Loop Attributes dialog displays a list of parameters, depending on the active 
tab.  There are three types of parameters in the station view. 
• Text 
• Numeric 
• Discrete 

 
The type of parameter is specified by the data in the Information list box.  A Selections 
list box displays, rather than an Information list box, when the selected parameter is a 
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discrete parameter.  Each tab may not have all three types of parameters available to 
edit. 
 
All parameters behind the tabs that display on the Station/Loop Attributes dialog are 
editable.  Changes do not apply to the station until the user clicks [OK].  All changes 
made in the dialog are cancelled by clicking [Cancel]. 

2.6.1  Text Parameters 
A text parameter is a character value of a parameter.  Characters are entered in the New Value 
text box.  The Information list box indicates the maximum character length allowed for the value.  
See Figure 2-8 for an example. 
 
! To edit a text parameter: 

1. Select a text parameter on the Parameter List 
 

The first line in the Information list box indicates that the selected parameter is a text 
parameter.  The second line indicates the maximum number of characters for this 
parameter.   

2. Enter any characters, up to the maximum number, in the New Value text box. 

3. Click [Accept].  The modified value changes in the Parameter List. 

4. Click [OK]. The change is stored in the configuration. 

2.6.2  Numeric Parameters 
A numeric parameter is a number value for a parameter.  Numbers are entered in the New 
Value text box.  The Information list box provides the range of numbers available for a value.  
See Figure 2-9 for an example. 
 
! To edit a numeric parameter: 

1. Select a numeric parameter on the Parameter List. 
 

The first line of the Information list box indicates that the selected parameter is an 
integer or real number parameter.  It also displays the minimum and maximum 
numeric values for the selected parameter. 

2. Enter a value, within the valid range, in the New Value text box. 

3. Click [Accept].  The modified value changes in the Parameter List. 

4. Click [OK].  The change is stored in the configuration. 
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Figure 2-9  Station/Loop Attributes dialog in edit numeric parameter mode 

2.6.3  Discrete Parameters 
A discrete parameter is a parameter for which a list of choices for the value displays in the 
Selections list box. 
 
! To edit a discrete parameter: 

1. Select a discrete parameter in the Parameter List. 
 

The Selections list box displays a list of the values to select to assign to the parameter.  
See Figure 2-10. 

2. Select the appropriate value in the Selections list box.  The selected value changes in 
the Parameter List. 

3. Click [OK].  The changes store in the configuration. 
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Figure 2-10  Station/Loop Attributes dialog in edit discrete parameter mode 

2.7  Opening Loops 
A loop is shown in a function block view or a ladder logic view that is created in the station view.  
The user selects and places items specific to the loop - function blocks for function block loops 
and ladder logic elements for ladder logic loops - within a displayed loop. 
 
! To open a loop: 

1. Do one of the following: 
 

• Select a loop in the tree, then Loop > Open from the menu. 

OR 

• Double-click a loop in the tree. 

OR 

• Right-click a loop in the tree and then select Open from the pop up menu. 
 

The function block view or ladder logic view displays, depending on the selected loop.  
Function block and ladder logic views are shown in Figures 2-11 and 2-12, respectively. 
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Figure 2-11  Function block view 

 

 
Figure 2-12  Ladder logic view 
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2.8  Cutting, Copying, and Pasting Loops 
A loop may be cut, copied, and pasted only in the station view. 
 
A function block loop can be cut, copied, and pasted into the same or different controller 
configuration (of the same database level) but any physical I/O blocks (e.g. AIN, DIN, DOUT) 
will be removed. Any function block associated with a fixed resource (I/O, Ethernet, LIL, LON) 
will not be copied. All line connections to other loops are unconfigured. 
 
A ladder logic loop can be cut, copied, and pasted but all references in the pasted loop will be 
unconfigured. 
 
Some function blocks may have only one instance, or a maximum number of instances, in a 
controller configuration.  If i|config cannot paste one or more function blocks into a loop after 
copying, it removes those function blocks and all of their connections from the pasted loop.  The 
function blocks that can be pasted display in the function block view exactly as in the original, 
with the same parameter values.  

2.8.1  Cutting Loops 
The cut function is used with the paste function to move a loop from one configuration to 
another.  When a loop is cut, it is placed in the clipboard.  The graphical and parameter 
information is removed from the loop.  The loop can then be pasted into the same or a different 
controller configuration.  See Section 2.8.3 Pasting Loops. 
 
! To cut a loop: 

1. Select a loop in the tree. 

2. Do one of the following: 
 

• Select Edit > Cut from the menu. 

OR 

• Click the [Cut] button on the Standard toolbar.  

OR 

• Right-click on the loop in the station tree and, from the pop-up menu, select Cut. 
OR 

• Press <Ctrl+X>. 
 

A loop cut message displays as in Figure 2-13. 
 

 
 

Figure 2-13  Cut loop confirmation message 
 

3. Click [Yes]. The loop is cut from the configuration and placed in the clipboard. 
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2.8.2  Copying Loops 
The copy function is used with the paste function to duplicate loops.  When a loop is copied, it is 
placed in the clipboard.  The loop can then be pasted into the same or a different controller 
configuration.  See Section 2.8.3 Pasting Loops. 
 
! To copy a loop: 

1. Select a loop in the tree. 

2. Do one of the following: 
 

• Select Edit > Copy from the menu. 

OR 

• Click the [Copy] button on the Standard toolbar.  

OR 

• Right-click on the loop in the station tree and, from the pop-up menu, select Copy. 

OR 

• Press <Ctrl+C>. 
 

The loop is copied and placed in the clipboard. 

2.8.3  Pasting Loops 
The paste function is used with the cut and copy functions.  Pasting is useful to move a loop 
from one controller configuration to another or to duplicate a loop within the same configuration. 
 
Note: Loops may not be pasted when controller memory is exceeded. 
 
! To paste a function block loop: 

1. Cut or copy a loop in the tree. 

2. Select the controller (station) name in the station view. 

3. Do one of the following: 
 

• Select Edit > Paste from the menu. 

OR 

• Click the [Paste] button on the Standard toolbar.  

OR 

• Right-click on the loop in the tree and, from the pop-up menu, select Paste. 

OR 

• Press <Ctrl+V>. 
 

The loop is pasted into the station view. 
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2.9  Deleting Loops 
Deleting a loop removes a function block or ladder logic loop from the station view.  When a 
loop is deleted, all the graphic and parameter information is removed from the configuration. 
 
! To delete a loop: 

1. Select the loop in the tree. 

2. Do one of the following: 
 

• Select Edit > Delete from the menu. 

OR 

• Right-click on the loop in the tree and, from the pop-up menu, select Delete. 

OR 

• Press <Delete>. 
 

The deletion confirmation message displays as in Figure 2-14. 
 

 
 

Figure 2-14  Deletion confirmation message 
 

3. Click [Yes].  The loop is deleted form the configuration. 

2.10  Saving Configurations 
When an open configuration is saved to a file it is stored as a pair of files: a database file with a 
.V3C extension and a graphical file with a .353 extension. 
 
Note: When saving a configuration that will be copied to a MultiMediaCard (MMC), the file 
name should be no more than 8 characters (the 3 character extension will be added by 
i|config). Longer file names will be reduced to 8 characters and files may be difficult to 
identify when stepping through the MMC file tree from the controller faceplate. 
 
Note: When saving a previously saved configuration, i|config will save the original files (.353 
and .V3C) as filenameBackup.353 and .V3C and then saves the new .353 and .V3C files. 
 
! To save a configuration: 

1. Do one of the following: 
 

• Select File > Save from the menu. 

OR 

• Select File > Save As from the menu. 

OR 
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• Click the [Save] button on the Standard toolbar.  

OR 

• Press <Ctrl+S>. 
 

The Select Database File dialog opens.  See Figure 2-15. 
 

 
 

Figure 2-15  Select Database File dialog 
 

2. Select the folder in which to save the configuration.  The “configs” folder displays as 
the default folder. 

3. Type a new file name in the File name text box. 

4. Click [Save].  The configuration is saved in the selected folder. 

2.11  Closing Configurations 
A configuration can be closed, after it is saved, without losing any graphical information.  If the 
user attempts to close a configuration before saving, i|config displays a warning message 
offering to save the configuration before closing. 
 
! To close a configuration: 

1. Select File > Close. 
 

If the configuration has been saved, the file closes and it is removed from the view.  If 
the configuration has not been saved, the message in Figure 2-16 is displayed. 

 

 
 

Figure 2-16  Save warning message 
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2. Click [Yes] to save and close the configuration.  If the configuration has not been 
previously saved the Select Database File dialog will open.  See Section 2.10 Saving 
Configurations section for more information on entering a file name and saving the 
configuration. 

 
Click [No] to close the configuration without saving. 
 
Click [Cancel] to cancel the configuration closing operation. 

2.12  Deleting Configurations 
A configuration can be deleted using the File menu or the delete key on the keyboard.  Both the 
.V3C and .353 files will be deleted when the configuration is deleted. 
 
! To delete a configuration: 

1. Select File > Delete. 
 

The Select File to Delete dialog is displayed.  See Figure 2-17. 
 

 
 

Figure 2-17  Select File to Delete dialog 
 

2. Do one of the following: 
 

• Select the file to delete and click [Open]. 
OR 

• Enter the file name in the File Name text box and click [Open]. 
OR 

• Select the file to delete and press <Delete>. 
 

The deletion confirmation displays.  See Figure 2-18. 
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Figure 2-18  Deletion confirmation message 
 

3. Click [Yes].  The file is deleted. 
 

Click [No] to cancel the delete operation.   

2.13  Viewing Controller (Station) Information 
i|config provides you with a method to view function block parameters, connection identifiers, 
and references used in the active configuration.  These can be printed for easier viewing.  For 
information on printing configuration information, see Section 2.14 Printing Configuration 
Information. 

2.13.1  Function Block Parameters 
Function block parameters are the parameters of a controller, including all parts of its loops and 
their function blocks, if any, that can be changed using the Attributes dialogs.  See Section 2.6 
Editing the Station and/or Loop Attributes for more information.  Printing function block 
parameters may make it easier to review controller parameter information. 
 
! To view function block parameters: 
 

Select View > Function Block Parameters. 
 

The Function Block Parameters report view for the active configuration is displayed. 

2.13.2  Connection Identifiers 
Connection identifiers are used to label the connections between an output on a function block 
and any inputs to which it connects.  This report is especially useful for identifying connections 
between function block loops.  Connections on ladder logic loops do not use connection 
identifiers.  The Connection Identifier report view displays all connection identifiers and their 
values of the active configuration. 
 
! To view connection identifiers: 
 

Select View > Connection Identifiers 
 

The Connection Identifiers report view for the active configuration is displayed. 



SG15939-64V400 Chapter 2 – Working with the Station View 

2-19 

2.13.3  References 
References label the digital outputs of function blocks and coils.  They have a name and a 
value.  The References report view displays all references and their values for the active 
configuration.  The two types of references are: 

• User-defined (i.e. external reference or function block reference) 

• Fixed value (i.e. coil reference) 

 
The user creates a user-defined reference through the Edit Reference dialog.  The value of a 
user defined reference is a digital output of a function block on a function block loop. 
 
Fixed value references are created automatically when a coil is created on a ladder logic loop.  
The user cannot create a fixed value reference. 
 
! To view references: 
 

Select View > References. 
 

The References report view for the active configuration is displayed.  See Figure 2-19. 
 

 
 

Figure 2-19  References report view 
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2.14  Printing Configuration Information 
The Function Block Parameters, Connection Identifiers, and References report values can be 
printed to document the information in hard copy form. See Figure 2-20.  One report can be 
printed at a time.  The following procedure describes how to print these views.  For more 
information on printing, see Section 7.12 Print. 

 

 
 

Figure 2-20  Print dialog 
 
! To print configuration information: 

1. Make the view to be printed the active window. 

2. Do one of the following: 
 

• Select File > Print in the active window. 

OR 

• Press <Ctrl + P>.  
 
The Print dialog displays.  See Figure 2-20. 

3. Make any necessary changes to the Print dialog. 

4. Click [Print].  The active report is sent to the printer. 
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2.15  Closing Report Views 
The report views do not need to be open while creating the configuration. 
 
! To close a report view: 

1. Make the report view the active window. 

2. Click  in the upper right corner of the window. 

2.16  Creating and Editing References 
As described in Section 2.13 Viewing Controller (Station) Information, there are two types of 
references: user-defined and fixed-value.  User-defined references can be created manually. 
i|config automatically creates fixed-value references when coils are created in a ladder logic 
loop.  Since fixed-value references are automatically created, they are limited in what can be 
edited. 

2.16.1  Creating References 
References have a name and a value.  User defined references are the only type of reference 
that can be created manually.  Up to 16 characters may be used in a reference name.  The 
value of a user defined reference is a digital output on a function block. 
 
When configuring a value for a reference, at least one function block loop must have a function 
block that has a digital output. The value is the source output of a connection. In an external 
(user-defined) reference, the source output is defined in the Reference Create/Modify dialog 
box. For a coil (fixed) reference, the value (source output connection) is defined in ladder logic 
loop when the coil input is configured to a ladder logic element. For more information, see 
Section 8.7 References. 

2.16.2  Modifying References 
Modify one reference at a time.  The name of a user-defined reference or a fixed-value 
reference may be edited.  A user-defined reference value may be edited; editing of a fixed-value 
reference is limited, hence the name “fixed value.”  For more information, see Section 8.7 
References. 

2.16.3  Showing Uses of References 
The Show Uses option displays where a reference is used.  It shows uses of the selected 
reference.  For more information, see Section 8.7 References. 

2.16.4  Deleting References 
A fixed value reference can not be deleted. 
 
The user can select multiple user-defined references to delete all at once.  [Delete] is only 
enabled if all selected references are user defined.  For more information, see Section 8.7 
References. 
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Chapter 3 - Working with Function Block Loops 
Function block loops represent configurations that create continuous control applications.  Each 
loop is comprised of function blocks, connection lines and, where needed, graphic items. 
 
The function block view displays when the user double-clicks a function block loop in the tree 
control of the station view or right-clicks on the icon and, from the pop-up menu, selects [Open]. 
 
The view shows the workspace for creating configurations using function blocks.  See Figure 3-
1 for an example of a function block view.   
 

 
Figure 3-1  Function block view 

 
The title of the function block view specifies the following: 
 

File Name: Station (Controller) Name: Loop Name (zoom level) 

3.1  Creating/Opening a Function Block Loop 
Creating a function block loop involves placing function blocks onto the workspace and making 
connections between blocks.   
 
! To create a function block loop: 
 

Do one of the following to create a function block loop: 
 

• With the Station View (see Figure 2-1) displayed, select Loop > New > Function 
Block from the menu toolbar. 

 
The Loop Name dialog will open.  The default name appears in the Enter Loop 
Name text box.  See Figure 3-2.  Type a meaningful, unique loop name into the 
Enter Loop Name text box and click [OK].  The name may be up to 12 characters; 
the period (.) and quote marks (“) are not legal characters. A function block icon is 
created and placed in the tree control. 
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Figure 3-2  Loop Name dialog 

OR 

• Click the [Function Block Loop] button on the 353 Objects Toolbar.   
 

A function block loop icon is constructed and placed in the tree control with a 
default name used for the loop name. 

 
! To open a function block loop: 
 

Do one of the following to open a function block loop: 
 

• From the tree control, select the loop icon and then select Loop > Open from the 
menu. 

OR 

• Right-click on the function block loop icon and, from the pop-up menu, select 
Open. 

OR 

• From the tree control, double-click on the function block loop. 
 

The loop opens and the function block loop is displayed. 

3.2  Describing Function Blocks 
A function block is the building block for creating a function block loop.  Function blocks are 
placed on the workspace one at a time, or multiple times when in the repeat mode.  Up to 250 
function blocks can be placed in a loop.  Function blocks can be placed anywhere on the 
workspace except on top of other blocks, on top of connecting lines, or off the sheet. 
 
Function blocks display as a rounded rectangle (block) with short input and output lines 
projecting from the block.  See Figure 3-3.  Inputs are located on the left side of the block and 
outputs are located on the right side of the block.  All inputs and outputs are identified.  Blocks 
that have physical inputs or outputs associated with them will have screw terminal symbols on 
one side of the block.   
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Figure 3-3  Function blocks 

 
The block name and instance number appear in the center of the block.  Instance numbers are 
described in the controller User’s Manual. 
 
The three types of block inputs and outputs are shown in Table 3-1 below. An input can have 
only one connection but outputs can have multiple connections. 
 

Table 3-1  Input/Output Types 
 

I/O Type Color Provides 
Range Black Range (Scaling) 
Analog Red Real (Floating Point Number) 
Digital Blue Discrete (I/O) 

 
While many function block attributes may be edited, refer to Section 3.5 Editing Function Block 
Attributes, three attributes are not editable: the block size, the font of the text within the function 
block, and the colors of the input and output connection lines. 

3.3  Placing Function Blocks 
Function blocks are selected and placed from the Select Item to Create dialog shown in Figure 
3-4. i|config™ allows some function blocks to be placed only once in a configuration or loop 
while others can be used multiple times.  Function blocks associated with a physical resource 
(e.g. I/O blocks) can be used once per configuration. Other function blocks are allowed only one 
instance per loop (e.g. PID, A/M). If a function block can be used only once, it disappears from 
the Select Item to Create dialog once it has been used.  If the function block can be used more 
than once, the name of the function block is displayed in the dialog with the next available 
instance number. 
 

Note:  Function blocks are described in the controller User Manual. 
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! To place a function block: 

1. Click the [New Function Block] button on the Line Connection toolbar.   
 

The “Select Item to Create” dialog is displayed.  See Figure 3-4. 
 

 
 

Figure 3-4  Select Item to Create dialog (Generic Blocks shown) 
 

2. Do one of the following to place function blocks on the loop workspace. 
 

• Select a function block.  Click [OK]. 
OR 

• Enter the name of the block in the text box.  Click [OK]. 
OR 

• Double-click the desired function block name in the list. 
 

A dotted box appears in the workspace which indicates the start of the function block 
placement process. 

 
Note: The function block floats with the cursor until you physically place it. 

3. Move the box to a valid location for placement and click.  The function block displays 
on the function block view workspace. 

 
Note:  When a function block is dragged outside the view, the view automatically 

scrolls, keeping the function block visible within the workspace. 
 

If the cursor displays as a not allowed symbol (∅), the placement location is 
not valid. 

 

IMPORTANT 
 
The controller that is to receive the completed 
configuration must be a model (including installed 
circuit boards) and design level that supports all 
selected function blocks. Selecting certain function 
blocks will cause a �controller model warning message� 
to be displayed. To learn which blocks a particular 
controller supports, refer to the controller�s 
nameplate for its complete model number and to the 
Model Designation and Configuration Overview 
sections of the User�s Manual for that controller 
model. See Table 1-1 for a list of manuals. 
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! To place a function block multiple times consecutively: 

1. Click the [Multiple Create] button on the Line Connection toolbar.   
2. Repeat the previous “To place a function block” until all required function blocks are 

placed in the workspace. 
 

Note:  To stop placing blocks, any time during the procedure, press <Esc>, click 
[Cancel] or right click when the dotted box appears. 

 

3.4  Viewing Station and Loop Resources 
Station (Controller) Resources are displayed in bargraph form and numerically, as a percent of 
controller memory consumed. Details are accessed by clicking the Information button in the 
toolbar. The bargraph will change color from green to yellow to red as controller memory is 
consumed. 
 
A function block loop can support up to 250 function blocks. The Station Resources Information 
dialog shows the number of function blocks that have been placed in a loop. It also shows the 
“Percent of function blocks available,” as a percentage of 250; see Figure 3-5. In addition, in the 
Station Resource Information portion of the dialog, the “Cycle time base” time (i.e. calculated 
controller execution time) is shown. These measurements can be displayed in the function block 
and ladder logic views. 
 
! To view loop resources: 

1. Open the loop and do one of the following: 
 

• Select Tools > Loop Resources. 

OR 

• Click the Loop Information icon  on the Station (Controller) Resources 
toolbar. 

 
The Loop Resource Information dialog appears. See Figure 3-5. 

 

 
 

Figure 3-5  Loop Resources Information dialog 
 

2. View the information and then click [OK] to close the dialog. 
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3.5  Editing Function Block Attributes 
Function blocks are edited by changing their attributes (i.e. parameters). The Item Attributes 
dialog (see Figure 3-6) displays a list of parameters, depending on the active tab.  There are 
four types of parameters in the function block view.  

• Text 

• Numeric: Integer, Real, AUTO format, HEX (hexadecimal) format. 

• Discrete 

• Input 

 
The type of parameter is specified by the data in the Information list box.  A Selections list box 
displays, rather that an Information list box, when the selected parameter is a discrete 
parameter.  Each tab does not necessarily have all types of parameters available to edit. 
 
The user can change all parameters that display on the Items Attributes dialog.  Changes do not 
apply to the configuration until the user clicks [OK].  All changes made in the dialog, except for 
input parameters, are cancelled if the user clicks [Cancel]. 
 
Some blocks do not have attributes to edit. If they do not, the Item Attributes dialog does not 
display a tab for the selected function block attribute. 
 
! To edit function block attributes: 
 

Do one of the following to start the editing process: 
 

• Select the function block and then select Edit > Item Attributes. 

OR 

• Select the function block and then click the [Edit Item Attributes] button on the 
Graphic Primitives toolbar.  

OR 

• Select the function block and then click the [Line Connection Attributes] button 
on the Line Connection toolbar.  

OR 

• Right click the function block and from the pop-up menu select Edit Item 
Attributes. 

OR 

• Click the [Selection Mode] button  on the Graphic Primitives toolbar and then 
double-click the function block. 

OR 

• Click the [Line Connection Selection Mode] button  on the Line Connection 
toolbar and then double-click the function block. 

 
The Item Attributes dialog opens.  The names of the selected items display as tabs in 
the dialog. 
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3.5.1  Text Parameters 
A text parameter is a character value of a parameter.  Characters are entered in the New Value 
text box.  The Information list box indicates the maximum number of characters allowed for the 
value.  See Figure 3-6. 
 
! To edit text parameters: 

1. Select a text parameter in the Parameter list of the Item Attributes dialog. The 
Information box shows the text information and the New Value box shows the current 
value. 

 

 
 

Figure 3-6  Item Attributes dialog in edit text mode 
 

The first line in the Information box indicates that the selected parameter is a text 
parameter.  The second line indicates that the parameter has a maximum of 6 
characters. 

2. Type a value in the New Value text box. 

3. Click [Accept].  The value changes in the parameter list. 

4. Click [OK]. The change stores in the configuration. 

3.5.2  Numeric Parameters 
A numeric parameter is a number value for a parameter.  Numbers are entered in the New 
Value text box.  The Information list box provides the range of numbers for the value.  There are 
four types of numeric parameters: integer, real, AUTO format, and HEX format. 
 
! To edit numeric parameters: 

1. Select a numeric parameter in the Parameter list. 
 

Depending on the type of parameter selected, the corresponding edit numeric 
parameter mode of the Item Attributes dialog displays.  Each of the four types of 
numeric parameters is discussed below. 
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See Figure 3-7 for an example of the edit integer parameter mode.  The Information 
list box indicates that the selected parameter is an integer parameter.  It also displays 
the minimum and maximum range for the integer value. 
 

 
 

Figure 3-7  Item Attributes dialog in edit integer mode 
 

 
Figure 3-8 is an example of the edit real number parameter mode.  The Information list 
box indicates that the selected parameter is a real parameter.  It also displays the 
minimum and maximum range for the real value. 
 

 

 
 

Figure 3-8  Item Attributes dialog in edit real mode 
 

Figure 3-9 is an example of the edit AUTO parameter mode.  The Information list box 
indicates that the selected parameter is a real parameter.  It also displays the range 
values.  If a New Value of “0” is entered, “AUTO” displays as the value in the 
Parameter List.  
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Figure 3-9  Item Attributes in edit AUTO mode 
 
Figure 3-10 is an example of the edit HEX parameter mode.  The Information list box 
indicates that the selected parameter is a HEX number parameter.  It also displays the 
HEX value range for the selected parameter. 
 

 
 

Figure 3-10  Item Attributes dialog in edit HEX mode 
 

2. Enter the desired value in the New Value text box 

3. Click [Accept].  The value changes in the parameter list. 

4. Click [OK]. The change stores in the configuration. 

3.5.3  Discrete Parameters 
A discrete parameter is a parameter for which a list of choices for the value displays in the 
Selections text box.  The user cannot manually enter a value but selects from the choices. 
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! To edit discrete parameters: 

1. Select a discrete parameter on the Parameter List. 
 

The Item Attributes dialog displays the Selections box with the discrete information and 
the current value highlighted.  See Figure 3-11. 

 

 
 

Figure 3-11  Item Attributes in edit discrete mode 
 

2. Select the value in the Selections list box.  The value changes in the Parameter List. 

3. Click [OK]. The change stores in the configuration. 

3.5.4  Input Parameters 
Input parameters refer to inputs to a function block.  An input value is configured by a 
loop/block/output reference or by “unconfigured.” 
 
! To configure input parameters by the loop/block/output method: 

1. Select an input parameter from the Parameter List. The Item Attributes dialog for the 
edit input parameters mode displays; see Figure 3-12. 

 

 
 

Figure 3-12  Item Attributes dialog in edit input mode 
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The Information list box indicates that the selected parameter is an input parameter.  
The Connect To list box indicates that the input can be connected to a 
Loop/Block/Output or a Reference.  The [Edit Input] button allows the user to edit the 
input connection. 

2. Click [Edit Input].  The dialog box for a Loop/Block/Output connection is displayed.  
See Figure 3-13.  

 

 
 

Figure 3-13  Configuration Connection dialog 
 

3. Select the loop from the Loop list box.  A list of blocks in the selected loop will be 
displayed in the Block list box. 

4. Select a function block from the Block list box.  A list of available outputs will be 
displayed in the Output list box. 

5. Select the output from the Output list box. 

6. Click [OK]. 
 

The input parameter is configured by the selected loop/block/output value.  A triangle and a 
connection identifier (e.g. A25) appear at both connection points in the graphic function 
block view signifying a connection; a line is not drawn.  The connection identifier is added 
to the Connection Identifiers report view.  The value also changes in the Parameter List in 
the Item Attributes dialog. 

 
! To unconfigure an input parameter: 

1. Perform steps 1 and 2 of “To configure input parameters by the loop/block/output 
method” above. 

2. Click the Unconfigure check box. 

3. Click [OK].  The input value is unconfigured. 
 
! To configure a digital input parameter by reference: 

1. Select a digital input from the Parameter List in the Items Attributes dialog. 

2. Select Reference in the Connect To list box. 

3. Click [Edit Input].  The Set Reference dialog opens. See Figure 3-14. 
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Figure 3-14  Set Reference dialog 
 

4. Select a reference from the Set Reference dialog. 
 

Note: Only fixed value references are displayed and, therefore, are the only ones 
that can be selected. 

5. Click [OK].  The changes are made in Item Attributes dialog.  Changes are listed there 
by value and by reference. 

6. Click [OK].  

3.6  Connecting Function Blocks using Connection Lines 
Connection lines are created using the Line Connection Mode button on the Line Connection 
toolbar.  Only function blocks in the same loop can be connected with connection lines.  There 
are four ways to make a connection line: 

• Click a block input and then click a block output. 

• Click a block input and then click a connection line. 

• Click a block output and then click an unconfigured input. 

• Click a connection line and then click an unconfigured input. 

The Line Connection Mode button is also referred to as the Wire Spool button because the 
cursor becomes a spool when the Line Connection Mode button is selected.  
 
A connection line can go anywhere on the workspace, except through a function block.  If a 
connection line can not be routed, a triangle and connection identifier display on the block input 
and output to signify a connection. 
 
The attributes of a connection line can be changed in the Line Connection tab of the Item 
Attributes dialog.  Refer to Section 3.9 Editing Connection Lines for further information. 
 
To minimize configuration errors, i|config will draw a connection line only between the same 
type of input and output.  For example: 

• A Range input connects to a Range output (black to black) 

• An Analog input connects to an Analog output (red to red) 

• A Digital input connects to a Digital output (blue to blue) 

If a line ends on an input, the input must be unconfigured.  A line started on an input can end on 
an output or an existing connection line.  Connection dots, points at which lines connect to each 
other, display on any lines that share the same segment. 
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Connection lines are made only between inputs and outputs of function blocks in the same loop.  
When a connection is made, a connection identifier (e.g. A25) is shown on the input and the 
output to identify the connection.  If a connection is made, but the line could not be routed, a 
triangle and a connection identifier display on the input and the output to signify that a 
connection exists.   
 
! To connect function blocks on the same loop: 

1. Click the [Line Connection Mode] button.   The cursor becomes a wire spool. 

2. Click a valid starting point. 
  

Note: The cursor displays as a spool with a (+) sign when over a valid connection 
point. It displays with a (∅) symbol when the connection point is not valid. 

3. Move the cursor to a valid connection point. 

4. Click a valid ending point to make a connection. 
 

If possible, a line is drawn between the connection points. If a line can not be routed 
between the two points, a triangle and a connection identifier appear at each 
connection point signifying a connection. 

 
Note: Press <Esc> at any point, when creating a connection line, to cancel the 
operation. 

 
A connection can start on an input, an output, or an existing connection line.  If the 
input already has a connection or is used by a reference, a warning message is 
displayed. See Figure 3-15. 

 

 
 

Figure 3-15  Input already has a connection warning message 
 

If a connection line starts on an existing line, the starting point is considered to be the 
output of the connection line on which the user started. 

3.6.1  Auto-Routed and Manual-Routed Connection Lines 
The connection line between two items is the line connection path.  Line connection paths 
represent signal connections between inputs and outputs.  There are two types of connection 
lines. 

• Auto-routed connection lines 

• Manual-routed connection lines 
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An Auto-routed connection line is generated when the spool tool is used to directly connect an 
input to an output (e.g. click an input and click a valid output, two clicks).  An Auto-routed line is 
solid and is auto-routed by i|config to form a signal path between an input and an output.  See 
figure 3-16. 
 

 
Figure 3-16  Auto-routed lines 

 
A Manual-routed connection line is generated when more than two clicks occur in routing a line 
between an input and an output.  A Manual-routed connection line is dotted and has auto-routed 
segments between each click.  See Figure 3-17. 
 

 
Figure 3-17  Manual-routed lines 

 

3.6.2  Connection Dots 
Where two or more connection lines intersect, a connection dot is placed at the junction.  A 
connection dot is the point at which two or more lines connect, rather than where they cross 
over each other.  See Figure 3-18. 
 

 
 

Figure 3-18  Connection dot 
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3.7  Connecting Function Blocks without Connection Lines 
Function blocks may be connected on the same or different loops in the line connection mode.  
This is done using the Configure Connections dialog; see Section 3.5 Editing Function Block 
Attributes. 
 
! To connect function blocks without connection lines: 

1. Click the [Line Connection Mode] button.   The cursor becomes a wire spool. 

2. Do one of the following: 
 

• <Ctrl>+click on a function block input or output. 

OR 

• Right-click on a function block input or output.  Select Configure Connections 
from the pop-up menu. 

 
The Configure Connection dialog, shown in Figure 3-19, is displayed if the input is 
unconfigured. If the warning dialog in Figure 3-20 is displayed, do one of the following: 

 
• Click [Yes] to unconfigure the existing input connection. 

OR 

• Click [No] to leave the input connection unchanged. 
 

 
 

Figure 3-19  Configuration Connection dialog 
 

 
 

Figure 3-20  Input already has a connection warning message 

3. Select a loop from the Loop list box.  A list of Blocks displays in the Block list box. 

4. Select a block from the Blocks list box.  A list of outputs, of the same type, displays in 
the Output list box. 
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5. Select an output, if any, from the Output list box. 

6. Click [OK]. 
 

The input parameter is configured by the selected loop/block/output value.  A triangle and a 
connection identifier (e.g. A05) on the input and output of the function blocks in the graphic 
function block view signify a connection.  The connection identifier is added to the 
Connection Identifiers report view.  The value also changes in the Parameter List in the 
Item Attributes dialog. 

 
! To unconfigure input connections on the same loop: 

1. Click the [Line Connection Mode] button.   The cursor becomes a wire spool. 

2. Right-click on the input connection to be unconfigured. The Configure Connection 
dialog appears; see Figure 3-13. 

3. Click the Unconfigure check box. 
 
If you are unconfiguring an output with at least one connection, the message in Figure 
3-21 appears. 

 

 
 

Figure 3-21  Input already has a connection warning message 
 

4. Click [Yes] to unconfigure the existing input connection and remove the connection.  
 

Click [No] to cancel the operation. 

3.8  Viewing Connections 
Connections are displayed in the Connection Info dialog.  This dialog displays a list of 
connections for the selected input or output, and it indicates if there are connections to another 
loop. 
 
! To view input or output connections: 

1. Click the [Line Connection Mode] button.   The cursor becomes a wire spool. 

2. Right-click a function block input or output and from the pop-up menu, select Show 
Connections. 

 
The Connection Info dialog displays a list of input or outputs showing the 
loop.block.input or output connection for the selected input or output.  See Figure 3-22. 
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Figure 3-22  Connection Info dialog 
 

3. Click [Close].  The dialog closes. 

3.9  Editing Connection Lines 
Connection lines cannot be moved or sized.  However, the user can perform other editing 
functions on lines. 
 
! To edit connection lines: 

1. Do one of the following: 
• Click the [Line Connection Attributes] button    on the Line Connection 

toolbar. 

OR 

• Click the [Line Connection Selection Mode] button    on the Line 
Connection toolbar. 

 
The Item Attributes dialog displays.  See Figure 3-23. 

 

 
 

Figure 3-23  Item Attributes dialog 
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2. Click the Line Connection tab, if it is not already selected. 

3. Select and edit the attribute(s) as desired.  Refer to procedure for selecting a color in 
the “Custom Colors” section in Chapter 6 Using the Toolbars. 

4. Click [OK]. The modification of the line connection attributes display in the function 
block loop. 

3.10  Deleting Connection Lines 
Deleting a connection line removes a connection between an input and an output. 
 
! To delete a connection line: 

1. Do one of the following: 
 

• Click the [Line Connection Selection Mode] button    on the Line 
Connection toolbar. 

OR 

• Click the [Selection Mode] button   on the Graphic Primitives toolbar. 

2. Do one of the following: 
 

• Select the line, and then select Edit > Delete. 

OR 

• Select the line, and then press <Delete>. 

OR 

• Right-click the line and select Delete from the pop-up menu. 

3.11  Moving Function Blocks 
When moving a function block, i|config will attempt to reroute auto-routed connections to the 
block being moved. A function block cannot be moved on top of another function block or a 
connection line. 
 
! To move a function block to an empty location: 

1. Click the [Line Connection Selection Mode] button    on the Line Connection 
toolbar. 

2. Click the selected function block, drag it to a valid location, and release the mouse 
button.  The function block displays in the new location. 

 
Note: the cursor displays with a �plus� (+) sign if the move is valid.  It 
displays with a �not allowed� (∅) if the move is invalid.  If a �not allowed� 
symbol appears but no interfering line is visible, click View in the Menu 
Toolbar to ensure that all lines are displayed (checked). 

 
! To move a function block to a line interference location: 

1. Click the Erase Line Connection button. Auto and manual-routed lines are erased. 

2. Click the function block and drag it to a valid location. Release the mouse button. 
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3. Click the Automatic Line Connection button. Lines are Auto routed; previously 
manual-routed lines will be Auto routed. Where a line can be routed for visual display, 
the connection will be made and a triangle and connection identifiers added. 

 
! To move a function block to a function block interference location: 

1. Click the Erase Line Connection button. 

2. Move the interfering function block to a new location. Move the initial function block to 
the now vacated location. 

3. Click the Automatic Line Connection button. 

3.12  Deleting Function Blocks 
When deleting a function block, i|config will delete all connections to that block and all 
parameters associated with the block. 
 
! To delete a function block: 

1. Select one of the following mode buttons: 
 

• Click the [Line Connection Selection Mode] button    on the Line 
Connection toolbar. 

OR 

• Click the [Selection Mode] button   on the Graphic Primitives toolbar. 

2. Do one of the following to start the delete process: 
 

• Select a function block, and then select Edit > Delete. 

OR 

• Right-click a function block and from the pop-up menu select Delete. 

OR 

• Select the function block and then press <Delete>. 
 

The deletion confirmation dialog displays.  See Figure 3-24. 
 

 
 

Figure 3-24  Delete confirmation 
 

3. Click [Yes].  The function block and all its parameters are deleted from the 
configuration. 
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3.13  Printing Function Block Loops 
There are several print options from which to choose: 

• Screen 

• Active Window – Current View 

• Active Window – Entire View 

• Active Window – 1 to 1 

For more information on printing, refer to Section 7.10 Print. 
 
! To print a function block loop: 

1. Open the loop to be printed. 

2. Select File > Print Options > Desired Option. 

3. Do one of the following: 
 

• Select File > Print. 
OR 

• Click the [Print] button  on the Standard toolbar.  

OR 

• Press <Ctrl+P>. 
 

The Print dialog displays.  See Figure 3-25 
 

 
 

Figure 3-25  Print dialog 
 

4. Make changes to the dialog, if necessary. 

5. Click [OK].  The selected option is sent to the printer. 
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Chapter 4 - Working with Ladder Logic Loops 
Sections 4.1 through 4.6 provide an introduction to the relationship between the ladder logic and 
Boolean elements plus details concerning ladder elements, contacts, coils, and timers.  An 
example is provided of the creation of ladder logic loops and a function block loop that contains 
the discrete I/O associated with the ladder logic loop.  Details of the actual steps used in the 
configuration of a ladder logic loop are provided in Sections 4.7 through 4.18. 

4.1  Overview 
Ladder Logic loops are used in place of Boolean logic (function blocks) to design discrete logic 
operations.  Since 353 controllers are based on function block objects, i|config™ converts a 
ladder logic design to an equivalent Boolean design that will be downloaded to the controller. 

4.1.1  Ladder Logic Pages 
Up to four pages of ladder logic rungs are permitted in a ladder logic loop.  In practice, it is best 
to use only two pages of ladder logic per loop.  After the second page, you typically will run out 
of loop resources.  For this reason, it is best to switch to a new loop after two pages of ladder. 
 
When configuring ladder logic, allow an empty rung between each rung of ladder created.  
While testing (debugging) the ladder logic, you will probably need to add more contacts or rungs 
of logic.  Having unused rungs makes it easy to add needed rungs. 

4.1.2  Ladder Logic Configuration 
A summary of the steps involved in assigning names to Ladder Logic elements follows. Each 
step is then further divided into steps in subsequent paragraphs. 

1. Create the loop(s) necessary for the ladder. 

2. Create the Reference List for the discrete inputs to the ladder. 

3. Draw the ladder. 

4. Name the contacts in the ladder. 

5. Name the coils in the ladder. 

6. Connect the coils to the discrete outputs. 

 
! Create a Function Block Loop for I/O: 

1. Click the Function Block Loop button  to create a new loop. Give the loop a 
meaningful name, for example, “Motor105 I/O”.  Refer to Chapters 2 and 3 as needed. 
This loop will contain the reference names that will be the connections between this 
function block loop and the related ladder logic loop. 

2. In this loop place all of the I/O blocks (e.g. Comparators, DIN's, DID's, DOUT's and 
DOD blocks) that will be referred to from the ladders. 

 
! Create the Reference List: 

1. Select Reference from the Edit>References menu to get the Edit/Reference dialog 
box. 

2. Click the [Create] button to get the Create/Modify References dialog box. 
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3. Type the reference name of a discrete input to the ladder, such as “FAN RUNNING” or 
“MOTOR ON”. 

4. Select the name of the loop containing the Discrete I/O in the ladder.  (The check mark 
in the box next to “Unconfigured” will clear.) Select the block and output that will be 
connected to the discrete input.  
 
A symbol may appear in front of the reference name: 

% – Indicates that the reference name is connected from the ladder to a signal 
outside the controller. 

> – Indicates a connection from the ladder to another loop within the station. 
No symbol – Indicates the reference name is connected only within the ladder. 

5. Repeat steps 3 and 4 for each discrete input and output. 
 
! Create a Ladder Logic Loop and Draw the Ladder(s): 

1. Click the Ladder Logic Loop button to construct the ladder.   Give it a meaningful 
name, for example “Motor105.” 

2. Draw the ladder by clicking the [New Ladder Logic Element] button    in the Line 
Connection Toolbar and selecting the appropriate contacts and coils. 

3. Next, click the [Line Connection Mode] button    on the Line Connection Toolbar. 
The cursor will change to a wire spool that is used to interconnect or "wire" the 
elements in the ladder. 

4. Wire all the elements into the desired ladder logic configuration. 
 
! Name the Contacts: 

1. Name the contacts in the ladder using the wire spool cursor. Right-click on the contact 
name.  The Set Reference dialog box will pop up. 

2. For external inputs, select the proper discrete input from the list created earlier. 

3. Add to the reference list any contact that comes from a loop within the station.  Click 
the [Edit/References] button and click on the [Create] button.  The Create/Modify 
References dialog box will pop up.  Name the contact reference and then specify the 
loop block and output used to provide this discrete input to the ladder. 

4. If a contact comes from a coil on the ladder, leave it unconfigured until the coils are 
named in the next step. 

 
! Name the Coils: 

1. To name coils, continue to use the wire spool. Right-click on the coil name; usually it 
will be in the form of DefCoilTagn. 

2. The Create/Modify Reference dialog box will pop up with the coil name highlighted. 

3. Change the reference name to the appropriate name and click [OK]. 
4. Go to the next coil and repeat this procedure until all the coils are named. 

5. Go back through the ladder and name the unconfigured contacts that come from the 
coils that were just named.  This is done using the wire spool and right-clicking 
‘Unconfigured’ above the contact.  As before, the Set Reference dialog box pops up 
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and the appropriate coil name may be selected from the references listed by 
highlighting the appropriate name and clicking [OK]. 

 
! Connect the Coils: 

1. Connect each coil that drives a discrete output, such as START FAN, OPEN GAS 
SSV's, to a discrete output block.  This is accomplished by opening the "Discrete I/O" 
function block loop with the [Line Connection Selected Mode] button    that is 
next the wire spool button. 

2. Double-click the appropriate discrete block.  The Item Attributes dialog box will pop up. 

3. Select the tab for the block selected. 

4. Select the appropriate input to highlight it. 

5. Highlight the word Reference in the Connect to box. 

6. Click the [Edit Input] button in that box.  The Set Reference list will pop up with all the 
coil names listed. 

7. Select the proper coil name that corresponds to the discrete output channel desired 
and then click [OK].  This connects the coil to that discrete output channel.  When the 
coil goes high, the discrete output will go high. 

4.2  Ladder Logic Elements 
Logic functions are implemented in a controller using function blocks (Boolean functions).  Many 
users, however, prefer ladder diagrams for developing logic configurations. i|config can be used 
to configure logic using ladder techniques.  This section provides a list of ladder diagram 
elements, contacts, coils, and timers available for use within i|config. It also describes how they 
correspond to controller function blocks. A sample ladder logic page with a variety of elements 
is shown in Figure 4-1. 
 

 
Figure 4-1  Sample ladder logic page 
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Chapter 4 – Working with Ladder Logic Loops SG15939-64V400 

 4-4

4.2.1  Ladder Elements 
 
Power Rail (PR)  | 
This element is on the left of the ladder diagram and is always conducting. 
 
Horizontal Shunt (HS) ----- 
This element conducts when the element on the left is conducting and transfers this state to the 
element on the right. 
 
Vertical Shunt (VS) | 
This element is the inclusive OR of the states of the elements to its left. 
 
Connections by Reference <reference>  
A <reference> is a connection element to: 

• Another element within the ladder diagram 

• An input or output in the related function block loop 

• An input or output in another loop within the configuration 

4.2.2  Contacts 
A contact is a ladder element that copies a state to the element on its right equal to the logical 
AND of the state of the element on its left with the state of the reference.   

4.2.2.1 Normally Open Contact --| |-- NOC 
The NOC copies the state of the left horizontal shunt to 
the right horizontal shunt, if the state of the contact 
reference is TRUE.  Otherwise the state of the right 
horizontal shunt will be non-conducting. {The NOC is 
equivalent to a two input AND function block having inputs A <reference> & B and output O1. If 
the B input is connected to the Power Rail the contact output will equal the <reference> and an 
actual AND function block is not required.} 

4.2.2.2 Normally Closed Contact --|\|-- NCC 
The NCC copies the state of the left horizontal shunt to 
the right horizontal shunt, if the state of the contact 
reference is FALSE.  Otherwise the state of the right 
horizontal shunt will be non-conducting. {The NCC is 
equivalent to a two input AND function block having inputs A <reference> & B and output O1 
and a NOT function connected to the A input of the AND block. If the B input is connected to the 
Power Rail the contact output will equal the output of the NOT function block and an AND 
function block is not required.} 

4.2.2.3 Positive Transition Sensing Contact --|P|-- PTC 
The PTC copies the state of the left horizontal shunt to 
the right horizontal shunt for one scan cycle, when the 
state of the contact reference changes from FALSE to 
TRUE.  Otherwise the state of the right horizontal shunt 
will be non-conducting. {The PTC function is equivalent to a two input AND function block 
having inputs A <reference> & B and output O1 and a RTG rising edge trigger function 
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connected to the A input. If the B input is connected to the Power Rail the contact output will 
equal the output of the RTG function block and an AND function block is not required.} 

4.2.2.4 Negative Transition Sensing Contact --|N|-- NTC  
The NTC copies the state of the left horizontal shunt to 
the right horizontal shunt for one scan cycle, when the 
state of the contact reference changes from TRUE to 
FALSE.  Otherwise the state of the right horizontal 
shunt will be non-conducting. {The NTC function is equivalent to a two input AND function block 
having inputs A <reference> & B and output O1 and a FTG falling edge trigger function 
connected to the A input. If the B input is connected to the Power Rail the contact output will 
equal the output of the FTG function block and an AND function block is not required.} 

4.2.3  Coils 
Coils copy the state of the left horizontal shunt to the right horizontal shunt without modification 
and store the state of the left horizontal shunt into a Boolean variable, having a unique user 
assigned name for use within the graphical ladder diagram. 

4.2.3.1 Coil --(C)-- 
The C coil sets the state of the reference to TRUE 
when the left horizontal shunt is conducting and to 
FALSE when not conducting.  {The coil function is 
associated with the output state of another function 
block and assigns a unique reference name within the ladder diagram to this state.}  

4.2.3.2 Set (Latch) Coil --(S)-- 
The S coil sets the state of the coil reference TRUE 
when the left horizontal shunt changes from not 
conducting to conducting.  It will remain TRUE, after the 
left horizontal shunt returns to a not conducting state, 
until the reference is reset using an R coil assigned to the same reference.  During a warm or 
cold start of the controller, the reference will be set to FALSE.  {The set coil function is 
equivalent to a SRF function block having input S connected to the left horizontal shunt, the 
block output O1 associated with the coil reference, and PU LAST set to NO. The left horizontal 
shunt of the corresponding R coil is connected to the R input. Set is paired with the 
complementary Reset function.} 

4.2.3.3 Reset (Unlatch) Coil --(R)-- 
The R coil resets the state of the coil reference to 
FALSE when the left horizontal shunt changes from not 
conducting to conducting.  It will remain FALSE after the 
left horizontal shunt returns to a not conducting state, 
until the reference is set using an S coil assigned to the same reference.  During a warm or cold 
start of the controller, the reference will be set to FALSE.  {The reset coil function is equivalent 
to a SRF function block having input R connected to the left horizontal shunt, the block output 
O1 associated with the coil reference, and PU LAST set to NO.  The left horizontal shunt of the 
corresponding S coil is connected to the S input. Reset is paired with the complementary Set 
function.} 
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4.2.3.4 Retentive (Memory) Coil --(M)-- 
The M coil sets the state of the coil reference to TRUE 
when the left horizontal shunt is conducting and will set it 
to FALSE when the shunt is not conducting.  It will retain 
the state of the reference during a warm start (of the 
controller) until the coil is executed on the first scan cycle.  {The retentive coil function is 
equivalent to a SRF function block having input S connected to the left horizontal shunt, the R 
input is not connected (defaulting to TRUE), the block output O1 associated with the coil 
reference, and PU LAST set to YES.} 

4.2.3.5 Set Retentive (Memory) Coil --(SM)-- 
The SM coil sets the state of the coil reference TRUE 
when the left horizontal shunt changes from not 
conducting to conducting.  It will remain TRUE, after the 
left horizontal shunt returns to a not conducting state, until 
the reference is reset using a RM coil assigned to the same reference.  During a warm start of 
the controller, the reference will be retained at the previous value and during a cold start it will 
be set to FALSE.  {The set retentive coil function is equivalent to a SRF function block having 
input S connected to the left horizontal shunt, the block output O1 associated with the coil 
reference, and PU LAST set to YES. The left horizontal shunt of the corresponding RM coil is 
connected to the R input. Set is paired with the complementary Reset function below.} 

4.2.3.6 Reset Retentive (Memory) Coil --(RM)--  
The RM coil resets the state of the coil reference to 
FALSE when the left horizontal shunt changes from not 
conducting to conducting.  It will remain FALSE after the 
left horizontal shunt returns to a not conducting state, 
until the reference is set using a SM coil assigned to the same reference.  During a warm start 
of the controller, the reference will be retained at the previous value and during a cold start it will 
be set to FALSE.  {The reset retentive coil function is equivalent to a SRF function block having 
input R connected to the left horizontal shunt, the block output O1 associated with the coil 
reference, and PU LAST set to YES.  The left horizontal shunt of the corresponding SM coil is 
connected to the S input. Reset is paired with the complementary Set function above.} 

4.2.3.7 Positive Transition-Sensing Coil --(P)--  
The P coil changes the state of the coil reference from 
FALSE to TRUE for one scan cycle, when the left 
horizontal shunt changes from not conducting to 
conducting. {The positive transition-sensing coil function 
is equivalent to a RTG function block having input A connected to the left horizontal shunt and 
the block output O1 associated with the coil reference.} 

4.2.3.8 Negative Transition-Sensing Coil --(N)--  
The N coil changes the state of the coil reference from 
FALSE to TRUE for one scan cycle, when the left 
horizontal shunt changes from conducting to not 
conducting. {The negative transition-sensing coil function 
is equivalent to a FTG function block having input A connected to the left horizontal shunt and 
the block output O1 associated with the coil reference.} 

<reference>
O1

M
S S

SRFxx
S

O1

S

PU LAST = YES

<reference>
O1

SM
S S SRFxx

S
O1

S

PU LAST = YES

R

O1

RM
R R

<reference> SRFxxR
S

O1

PU LAST = YES

R

O1

P
A

RTGxxA O1

A
A

<reference>

O1

N
A

FTGxx
A O1

A
A

<reference>



SG15939-64V400 Chapter 4 – Working with Ladder Logic Loops 

4-7 

4.2.3.9 Negated Coil --(NG)-- 
The NG coil sets the state of the coil reference TRUE 
when the left horizontal shunt not conducting and to 
FALSE when conducting. {The negated coil function is 
equivalent to a NOT function block having input A 
connected to the left horizontal shunt and the block output O1 associated with the coil 
reference.} 

4.2.4  Timers 
Timers are similar to coils. They copy the state of the left horizontal shunt to the right horizontal 
shunt without modification and store a state into a Boolean reference based on the state of the 
left horizontal shunt and the operation of the specific timer function. 

4.2.4.1 Retentive On Timer -- (ROT)-- 
The ROT changes its coil reference from FALSE to 
TRUE after the left horizontal shunt has been 
conducting for a time equal to or greater than the time 
setting, provided its associated EROT is conducting.  
Once the timer has been started, the elapsed time will 
be retained even if the left horizontal shunt returns to a 
not conducting state.  The elapsed timer will continue 
when the state returns to conducting.  The ROT must be 
used with an EROT (enable retentive on timer) having 
the same reference as the ROT but preceded by NOT (e.g. ROT is TIMER1 and EROT is 
NOTTIMER1).  During a warm or cold start of the controller, the reference will be initialized to 
FALSE and the elapsed timer will be initialized to 0.  {This function and its associated EROT 
corresponds to a ROT function block with the PU LAST set to NO, the left horizontal shunt 
connected  to the ON input,  and the D output corresponding to the reference. The left horizontal 
shunt of the corresponding EROT coil is connected to the EN input.} 

4.2.4.2 Enable Retentive On Timer --(EROT)-- 
The EROT changes its coil reference from FALSE to TRUE when the left horizontal shunt is 
conducting and its associated ROT is NOT TRUE. {This function and its associated ROT 
corresponds to a ROT function block with the PU LAST set to NO, the left horizontal shunt 
connected to the EN input,  and the DN output corresponding to the reference. The left 
horizontal shunt of the corresponding ROT coil is connected to the ON input.} 

4.2.4.3 Retentive On Timer (Memory) --(ROTM)-- 
The ROTM changes its coil reference from FALSE to 
TRUE after the left horizontal shunt has been conducting 
for a time equal to or greater than the time setting, 
provided its associated EROTM is conducting.  Once the 
timer has been started, the elapsed time will be retained 
even if the left horizontal shunt returns to a not 
conducting state.  The elapsed timer will continue when 
the state returns to conducting.  The ROTM must be 
used with an EROTM (enable retentive on timer) having 
the same reference as the ROTM but preceded by NOT (e.g. ROTM is TIMER2 and EROTM is 
NOTTIMER2).  During a warm start of the controller, the references and elapsed timer will be 
initialized to their previous values.  {This function and the matching EROTM corresponds to a 
ROT function block with the PU LAST set to YES, the left horizontal shunt connected to the ON 
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input,  and the D output corresponding to the reference. The left horizontal shunt of the 
associated EROTM coil is connected to the EN input.} 

4.2.4.4 Enable Retentive On Timer (Memory) --(EROTM)-- 
The EROTM changes its coil reference from FALSE to TRUE when the left horizontal shunt is 
conducting and its associated ROTM is NOT TRUE. {This function and its associated ROTM 
corresponds to a ROT function block with the PU LAST set to YES, the left horizontal shunt 
connected to the EN input,  and the DN output corresponding to the reference. The left 
horizontal shunt of the associated ROTM coil is connected to the ON input.} 

4.2.4.5 On-Delay Timer --(TON)-- 
The TON changes the coil reference from FALSE to 
TRUE after the left horizontal shunt changes from not 
conducting to conducting and has been conducting for a 
time equal to or greater than the time setting.  The 
reference will remain TRUE until the left horizontal shunt 
returns to a not conducting state.  During a warm start of 
the controller, the reference will be set FALSE, any elapsed time will reset to 0.0, and the timer 
will act on state of the left horizontal shunt during the first scan. {The TON function is equivalent 
to the DYT function block with the TYPE set  to ON, PU LAST set to NO, and the DLY TIME set 
to the time.}  

4.2.4.6 On-Delay Retentive (Memory) Timer --(TONM)-- 
The TONM changes the coil reference from FALSE to 
TRUE after the left horizontal shunt changes from not 
conducting to conducting and has been conducting for a 
time equal to or greater than the time setting. It will 
remain TRUE until the left horizontal shunt returns to a 
not conducting state.  During a warm start of the 
controller, the reference will be set to the last state, any elapsed time will be retained including 
that time accumulated during a power out condition.  The timer will act on the state of the left 
horizontal shunt during the first scan based on the state of the last scan prior to power out. {The 
TONM function is equivalent to the DYT function block with the TYPE set  to ON, PU LAST set 
to YES, and the DLY TIME set to the time.}  

4.2.4.7 Off-Delay Timer --(TOF)-- 
The TOF changes the coil reference from TRUE to 
FALSE after the left horizontal shunt changes from 
conducting to not conducting and has been in a not 
conducting state for a time equal to or greater than the 
time setting. It will remain FALSE until the left horizontal 
shunt returns to a conducting state.  During a warm start 
of the controller, the reference will be set FALSE, any elapsed time will reset to 0.0, and the 
timer will act on state of the left horizontal shunt during the first scan. {The TOF function is 
equivalent to the DYT function block with the TYPE set  to OFF, PU LAST set to NO, and the 
DLY TIME set to the time.}  
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4.2.4.8 Off-Delay Retentive (Memory) Timer --(TOFM)-- 
The TOFM changes the coil reference from TRUE to 
FALSE after the left horizontal shunt changes from 
conducting to not conducting and has been in a not 
conducting state for a time equal to or greater than the 
time setting and will remain FALSE until the left horizontal 
shunt returns to a conducting state.  During a warm start 
of the controller, the reference will be set to the last value, the elapsed time will retained 
including that time accumulated during a power out condition, and the timer will act on state of 
the left horizontal shunt during the first scan based on the state on the last scan prior to power 
out. {The TOF function is equivalent to the DYT function block with the TYPE set  to OFF, PU 
LAST set to YES, and the DLY TIME set to the time.}  

4.2.4.9 Timed Pulse Timer --(TP)-- 
The TP changes the coil reference from FALSE to TRUE 
when the left horizontal shunt changes from a not 
conducting to a conducting state and will remain TRUE 
for a period equal to the time setting regardless of the 
state of the left horizontal shunt. The timed pulse can not 
be retriggered until after the time expires.  During a 
warm start of the controller, the reference will be set FALSE, any elapsed time will reset to 0.0, 
and the timer will act on state of the left horizontal shunt during the first scan. {The TP function 
is equivalent to the OST function block with RETRIG set to NO, PU LAST set to NO, and the 
ON TIME set to the time.} 

4.2.4.10 Timed Pulse Retentive (Memory) Timer --(TPM)-- 
The TPM changes the coil reference from FALSE to 
TRUE when the left horizontal shunt changes from a not 
conducting to a conducting state and will remain TRUE 
for a period equal to the time setting regardless of the 
state of the left horizontal shunt. The timed pulse can not 
be retriggered until after the time expires.  During a warm 
start of the controller, the reference will be set to the last state, any elapsed time will retained 
including that time accumulated during a power out condition, the timer will continue timing, if 
time has not elapsed, and if elapsed will act on state of the left horizontal shunt during the first 
scan based on the state during the last scan prior to power out. {The TP function is equivalent to 
the OST function block with RETRIG set to NO, PU LAST set to YES, and the ON TIME set to 
the time.}  

4.2.4.11 Retriggerable Timed Pulse Timer --(RTP)-- 
The RTP changes the coil reference from FALSE to 
TRUE when the left horizontal shunt changes from a not 
conducting to a conducting state and will remain TRUE for 
a period equal to the time setting regardless of the state of 
the left horizontal shunt. The timed pulse can be 
retriggered if the left horizontal shunt changes from a not 
conducting to a conducting state during the timing period.  During a warm start of the controller, 
the reference will be set FALSE, any elapsed time will reset to 0.0, and the timer will act on the 
state of the left horizontal shunt during the first scan. {The TP function is equivalent to the OST 
function block with RETRIG set to YES, PU LAST set to NO, and the ON TIME set to the time.}  
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4.2.4.12 Retriggerable Timed Pulse Retentive (Memory) Timer --(RTPM)-- 
The RTPM changes the coil reference from FALSE to 
TRUE when the left horizontal shunt changes from a 
not conducting to a conducting state and will remain 
TRUE for a period equal to the time setting regardless 
of the state of the left horizontal shunt. The timed pulse 
can be retriggered if the left horizontal shunt changes 
from a not conducting to a conducting state during the timing period.  During a warm start of the 
controller, the reference will be set to the last state, any elapsed time will retained including that 
time accumulated during a power out condition, the timer will continue timing if time has not 
elapsed, and if elapsed will act on state of the left horizontal shunt during the first scan based on 
the state during the last scan prior to power out {The TP function is equivalent to the OST 
function block with RETRIG set to NO, PU LAST set to YES, and the ON TIME set to the time.}  

4.2.4.13 Repeat Cycle Timer --(RCT)-- 
The RCT changes the coil reference from FALSE to 
TRUE when the left horizontal shunt changes from a not 
conducting to a conducting state and will remain TRUE 
for a period equal to the on time. At the end of the on 
time the reference will go FALSE and remain FALSE 
until the off time expires.  It will continue to repeat this 
cycle as long as the left horizontal shunt is conducting. The reference will always be FALSE 
when the left horizontal shunt is not conducting.  During a warm start of the controller, the 
reference will be set FALSE, any elapsed time will reset to 0.0, and the timer will act on state of 
the left horizontal shunt during the first scan. {The RCT function is equivalent to the RCT 
function block with INPUT AT unconfigured, PU LAST set to NO, the ON TIME set to the on 
time, and the OFF TIME set to the off time.}  

4.2.4.14 Repeat Cycle Retentive (Memory) Timer --(RCTM)-- 
The repeat cycle retentive timer RCTM changes the coil 
reference from FALSE to TRUE when the left horizontal 
shunt changes from a not conducting to a conducting 
state and will remain TRUE for a period equal to the on 
time. At the end of the on time the reference will go 
FALSE and remain FALSE until the off time expires.  It 
will continue to repeat this cycle as long as the left horizontal shunt is conducting. The reference 
will always be FALSE when the left horizontal shunt is not conducting.  During a warm start of 
the controller, the reference will be set to the last value, any elapsed time will retained including 
that time accumulated during a power out condition, and the timer will act on state of the left 
horizontal shunt during the first scan. {The RCT function is equivalent to the RCT function block 
with INPUT AT unconfigured, PU LAST set to YES, the ON TIME set to the on time, and the 
OFF TIME set to the off time.}  
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4.3  Ladder Logic Design Example 
This section illustrates a typical controller ladder logic configuration using i|config.  The 
configuration consists of a function block loop and a ladder logic loop.  The function block loop 
contains the discrete I/O function blocks required to process the physical inputs and outputs to 
the station.  The ladder logic loop contains the ladder logic diagrams. 
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Figure 4-2  Loop function blocks 
 
 
 
 
Reference connections for function block DID01: 
 
Output O0: %FDF_Start_PB  Output O8: %Gas_Press_Lo 
Output O1: %FDF_Stop_PB  Output O9: %Gas_Press_Hi 
Output O2: %FD_Fan_Running  Output OA: %Gas_V1_Closed 
Output O3: %Air_Flow_LoLo  Output OB: %Gas_V2_Closed 
Output O4: %Drum_Level_LoLo  Output OC: %Oil_V1_Closed 
Output O5: %Oil_Temp_Lo  Output OD: %Oil_V2_Closed 
Output O6: %Oil_HdrPress_Lo  Output OE: %Start_Purge_PB 
Output O7: %Atom_Med_Hi  Output OF: %Reset_MFT_PB 
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Reference connections for function block DID02: 
 
Output O0: %Start_Ignitr_PB  Output O8: %Start_Gas_PB 
Output O1: %Burner_Flame  Output O9: %Stop_Gas_PB 
Output O2: %Start_Oil_PB  Output OA: %Gas_V1_NotOpen 
Output O3: %Stop_Oil_PB  Output OB: %Gas_V2_NotOpen 
Output O4: %Oil_V1_NotOpen  Output OC: %Vent_NotClosed 
Output O5: %Oil_V2_NotOpen  Output OD: %Master_Abort_PB 
Output O6: %RecircPmp_Stop_PB Output OE: % 
Output O7: %RecircPmp_Strt_PB  Output OF: % 
 
 
 
Reference connections for function block DOD01: 
 
Input 0: %FDF_Start   Input 8: %MFT 
Input 1: %Start_Purge   Input 9: %System_Alarm 
Input 2: %Purge_InProgress  Input A: % 
Input 3: %Purge_Complete  Input B: % 
Input 4: %Opn_Ig_Gas_Vlvs  Input C: % 
Input 5: %Open_Oil_Valves  Input D: % 
Input 6: %Close_Recirc  Input E: % 
Input 7: %Open_Gas_Valves  Input F: % 
 
 
 
Reference connections for function block ODS: 
 
Output LE: Model 353_Loop_Error 
 
 
 
The ODS can be used for displaying various operations within the ladder logic loops.  The 
Universal display provides more capability for this type of loop in that it will be able to display 
various messages.  See the description of the ODS function block for additional information.  
When a basic display is used it will normally display the loop tag.S and indicate the step number 
of the sequencer, if used.  If message inputs are configured and a basic display is used they 
can be viewed by pressing the D button to advance through the list of active messages.   
 
 
Other function blocks can also be used to provide Boolean inputs or outputs to the ladder logic 
elements.  For example, a pushbutton function block could be used to start or stop a logic 
operation.  The connections between these elements on the primary page are made by creating 
a reference for the inputs and outputs of these function blocks, similar to that above for the 
discrete I/O.  
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Figure 4-3  Graphical configuration of the first secondary page 
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Figure 4-4  Ladder to function block conversion for Figure 4-3 
 

Figure 4-4 is continued on next page. 
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Figure 4-4  Continued 
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Figure 4-5  Graphical configuration of the second secondary page 
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Figure 4-6  Ladder to function block conversion for Figure 4-5 
 

Figure 4-6 is continued on the next page. 
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Figure 4-6  Continued 
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4.4  Creating/Opening Ladder Logic Loops 
Creating ladder logic loops involves placing ladder logic elements onto the workspace and 
making the connections between the elements. 
 
! To create and name a ladder logic loop: 
 

Do one of the following to create a ladder logic loop: 
 

• Select Loop > New > Ladder Logic from the active station view. 
 

The Loop Name dialog will open.  The default name appears in the Enter Loop 
Name text box.  See Figure 4-7.  Type a meaningful name in the Enter Loop Name 
text box.  Click [OK].  A ladder logic icon is created and placed in the tree control. 

 

 
 

Figure 4-7  Loop Name dialog 

OR 

• Click the [Ladder Logic Loop] button on the 353 Objects Toolbar.    A ladder 
logic loop icon is constructed and placed in the tree control with a default name for 
the loop name. 

 
To edit the default name, click the loop name in the tree and, after a short pause, 
click the name again to highlight the name. Type a meaningful name. 

 
Note: The name must be unique in that loop. No other loop can have the same 
name in the same controller.  The maximum number of characters is 12. 

 
! To open a ladder logic loop: 
 

Do one of the following to open a ladder logic loop: 
 

• From the tree control, select the loop icon and then select Loop > Open. 

OR 

• Right-click on the ladder logic loop icon and, from the pop-up menu, select Open. 

OR 

• From the tree control, double-click on the ladder logic loop. 
 

The loop opens and the ladder logic loop is displayed. 
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4.5  Describing Ladder Logic Elements 
Ladder logic elements are comprised of inputs, outputs, references, and element names.  Inputs 
appear on the left side of the element, outputs appear on the right side.  All ladder logic inputs 
and outputs are of the digital type. 
 
Note: The right side of a coil is not an output. Refer to Section 4.2 for detailed element 
descriptions. 
 
The industry standard images that make up a ladder logic element cannot be modified.  There 
are two types of ladder logic elements.  

• Contacts  

• Coils 

4.5.1  Contacts 
Contacts have a reference to which they connect.  They take inputs, perform a logic operation, 
and send the result to another contact or a coil.  Contacts are identified by straight vertical lines. 
 
The name of the contact (e.g. NOC, NCC) is not shown on the element.  The text above the 
contact represents the reference to which it is connected.  See Figure 4-8. 
 

 
Figure 4-8  Contact 

4.5.2  Coils 
A coil creates a fixed value reference, which represents its output. A coil is identified by 
parenthesis.  Some coils have a name that appears within the parenthesis.  The text above the 
coil represents the fixed reference assigned to the coil.  See Figure 4-9 where an On-Delay 
Retentive (Memory) Timer (TONM) is shown. 
 

 
Figure 4-9  Coil 

 
Most coils exist as a single ladder logic element.  However, Set Coil and Reset Coil are 
combined to make a Set-Reset Coil, and Set Memory Coil and Reset Memory Coil are 
combined to make a Set-Reset Memory Coil.  When one of these coils is place on a rung, two 
coils are placed on two consecutive rungs in the same column.  See Figure 4-10. 
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Figure 4-10  Set-Reset Memory Coil pair 

 
Initially, a default reference name is displayed above each contact or coil.  The default name 
can be changed by the user to a more meaningful name.  See Chapter 8 Using the Edit Menu 
for more information on changing reference names. 

4.5.3  Ladder Logic Pages 
Each ladder logic loop has four pages of workspace on which to place ladder logic elements.  
The current page displays in the view title.  See Figure 4-11. 

 
 

Figure 4-11  Current page in window title 
 
! To view ladder logic pages: 
 

Select View > Ladder Logic Pages > Ladder Logic Page #.  The selected logic page is 
displayed.   
 
Note:  All ladder logic elements connected by lines must reside on the same page.  
Elements can not be connected from one page to another. 
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4.5.4  Power Rail 
The left side of each page is a power rail which represents the starting point for each rung of 
logic.  The power rail has 38 connection points (rungs) on each page.  A ladder logic element 
can be placed anywhere on a page to the right of the power rail.  See Figure 4-12. 
 

 
 

Figure 4-12  Power rail 

4.6  Placing Ladder Logic Elements 
Each ladder logic element can be placed multiple times in a loop.  Ladder logic elements are 
described in detail in Section 4.2 Ladder Logic Elements.   
 
! To place any ladder logic element: 

1. Click the [New Ladder Logic Element] button on the Line Connection toolbar.    
The Select Item to Create dialog displays.  See Figure 4-13. 

 

 
 

Figure 4-13  Select Item to Create dialog 

2. Select the ladder logic element to create.  Click [OK]. 
 

Note: The dotted outline of the element floats with the cursor until it is placed as 
described in the next step. 
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3. Move the cursor to a valid location on the ladder and click to place the ladder logic 
element.  The element displays on the ladder logic view. 

 
Note:  To place the element on an area of the workspace not presently viewed, move 
the cursor to the workspace boarder. The view automatically scrolls, keeping the 
element visible within the workspace.  If the cursor displays as a not allowed symbol 
(∅), the placement is not valid. 

 
! To place basic ladder logic elements: 

1. Click the desired element [NO Contact], [NC Contact], or [Coil] button on the Line 
Connection toolbar.  

2. Move the ladder logic element to a valid location on the ladder and click.  The element 
displays on the ladder logic view. 

 
! To place ladder logic elements multiple times consecutively: 

1. Click the [Multiple Create] button on the Line Connection toolbar.   

2. Repeat the previous steps until all ladder logic elements are placed. 
 

Note: To stop placing ladder logic elements, any time during the procedure, press <Esc> 
or click [Cancel].  

4.7  Viewing Loop Resources 
The Loop Resources Information dialog displays the number of function blocks available to 
place.  One ladder logic loop supports up to 250 function blocks.  A ladder logic element can 
have zero, one, or two function blocks associated with it, so resource usage is not necessarily 
one logic element to one function block.  In other words, the Loop Resource Available toolbar 
shows the number of function blocks available, not the number of ladder logic elements.   
 
! To view loop resources: 

1. Do one of the following to view loop resources. 
 

• Select Tools > Loop Resources from the menu. 

OR 

• Click the [Available Block Information] button on the Loop Resources 
Available toolbar.    The Loop Resources dialog displays.  See Figure 4-14. 

2. View the information.  Click [OK]. The dialog closes. 
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Figure 4-14  Loop Resources Information dialog 
 

4.8  Editing Ladder Logic Attributes 
The Item Attributes dialog allows you to change some parameters of ladder logic elements.  
Only numeric parameters can be changed.   
 
The attributes of the following function block elements can not be changed. 
 

Coils:  --(C)--, --(M)--, --(N)--, --(NG)--, --(P)--, --(S/R)--, --(SM/SR)— 
 

Contacts: (all)  --|  |--, --|/|--, --|N|--, --|P|-- 
 
! To edit ladder logic elements: 
 

Do one of the following to open the Item Attributes dialog. 
 

• Select the ladder logic element, then select Edit > Item Attributes. 

OR 

• Select the ladder logic element, then click the [Edit Item Attributes] button on the 
Graphic Primitives toolbar.    

OR 

• Select the ladder logic element, then click the [Line Connection Attributes] 
button on the Line Connection toolbar.    

OR 

• Right-click the ladder logic element and, from the pop-up menu, select Edit Item 
Attributes. 

OR 

• Click the [Selection Mode] button   on the Graphics Primitives toolbar, and 
double-click the ladder logic element. 

OR 

• Click the [Line Connection Selection Mode] button  on the Line Connection 
toolbar, then double-click the ladder logic element. 
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The Item Attributes dialog displays.  See Figure 4-15. 

4.8.1  Numeric Parameters 
A numeric parameter is a number value for a parameter.  Values are entered in the New Value 
text box.  The Information list box indicates the number type and the range of numbers available 
for the parameter.  See Figure 4-15. 
 

 
 

Figure 4-15  Item Attributes dialog to edit numeric parameter 
 
! To edit numeric parameters: 

1. In the Item Attributes dialog, select a numeric parameter on the Parameter List. 

2. Enter a value, within the valid range, in the New Value text box. 

3. Click [Accept].  The new value is entered in the Parameter List. 

4. Click [OK].  The change stores in the configuration. 

4.9  Connecting Ladder Logic Elements on the Same Page 
Connection lines are created using the Line Connection Mode button on the Line Connection 
toolbar.  Line connections can only be made between logic elements on the same page.  Line 
connections can not be made to logic elements on other pages or loops.   
 
There are five ways to make a line connection: 

• Click an input and then click on an output. 

• Click an output and then click an input. 

• Click an input or output and then click a connection line. 

• Click a connection line and then click another connection line. 

• Click a connection line and then click an input. 
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! To connect ladder  logic elements: 

1. Click the [Line Connection Mode] button  on the Line Connection toolbar.  The 
cursor changes to a wire spool. 

2. Click a valid starting point. 
 

Note: The cursor displays as a spool with a plus (+) sign when it is over a valid 
connection point.  The cursor displays as a spool with a not allowed symbol (∅) 
when the connection location is not valid. 

3. Move the cursor to a valid connection point 

4. Click a valid ending connection point.  A connection is made and is represented as a 
line. 

 
Note: Press <Esc> at any point, when creating a connection line, to cancel the operation. 

4.9.1  Manual vs. Auto-Routed Connection Lines 
The connection line between two elements is the line connection path.  Line connection paths 
represent logic connections between inputs and outputs.  i|config can create two types of 
connection lines. 

• Auto-routed connection lines 

• Manual-routed connection lines 

Auto-routed connection lines are generated when the spool tool is used to directly connect an 
input to an output.  Auto-routed lines are solid and are auto-routed by the application to form a 
path between an input and output. See Figure 4-16. 
 

 
 

Figure 4-16  Auto-routed and Manual-routed lines 
 
Manual-routed lines are created when the user clicks the Line Connection Mode button, clicks 
an input or an output and then clicks the workspace one or more times while routing the line 
between the input and output connection points.  Manual-routed lines are dotted and have auto-
routed fixed line segments between each click. 
 
Connection lines can go anywhere on the workspace except through ladder logic elements.  If 
connection lines cannot be routed, no connection is possible.  If this situation occurs, a manual-
routed connection line must be made, or a ladder logic element must be moved, so that a 
connection line can be routed. 



SG15939-64V400 Chapter 4 – Working with Ladder Logic Loops 

4-27 

4.9.2  Connection Dots 
Where a connection line terminates at another line, a connection dot is visible on the line.  A 
connection dot is the point at which lines connect to each other, rather than where they cross.  
See Figure 4-17. 
 

 
Figure 4-17  Line crossing and line connection 

 
Whenever two or more outputs connect to the same input, one or more OR gates are present.  
This is indicated by an “X” displayed over the connection dot.  
 
Note: OR gates are provided automatically as you connect logic elements. 

4.10  Making Connections to References 
Use the Set Reference dialog to make connections to references.  This dialog displays all 
references in the current configuration.  In this dialog you can choose either a fixed value 
reference or a user-defined reference.  See Section 2.16 References for more information. 
 
! To assign a reference to a contact: 

1. Click the [Line Connection Mode] button on the Line Connection toolbar.    The 
cursor changes to a wire spool. 

2. Right-click the reference name above the contact.  The Set Reference dialog displays.  
See Figure 4-18. 

 

 
 

Figure 4-18  Set Reference dialog 
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Connect, OR 
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3. Do one of the following: 
 

• Select the reference.  Click [OK]. 
OR 

• Double-click the reference. 
 

The reference is assigned to that contact.  The user can edit references by clicking on 
the Edit Refs button on the Set Reference dialog.  See Chapter 2 Working with the 
Station View for further information. 

4.11  Changing Reference Names on Coils 
A coil creates a fixed value reference. This means that only the coil name can be changed, not 
its value. 
 
! To change a coil’s reference name: 

1. Click the [Line Connection Mode] button on the Line Connection toolbar.    The 
cursor changes to a wire spool. 

2. Right-click the reference name above the coil the Create/Modify References dialog 
displays.  See Figure 4-19. 

 

 
 

Figure 4-19  Create/Modify References 
 

3. Enter a new reference name in the Reference Name text box. 
 

Note: Use a unique name for each reference in a controller configuration.  A 
maximum of 16 characters is allowed.   

4. Click [OK].  The reference is saved in the configuration. 
 

The coil reference name can also be changed using the Edit References dialog.  See 
Chapter 2 Working with the Station View, for further information.   
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4.12  Viewing Connections 
Connections are displayed via the Connection Info dialog.  This dialog displays a list of 
connections for the selected input or output, and it indicates if the connections are also on 
another loop.  This list does not show ladder logic elements, only the internal function blocks. 
 
! To view input or output connections: 

1. Click the [Line Connection Mode] button on the Line Connection toolbar.    The 
cursor changes to a wire spool. 

2. Right-click a ladder logic element input or output and, from the pop-up menu, select 
Show Connections.  The Connection Info dialog displays a list of inputs and outputs 
showing the loop/block/input or output connections.  See Figure 4-20. 

 

 
 

Figure 4-20  Connection Info dialog 
 

3. View the information.  Click [Close].  The dialog closes. 

4.13  Editing Connection Lines 
Connection line color and background can be changed. Lines cannot be moved or sized.   
 
! To edit connection lines: 

1. Do one of the following: 
 

• Click the [Line Connection Attributes] button on the Line Connection toolbar.  
 

OR 

• Click the [Line Connection Selection Mode] button on the Line Connection 
toolbar.    Double-click on the workspace. 

 
The Item Attributes dialog displays.  See Figure 4-21. 
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Figure 4-21  Item Attributes dialog 
 

2. Select the Line Connection tab, if not already selected. 
 

As desired, select different line colors.  Or, select an opaque background for manual-
routed lines by clicking the Opaque Background check box. Refer to the procedure for 
selecting a color in Section 6.7.14.1 Custom Colors. 

3. Click [OK] save changes or click [Cancel] to discard changes.  The modification of the 
line connection attributes display in the ladder logic loop. 

4.14  Deleting Connection Lines 
Deleting a connection line removes the connection that the line represents. 
 
! To delete a connection line: 

1. Do one of the following: 
 

• Click the [Line Connection Selection Mode] button on the Line Connection 
toolbar.     

OR 

• Click the [Selection Mode] button on the Graphic Primitives toolbar.   

2. Do one of the following to start the delete process. 
 

• Select the line, then select Edit > Delete from the menu.  

OR 

• Select the line, then press <Delete>. 

OR 

• Right-click the line and, from the pop-up menu, select Delete. The connection line 
is removed from the configuration. 



SG15939-64V400 Chapter 4 – Working with Ladder Logic Loops 

4-31 

4.15  Moving Ladder Logic Elements 
A ladder logic element with or without connection lines can be moved. If that element has 
connection lines, they will be erased and will need to be redrawn.  As with function blocks, a 
ladder logic element cannot be moved on top of another element or a connection line.  Select a 
ladder logic element to be moved with the Line Connection Selection Mode tool. 
 
Refer to Section 3.3 Placing Function Blocks for further information. 
 
! To move a ladder logic elements: 

1. Click the [Line Connection Selection Mode] button on the Line Connection toolbar.  
   

2. Click the selected ladder logic element, drag it to a valid location, and release the 
mouse button. The element displays in the new location. 

 
Note: The cursor displays as a spool with a plus (+) sign when it is over a valid 
connection point.  The cursor displays as a spool with a not allowed symbol (∅) 
when the connection location is not valid. 

4.16  Deleting Ladder Logic Elements 
Deleting a ladder logic element removes all connections to the element and all function block 
parameters associated with the element. 
 
Deleting a coil also deletes the coil’s reference(s).  If any contact or function block digital input is 
connected to the reference, when the coil is deleted, the function block digital input becomes 
unconfigured. 
 
! To delete a ladder logic element: 

1. Do one of the following: 
 

• Click the [Line Connection Selection Mode] button on the Line Connection 
toolbar.     

OR 

• Click the [Selection Mode] button on the Graphic PrimitivesPrimitives toolbar.  
 

2. Do one of the following to start the delete process. 
 

• Select the ladder logic element, then select Edit > Delete from the menu.  

OR 

• Select the ladder logic element, then press <Delete>. 

OR 

• Right-click the ladder logic element and, from the pop-up menu, select Delete. 
 

The deletion confirmation dialog displays.  See Figure 4-22. 
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Figure 4-22  Delete Confirmation message 
 

3. Click [Yes].  The connection line is removed from the configuration. 

4.17  Execution Sequence 
The Execution Sequence Number (ESN) determines the order in which the ladder logic 
elements are executed.  The ESN is determined by the X, Y location of the elements.  The top 
left point of each ladder logic element is used in determining the sequence. 
 
The system automatically assigns a number when the user saves or downloads the active 
configuration to the controller.  If the system is unable to assign a sequence number to all ladder 
logic elements, it will not download the configuration.   
 
If a connection dot has an OR gate and has four or more lines associated with it, multiple 
sequence numbers are associated with the dot. 
 
Note:  Minimize adding connection lines that create OR gate connections. This can be done by 
creating several simpler ladder logic loops of one page each instead of building one complex, 
multiple page view.  
 
The user cannot modify the execution sequence manually.  The sequence can be viewed in the 
Function Blocks Parameters report view.  See Section 2.13.1 Function Block Parameters for 
further information. 
 
Execution sequence numbers are assigned top to bottom, left to right, as follows: 

" First page, power rail, top to bottom. 
" Second page, power rail, top to bottom. 
" Third page, power rail, top to bottom. 
" Fourth page, power rail, top to bottom. 
" First page, first column, top to bottom. 
" Second page, first column, top to bottom. 
" Third page, first column, top to bottom. 
" Fourth page, first column, top to bottom. 
" First page, second column, top to bottom. 
" Second page, second column, top to bottom. 
" Etc. 
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4.18  Printing Ladder Logic Loops 
There are various options from which to choose. 

• Screen 

• Active Window – Current View 

• Active Window – Entire View 

• Active Window – 1 to 1 

 
If either the Active Window – Entire View or Active Window – 1 to 1 is selected, all four 
ladder logic view pages are printed.  For more information on printing, see Section 7.10 Print. 
 
! To print a ladder logic loop: 

1. Open the loop to be printed. 

2. Select File > Print Options > Desired Option. 

3. Do one of the following: 
 

• Select File > Print. 
OR 

• Click the [Print] button   on the Standard toolbar. 

OR 

• Press <Ctrl+P>. 
 

The Print dialog displays.  See Figure 4-23. 
 

 
 

Figure 4-23  Print dialog 
 

4. Make changes to the dialog, if necessary. 

5. Click [OK].  The selected option is sent to the printer. 
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Chapter 5 - Communicating with the Controller 
Network communications must be established between a PC running i|config™ and a controller 
to download a configuration to a controller or upload a configuration from a controller.  This 
chapter describes how to configure PC and controller communication ports and how to transfer 
data between PC and controller.  
 
Four communication protocols are available.  

• MODBUS (Front Port) – Select when the PC is connected to the controller’s RS232 
communication port: 

Model 353: MJ11 jack on controller faceplate 

i|pac and Model 353R: P1 on the Control Carrier 
 
PC port settings must match those in the controller’s STATN – Station Parameters function 
block. 

• MODBUS (Rear Port) – Select when the PC is connected to the controller’s RS485 
communications port (a user-supplied RS232 to RS485 communication protocol converter 
may be needed): 

Model 353: Terminals NCA and NCB on controller rear terminals 

i|pac and Model 353R: Terminals NCA and NCB on the Control Carrier 
 
PC settings must match those in the controller’s STATN – Station Parameters function 
block. 

• ICI320 – Select when the controller’s optional LIL (Local Instrument Link)  communications 
will be used to transfer the configuration – requires that a LIL Network Board be installed in 
the controller.  All settings in the Communication Configuration dialog are configurable and 
must match the settings in the Model 320 ICI.  See Application Document AD320-10 Model 
320 Local Instrument Link Independent Computer Interface User’s Manual for more 
information on the Model 320 settings. (For a PDF of AD320-10, go to 
https://www.sea.siemens.com/instrbu/docs/pdf/ad320-10.pdf). 

• Ethernet – Select when the controller includes Ethernet communications and an IP address 
has been entered in the controller’s Ethernet function block. See Section 5.2. 

Model 353: Ethernet connector in case rear terminal assembly 

i|pac and Model 353R: Ethernet connector is P4 on the control carrier 
 
MODBUS and ICI 320 procedures are furnished in Section 5.1 below. The Ethernet procedure 
is provided in Section 5.2. Procedures to perform a configuration download to, or upload from, a 
controller are in Sections 5.3, 5.4 and 5.5. Grayed selections in the communications dialog box 
are preset and need not be changed. 
 
The communication parameters found in the controller STATioN and ETHERNET function 
blocks can be edited by right-clicking the station icon                      in the station view. See 
Figure 5-1. 
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Figure 5-1  Station/Loop Attributes dialog 

5.1  PC Serial Port Configuration 
! To configure the serial communication port: 

1. From the Menu Toolbar, select Communications > Configure. The Communication 
Configuration dialog displays. See Figure 5-2. 

 

 
 

Figure 5-2  Communication Configuration dialog 
 

2. Select the Port drop down menu and select the desired Com port. 

3. Select the Protocol menu and select the needed communications protocol.  
• MODBUS (Front Port) 
• MODBUS (Rear Port) 
• ICI320 

4. Do one of the following: 
 

MODBUS selected above – Select the Baud Rate menu and select a baud rate from 
the list that matches the controller baud rate. 
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ICI320 selected above – Select the needed ICI 320 communication settings from the 
drop down menus. 
• Baud Rate 
• Data bits 
• Start/Stop bits 
• Parity 

5. Click [OK]. The communication changes are saved and will be used for all future 
communications, until the communication port is changed. 

5.2  PC Ethernet Port Configuration 
Ethernet communication can be used to transfer configurations if the controller has Ethernet 
communications available and a valid IP address has been entered into the controller.  See the 
“ETHERNET” function block section in the controller User’s Manual for more information on 
setting the addressing of the controller. 
 
Note: The IP address in the Ethernet tab of the Station/Loop Attributes dialog block must 
match the IP address in the Ethernet function block in the controller. 
 
! To set Ethernet Communications: 

1. Select Communications > Configure from the menu. 

2. Select the Port drop down menu.  

3. Select Ethernet. 
4. Click [OK].  The communication changes are saved and will be used for all future 

communications, until the communication port is changed. 

5.3  Downloading to the Controller 
After creating a configuration, the next step is to download it to the controller. 
 
A configuration is made up of two files: a graphic file with a .353 extension and a database file 
with a .V3C extension.  Only the .V3C file is downloaded to the controller.  However, both files 
are saved as a pair in the PC and both can be saved to a MultiMediaCard.  
 
! To download a configuration: 
 

Click < File > Download in the Menu Bar and select one of the following. 
• Current Station Configuration 
• Download From File 

 
See the subsections below for descriptions of the above selections. 

5.3.1  Current Station Configuration 
This option downloads the configuration that is presently open in i|config.  If the configuration 
contains any ladder logic loops, the system assigns Execution Sequence Numbers (ESN) 
before the download starts.  If the ESN assignment fails for any reason, the configuration can 
not be downloaded or saved.  See Section 4.17 Execution Sequence for more information on 
the assignment of ESN numbers. 
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Always save the configuration before downloading it to the controller. Also be sure that the 
configuration and controller have the same Database Revision Number. 
 
! To download the active configuration: 

1. Save the configuration. 
 

IMPORTANT: The configuration file name is stored in the station when it is 
downloaded.  If the configuration is not saved at least once before the download, it 
will not be possible to merge the data with a graphic file when you upload.   

2. Select File > Download > Current Station Configuration. The download caution 
message in Figure 5-3 will appear. Read the message, click [OK], and take 
appropriate steps to avoid a process upset. Note that the configuration downloaded in 
step 5 will become the active configuration in the selected controller. 

 

 
 

Figure 5-3  Download caution message 

3. Select the communication port to use for downloading the configuration from the drop 
down menu in the Station Selection dialog.  See Figure 5-4.  

 

 
 

Figure 5-4  Station Selection dialog 
 

Note: See Section 5.1 Serial Port Configuration or Section 5.2 Ethernet Port 
Configuration for more information if the port needs to be configured. 
 
A message similar to that shown in Figure 5-5 will appear if a PC port configuration 
setting (e.g. baud rate, IP address) differs from the equivalent setting in the 
configuration to be downloaded. 
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Figure 5-5  Parameter disagreement message 

4. When downloading to a controller (station) on Ethernet, MODBUS (Rear Port), or LIL, 
an additional dialog must be opened in order to select the specific station address if 
you can not enter it in the Station Selection dialog   

 
• For MODBUS (Rear Port) or LIL, select the Browse button to view the stations on 

the multi-drop network.  After polling the multi-drop network for available 
controllers, a Station List dialog (See Figure 5-6) will open. Select the desired 
controller from the list. 

 

 
 

Figure 5-6  Station List dialog 
 

• For Ethernet, select [OK] on the Station Selection dialog. The system will query 
the Ethernet network using UDP (User Datagram Protocol) to determine the 
Procidia controllers present and will list them by IP address and station tag on the 
Procidia Selection dialog.  Select the desired controller from the list.  If the dialog 
does not list any controllers but you know one is present you can enter the IP 
address manually in the top text box.  See Figure 5-7. 
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Figure 5-7  Procidia Selection dialog 

5. Click [OK].  The configuration downloads to the controller. 

5.3.2  Downloading From File 
This option downloads a file from a disk (e.g. hard drive) directly to a controller.  Download From 
File, transfers the database .V3C file directly to a controller. 
 
Be sure that the configuration and controller have the same Database Revision Number. 
 
! To download a configuration from a file: 

1. Select File > Download > Download From File. The download caution message 
similar to that in Figure 5-8 will appear. Read the message, click [OK], and take 
appropriate steps to avoid a process upset. Note that the configuration downloaded in 
step 5 will become the active configuration in the selected controller. 

 

 
 

Figure 5-8  Download caution message 
 

2.  The Select Database dialog is displayed.  See Figure 5-9. 
 



SG15939-64V400 Chapter 5 – Communicating with the Controller 

 5-7

 
 

Figure 5-9  Select Database File dialog 

3. Do one of the following: 
 

• Select the database file to download, and then click [OK]. 
OR 

• Enter file name in the File Name text box, and then click [OK].  
OR 

• Double-click on the file name. 
 

The Select Station to Download dialog displays, from which you can select the port to 
use for downloading. 

4. Select the communication port to use for downloading the configuration from the drop 
down menu in the Station Selection dialog. See the previous method for downloading 
the active configuration for more steps necessary when downloading to multi-drop 
stations on MODBUS (Rear Port), LIL, or Ethernet.  

 
A message similar to that shown in Figure 5-10 will appear if a PC port configuration 
setting (e.g. baud rate, IP address) differs from the equivalent setting in the 
configuration to be downloaded. 
 

 
 

Figure 5-10  Parameter disagreement message 
 

5. Click [OK].  The configuration downloads to the controller 
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5.4  Uploading from the Controller 
The database file path and extension are not stored in the controller.  Because only the 
database file is downloaded to the controller, the upload path must be set to the directory where 
the graphic file is stored so the two files can merge during the upload.  
 
! To set the upload path: 

1. Select Tools > Upload File Path.  The Options dialog displays.  See Figure 5-11. 
 

 
 

Figure 5-11  Options dialog 
 

2. In the File tab, enter the desired upload path, if it is not currently displayed in the text 
field. 

 
Note: If a merge with the stored configuration is NOT desired, create a new folder 
and select it as the upload destination. 

3. Click [OK].  The upload path is accepted.  The Options path dialog closes and the 
selected path is used when uploading the configuration.  

5.4.1  Upload 
This option uploads a database from a controller and displays it within i|config.  
 
If the database that is being uploaded from the controller has a configuration file associated with 
it on the PC, i|config will attempt to merge the database with the graphic file on the PC.  If the 
database can be merged with the one on the PC, the existing database file on the PC will be 
updated to reflect the parameter values of the uploaded database.  Merging of an uploaded 
database will not be permitted if any of the following modifications were made to the controller 
configuration: 

• A loop was added or deleted from the controller. 

• A block was added or deleted from a loop. 

• Any input to any block in any loop was changed. 
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If the uploaded database can not be merged with an existing graphic file on the PC, i|config will 
attempt to auto-draw the graphic configuration.  When a configuration is auto-drawn: 

• A station view will be created to hold the names of all the loops found in the uploaded 
configuration. 

• For each function block loop that is found, a function block view will be created. 

• A ladder logic view will be redrawn as its function block equivalent rather than a view with 
ladder logic elements. 

As a function block view is created, all function blocks that belong to the loop will be auto-drawn 
by the system and placed on the loop view.  Placement of the function blocks on the loop view 
occurs as followings. 

• Display blocks (e.g. ODC, ODP) are drawn in the lower left corner of the view. 

• SETPT, ALARM, PID, AM blocks are drawn at the center of the view. 

• Input blocks are drawn on the left side of the view. 

• Output blocks are drawn on the right side of the view. 

• All other blocks are drawn where view space is available. 

i|config will not generate connection lines between function blocks when it auto-draws a 
configuration.  To quickly establish connection lines, after function blocks have been 
repositioned according to the users needs, use the Automatic Line connection button on the 
Line Connection toolbar.  See Section 6.4.3 Automatic Line Connection for details. 
 
! To upload: 

1. Select File > Upload. The Select Station dialog displays; see Figure 5-12.  

 
 

Figure 5-12  Select Station to upload from dialog 

2. Select the communication port to use for uploading the configuration from the drop 
down menu in the Station Selection dialog. See the previous method for downloading 
the active configuration for more steps necessary when downloading to multi-drop 
stations on MODBUS (Rear Port), LIL, or Ethernet. 

3. Click [OK].  The configuration will upload from the controller. 
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If the uploaded configuration is merged with a configuration on the PC, the 
configuration is updated on the disk. 
 
If the merge fails, a message is displayed stating that a merge failed during the upload. 
 
If there is no configuration on the PC for the uploaded configuration to merge with8, 
i|config will auto-draw the graphic view(s) for the uploaded database.  When the auto-
draw process is complete, the user can select File > Save to save the uploaded 
configuration to disk. 
 

! To save a new configuration after a failed merge: 

1. A message box is displayed stating that a merge has failed.  You are asked if you want 
to save the uploaded database to another file. 

2. Click [Yes].  The new database is auto-drawn by i|config.  When the auto-draw process 
is complete, select File > Save to save the uploaded configuration to disk. 

 
IMPORTANT:  Be careful not to save the uploaded database to an existing database 
file that has an associated graphics file (.353).  If the file to be uploaded differs in 
any way that might make the Upload/Merge process fail, as described previously, the 
graphics file corresponding to the saved database is invalid.  Attempting to open that 
graphics file will cause unpredictable results.   

5.5  Station Selection 
The Select Station to download to dialog displays in all download procedures and the Select 
Station to upload from dialog displays in all upload procedures. Use these dialogs to select the 
proper communication port and station address to download to, or upload from, a specific 
station. See Figure 5-13. 
 

 
 

Figure 5-13  Select Station dialog 
 
If the address of the station is not configured, the user can configure it from either dialog. 
                                                 
8 This will be the case when: the configuration was created at a controller faceplate; or the configuration being 
uploaded was created in i|config but was saved to a folder other than the default folder; see Figure 5.11; or the 
configuration’s graphic content was edited at the controller faceplate. 
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! To configure the PC port: 

1. From the Station Selection dialog, click [Configure Port]. The Port Configuration 
dialog displays. 

2. Use the drop-down menus to configure the ports. The PC port configuration must 
match the controller communication configuration in the STATN - Station Parameter 
function block or Ethernet function block. 

3. Click [OK]. The communications configuration is saved and is used hereafter until you 
reconfigure the port communications. The address fields appear differently, depending 
on the driver selected for the port. 
• ICI320 - the HLL and LIL address of the unit must be specified 
• MODBUS (Rear Port) - the MODBUS address of the unit must be specified 
• MODBUS (Front Port) - the station address is always 1 and, therefore, need not be 

specified 
 
The address of the station may not be evident, in which case the user can choose to view a 
list of stations connected to a particular communication port. This list is available in the 
Station Name Selection dialog. This dialog displays a range of station addresses, which 
can be incremented or decremented as desired. Once the correct address displays on the 
list, the user can automatically configure those fields in the Station Selection dialog. 
 
If the driver is MODBUS (Front Port) or MODBUS (Rear Port), the address range is listed. If 
the driver is ICI320, the HLL address is listed. 
 

! To view the stations connected to the selected communication port and configure 
fields in the Station Selection dialog: 

1. From the Station Selection dialog, click [Browse]. 
 
The Station Name Selection dialog, with a range of station names and addresses, 
displays. 
 

2. If the correct station name and address do not display, click [Next] or [Previous]. 
 

The next or previous range of station names and addresses display. 

3. Repeat step 2 until the correct station name and address displays on the list. 

4. Do one of the following: 
 

• Select the station to communicate with. Click [OK]. 
OR 

• Double-click on the station name. 
 
The Station Name Selection dialog closes and the appropriate address fields are populated in 
the Station Selection dialog. 
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5.6  i|config Actions During Download or Upload 
Before downloading to the station, the software performs the following operations: 

• Retrieves the current station status and displays it in the download confirmation dialog 

• Disables the [OK] button on the confirmation dialog if a download is not allowed with the 
current station status 

If this occurs, use [Cancel] to close the dialog. If the station status allows a download, press 
[OK] to download the file. 

 
Before uploading from the station, the software performs the following operations: 

• Retrieves the current station error status and displays it in a dialog 

• Disables the [OK] button on the dialog if an upload is not allowed. If this occurs, use 
[Cancel] to close the dialog. If no errors are present, the upload proceeds immediately with 
no confirmation. 

5.7  Monitor Mode 

  The Monitor Mode button is used to populate a displayed function block or ladder logic 
loop with the live variables from the 353 that is running the displayed loop. Figure 5-14 shows 
the variables highlighted in yellow. The PC to 353 communication requirements stated earlier in 
this chapter must be met. 
 

 
 

Figure 5-14  Function block loop with 353 live variables 
 
! To monitor live variables: 

1. Open the function block or ladder logic loop that is to be monitored.  

2. Click the Monitor Mode button to display the dialog in Figure 5-13. Select the Station 
and Port as described earlier in this chapter. 
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Figure 5-15  Station Selection dialog 
 

3. As needed, zoom in on the loop to allow the live variables to appear. Variables will 
appear when the display is zoomed to a size that permits reading. 
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Chapter 6 - Using the Toolbars 
i|config™ toolbars are shown in Figure 6-1.  Each toolbar is a series of buttons that provide 
quick access to an i|config function.  All toolbars display the first time i|config is installed and 
run.  Individual toolbars, or all toolbars, can be toggled on and off as desired. 
 
 
 
 
 
 
 

 
 
 
 
 

Figure 6-1  Toolbars 
 
! To toggle the display of the toolbars: 
 

1. Select View > Toolbars. The Toolbar dialog displays.  See Figure 6-2. 
 

 
 

Figure 6-2  Toolbars dialog 
 

Station 
Resources 

Alignment Toolbar 

Graphic Operations 
Toolbar 

Ladder Logic 
Toolbar 

353 Objects 
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Line Connection 
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Standard Toolbar Graphic Primitives Toolbar 
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Monitor 353 
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Title Bar Menu Toolbar 
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2. Click the check box for the toolbar to toggle on or off.  If an X displays in the check box, 
the corresponding toolbar will be displayed. 

3. Click [Close].  The Toolbars dialog closes. 
 

Note:  Toolbars can be placed in any location by clicking on the grey area of the toolbar 
and dragging it to a new location. 

6.1  Using the Standard Toolbar 
The Standard toolbar, shown in Figure 6-3 includes buttons that are used to manipulate a file.  
 

 
 

Figure 6-3  Standard toolbar 

6.1.1  New 

  The New button creates a new configuration.  This button is available in all views. 
 
! To create a new configuration: 

1. Click the New button on the Standard toolbar.  The Database Revision dialog displays. 
See Figure 6-4. 

 

 
 

Figure 6-4  Database Revision dialog 
 

2. Select the database revision level desired. 
 
Note: If the configuration will be downloaded to several controllers that have 
different database (firmware) revisions, choose the lowest database revision in the 
group of controllers. Create the configuration and save it. Use i|config to upgrade 
the configuration to the higher revision level (File > Upgrade to). Save the upgraded 
configuration with a different file name for use in a controller with the higher 
database revision level.  

 

3. Click [OK].  The new configuration opens at the Station view using a default station 
name.   
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6.1.2  Open 

  The Open button opens a dialog box from which an existing configuration can be 
selected and opened. A configuration consists of a graphic file (.353) and a database file (.V3C).  
In normal situations, the (.353) file is opened and the (.V3C) file is automatically merged with it.  
If for some reason the graphic file does not exist, a (.V3C) file can be opened in i|config and the 
software will auto-draw the function block views. 
 
When a configuration is auto-drawn, the line connections between function blocks are not drawn 
however the connection identifiers are included.  Blocks can be moved to a desired layout and 
then the Automatic Line Connection button can be used to auto-route the lines.  See Section 
6.4.3 Automatic Line Connection later in this chapter.   
 
! To open a new configuration: 

1. Click the Open button on the Standard toolbar.  The Select Database File dialog 
displays. See Figure 6-5. 

 

 
 

Figure 6-5  Select Database File dialog 
 

2. Do one of the following: 
 

• Select the file from the list, then click [Open]. 
OR 

• Enter a file name in the File name text box, and then click [Open]. 
OR 

• Double-click the file name. 
 

A station view displays.  If a database file was selected, additional function block views 
may open.  If these views are displayed, graphic function block associated with them 
will be auto-drawn. 
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6.1.3  Save 

  The Save button saves a new or modified configuration file.  When a file is saved, 
i|config saves both the graphic (.353) and database (.V3C) files.  
 
! To save a new or modified configuration: 

1. Click the Save button on the Standard toolbar.  The Select Database File dialog 
displays.  See Figure 6-6. 

 
Note: A previously saved configuration file will save immediately using the existing 
file name without displaying the Select Database File dialog. 

 

 
 

Figure 6-6  Select Database File dialog for saving a new configuration 
 

2. Select the folder in which to save the configuration.  The “C:\Program 
Files\Siemens\iConfig\Configs” folder displays as the default directory. 

3. Enter a new file name in the File name text box. 

4. Click [Save]. The configuration is saved as the entered file name in the selected folder. 

6.1.4  Print 

  The Print button sends a configuration loop view to the printer.  This option is available 
in both the function block and ladder logic views. 
 
Note:  The Function Block Parameters and Connection Identifiers report views open Notepad 
to view the report.  In this case the Notepad menu selection is used for printing the report. 
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! To print a configuration: 

1. Click the Print button on the Standard toolbar.  The Print dialog displays.  See Figure 
6-7. 

 

 
 

Figure 6-7  Print dialog 

2. Make changes to the dialog, if necessary. 

3. Click [OK].  The view is sent to the printer. 

6.1.5  Cut 

  The Cut button removes the selected graphic item or function block loop from the 
present location and moves it to the Clipboard.  Cut is used in combination with the Paste button 
to move an item or several items from one location to another. For more information on cutting 
function block loops, see Section 2.8.1 Cutting Loops. 
 
This option is available in the station view to cut function block loops and in the function block 
and ladder logic views to cut graphic items.   
 
! To cut an item: 

1. Select the item to cut. 

2. Click the Cut button on the Standard toolbar.  The item may be cut or a message may 
appear, depending on the graphic item selected. See Figure 6-8. 

 

 
 

Figure 6-8  Cut message 
 

3. Click [Yes].  The item is cut and pasted to the Clipboard. 
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6.1.6  Copy 

  The Copy button copies the selected graphic items or function block loops to the 
Clipboard.  It is used in combination with the Paste button to duplicate items. 
 
For more information on copying function block loops, see Section 2.8.2 Copying Loops. 
 
This option is available in the station view to copy function block loops and in the function block 
and ladder logic views to copy graphic items.   
 
! To copy an item: 

1. Select the item to copy. 

2. Click the Copy button on the Standard toolbar.  The item is copied and pasted to the 
Clipboard. 

6.1.7  Paste 

  The Paste button moves the contents of the Clipboard to the active view.  This button is 
used with the Cut and Copy functions to move items to new locations or to duplicate items. 
 
This option is available in the station view to paste function block loops and in the function block 
and ladder logic views to paste graphic items.  For more information on pasting, see the Section 
2.8.3 Pasting Loops. 
 
! To paste an item: 

1. Use Cut or Copy to select the item or items and transfer them to the Clipboard. 

2. Click the Paste button on the Standard toolbar to move the selection from the 
Clipboard to the active view. 

6.1.8  Online Manual 

  The Online Manual button opens this Software Guide using Adobe® Reader®. 
 
! To display the manual: 
 

Click the Online Manual button on the Standard toolbar.  The Manual opens in the Adobe 
Reader. 
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6.2  Using the 353 Objects Toolbar 
The 353 Objects Toolbar, shown in Figure 6-9, includes buttons that creates new 
configurations and adds loops to the configuration. 
 

 
 

Figure 6-9  353 Objects Toolbar 

6.2.1  Function Block Loop 

  The Function Block Loop button creates function block loops and places them on the 
station view.  This button is active in the station view. 
 
! To create a function block view: 
 

Click the Function Block Loop button on the 353 Objects Toolbar.  A new function block 
loop displays in the station view tree. 

6.2.2  Ladder Logic Loop 

  The Ladder Logic Loop button creates ladder logic loops and places them on the 
station view.  This button is active in the station view. 
 
! To create a function block view: 
 

Click the Ladder Logic Loop button on the 353 Objects Toolbar.  A new ladder logic loop 
displays in the station view tree. 

6.2.3  New FCO 

  The New FCO button creates a new configuration from the list of factory configured 
options.  This button is active in the station view. 
 
! To create a configuration from a Factory Configured Option: 

1. Click the New FCO button on the 353 Objects Toolbar      
 

The Database Revision dialog opens.  See Figure 6-10.  Select the revision level of 
the firmware in the controller that the FCO will be downloaded to.  After selecting the 
revision level the Factory Configured Dialog will open.  See Figure 6-11. 

 
Note:  If the configuration will be downloaded to several controllers that have 
different database (firmware) revisions, choose the lowest database revision in the 
group of controllers. Create the configuration and save it. Use i|config to upgrade 
the configuration to the higher revision level (File > Upgrade to). Save the upgraded 
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configuration with a different file name for use in a controller with the higher 
database revision level.  

 
 

 
 

Figure 6-10  Database Revision dialog 
 

 
 

Figure 6-11  Factory Configured Option dialog 
 

2. Do one of the following: 
 

• Select a Factory Configured Option from the dialog, click [OK]. 
OR 

• Double click a Factory Configured Option in the dialog. 
 
A station view of the Factory Configured Option will open. 
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6.3  Using the Line Connection Toolbar 
The Line Connection toolbar, shown in Figure 6-12 includes buttons that provide multiple 
functions on loop views.  This button is available in the function block and ladder logic views. 
 

 
 

Figure 6-12  Line Connection Toolbar 

6.3.1  Multiple Create 

  The Multiple Create button creates multiple function blocks or ladder logic elements 
without clicking the item button multiple times.  This option is available in the function block and 
ladder logic views. 
 
! To create multiple function blocks elements consecutively: 
 

1. Click the Multiple Create button on the Line Connection toolbar. 

2. Click the New Function Block button on the Line Connection toolbar.    The 
Select Item to Create dialog opens.  See Figure 6-13.  

 

 
 

Figure 6-13  Select Item to Create 
 

3. Select the function block and place it on the workspace. The dialog will open again.  
Continue placing blocks. 

4. Press <Esc> or click [Cancel] when finished placing blocks. 
 

Note: For more information on placing function blocks, see Chapter 3 Working with 
Function Block Loops. 

 
! To create multiple ladder logic elements consecutively: 



Chapter 6 – Using the Toolbars SG15939-64V400 

 6-10

1. Click the Multiple Create button on the Line Connection toolbar.  The button appears 
pressed in. 

2. Click the New Ladder Logic Element button on the Line Connection toolbar.    
The Select Item to Create dialog opens.  See Figure 6-14.  

 

 
 

Figure 6-14  Select Item to Create 
 

3. Select the ladder logic element and place it on the workspace. The dialog will open 
again.  Continue placing ladder logic elements. 

4. Press <Esc> or click [Cancel] when finished placing ladder logic elements. 
 

Note: For more information on placing ladder logic elements, see Chapter 4 Working 
with Ladder Logic Loops. 

6.3.2  Line Connection Mode 

  The Line Connection Mode button creates connection lines between connectable 
items.  This button is also referred to as the wire spool or simply as the spool.  This option is 
available in the function block and ladder logic views. 
 
Note: For more information on connecting function blocks, see Chapter 3 Working with 
Function Block Loops, and on connecting ladder logic elements, see Chapter 4 Working with 
Ladder Logic Loops. 
 
! To connect inputs and outputs: 

1. Click the Line Connection Mode button.   The cursor becomes a wire spool. 

2. Click a valid starting point. 
 

Note: The cursor displays as a spool with a (+) sign when over a valid 
connection point. It displays with a (∅) symbol when the connection point is not 
valid. 
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3. Move the cursor to a valid connection point. 

4. Click a valid ending connection point. 
 

A connection is made and is represented as a line.  A triangle and an alphanumeric 
connection identifier displays on the connected input and output if an Auto-routed line 
can not be drawn between the connection points. 

 
Note: Press <Esc> at any point, when creating a connection line, to cancel the 
operation. 

 
Connections can start on an input, an output, or an existing connection line.  If the 
input already has a connection or is used by a reference, a warning message is 
displayed. See Figure 6-15. 

 

 
 

Figure 6-15  Input already has a connection warning message 
 

If a connection line starts on an existing line, the staring point is considered to be the 
output of the connection line on which the user started. 

6.3.3  Line Connection Selection Mode 

  The Line Connection Selection Mode button selects a connection line, function block, 
or ladder logic element to edit.  This option is available in the function block and ladder logic 
views. 
 
In a ladder logic view, this mode enables the user to identify the function 
blocks associated with ladder logic elements.  This is done whenever the 
mouse cursor moves over a ladder logic element and the cursor is 
stopped.  After a short time, a tool tip styled information box appears and 
describes the function blocks associated with the ladder logic element, as 
shown at right.  
 
! To select items to edit: 

1. Click the Line Connection Selection Mode button on the Line Connection toolbar. 

2. Do one of the following to select items: 
 

• Click on an item.  A single item is selected.  If the item was previously selected, it 
is deselected. 

OR 

• <Shift> + click on multiple items.  Multiple items are selected.  If the items were 
previously selected, they are deselected. 

OR 
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• Click on an item where it overlays another item.  The Choose Items to Select 
dialog displays a list of connection lines and items near the location point.  See 
Figure 6-16.  Select the item or items and click [OK].  
OR 

 
 

Figure 6-16  Choose Item to Select dialog 
 

• <Shift> click on an item near where it overlays another item.  The Choose Item to 
Select dialog displays.  See Figure 6-16.  Select the item or items and click [OK]. 
OR 

• Click and drag a box across multiple items.  All the items within the dragged area 
are selected. 

OR 

• Right-click and from the pop up menu select [Select All].  All the items in the 
workspace are selected. 

OR 

• Select Edit > Select All from the menu.  All the items in the workspace are 
selected. 

OR 

• Press <Ctrl+A>.  All the items in the workspace are selected. 
 

3. Do one of the following to edit selected items: 
 

• Click an editing toolbar button or select a menu option. 

OR 

• Right-click on the selected items and select an edit option from the pop-up menu. 

OR 

• Drag the selected items to a new valid location. 
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6.3.4  Line Connection Attributes 

  The Line Connection Attributes button displays the Item Attributes dialog. This dialog 
can contain one or more of the following tabs: Line Connection, Fn (Function) Block, 
Selection, and Paper.  The Fn Block tab is available when a single function block or multiple 
function blocks have been selected.  The other tabs are available when the Line Connection 
Attributes button is used and no item selections (e.g. lines, function blocks) have been made. 
 
The user can change the parameters that appear on the Item Attributes dialog.  Changes are 
not applied to the view until [OK] is clicked.  All changes made in the dialog are cancelled if 
[Cancel] is clicked.  This option is available in the function block and ladder logic views.  
 
! To edit line connection, selection, and paper attributes: 

1. Click the Line Connection Attributes button on the Line Connection toolbar.  The 
Item Attributes dialog displays.  

2. Select the tab desired.  Refer to Sections 6.3.7.1 through 6.3.7.4 below to make the 
desired changes. 

3. Click [OK] or [Cancel]. 

6.3.4.1  Line Connection Tab 
! To change line colors: 

1. Click the Line Connection tab, if not already selected. See Figure 6-17. 
 

 
 

Figure 6-17  Line Connection tab - Item Attributes 
 

2. Select the current color block of the line type to be changed. 

3. Select a color from the color matrix.  See Custom Colors later in this chapter for 
information on creating custom colors. 
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4. Click [OK].  All lines of the line type selected will change. 

6.3.4.2 Selection Tab 
! To change the color outline of a selected item: 

1. Click the Selection tab, if not already selected. See Figure 6-18. 
 

 
 

Figure 6-18  Selection tab – Item Attributes dialog 
 

2. Select the current selection color block to be changed. 

3. Select a color from the color matrix.  See Custom Colors later in this chapter for 
information on creating custom colors. 

4. Click [OK].  The outline of all selected items will now use the new color. 

6.3.4.3 Paper Tab 
! To change the paper color: 

 
Paper refers to the workspace area.  You can also change the color of the area behind the 
workspace.   

1. Click the Paper tab, if not already selected. See Figure 6-19. 
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Figure 6-19  Paper tab – Item Attributes dialog 
 

2. Select the current Paper or Background color selection block to be changed. 

3. Select a color from the color matrix.  See Custom Colors later in this chapter for 
information on creating custom colors. 

4. Click [OK].  The workspace or background colors will be changed. 

6.3.4.4 Fn Block Tab 
! To edit Function Block colors: 

1. Select a function block or blocks for attribute change  

2. Click the Line Connection Attributes button on the Line Connection toolbar.  The 
Item Attributes dialog displays.  See Figure 6-20. 
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Figure 6-20  Item Attributes – Fn Blocks tab 
 

3. Select the Fn Block tab.   

4. Select the current Function Block Color box. 

5. Select a color from the color matrix.  See Custom Colors later in this chapter for 
information on creating custom colors. 

6. Click [OK].  The colors of all the selected function blocks will be changed. 

6.4  Using the Function Block Toolbar 
The Function Block Toolbar, shown below, is active while a function block loop is displayed. 
 

 

6.4.1  New Function Block 

  The New Function Block button creates function blocks and places them in the active 
function block view.  This option is available only in the function block view. 
 
! To place a new function block: 

1. Click the New Function Block button on the Line Connection toolbar.   
 

The “Select Item to Create” dialog is displayed.  See Figure 6-21. 
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Figure 6-21  Select Item to Create dialog 
 

2. Do one of the following to place function blocks on the loop workspace. 
 

• Select a function block.  Click [OK]. 
OR 

• Enter the name of the block in the text box.  Click [OK]. 
OR 

• Double-click the function block. 
 

A dotted box appears in the workspace which indicates the start of the function 
block placement process. 

 
Note: The function block floats with the cursor until you physically place it. 

3. Drag the box to a valid location for placement and click.  The function block displays on 
the function block view workspace. 

 
Note:  When a function block is dragged off the page, the view automatically scrolls, 

keeping the function block visible within the workspace.  If the cursor 
displays as a not allowed symbol (∅), the placement location is not valid. 

6.4.2  Find Block 

  Click the Find Block button to locate a specific type of function block in the displayed 
loop. 
 
! To find a function block: 

1. Click the Find Block button on the Function Block toolbar.   
 

The “Select a block to find” dialog is displayed.  See Figure 6-22. 
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Figure 6-22  Select a block to find 

2. In the displayed dialog, select the function block type and instance number that is to be 
found in the displayed loop and click Find.  

6.4.3  Automatic Line Connection 

  The Automatic Line Connection button automatically creates graphic lines for all 
existing configured connections.  All connections which exist without line connections will have 
line connections drawn if routing of the line is possible.   All connections which have graphic 
lines will have the lines deleted and regenerated. This option is available only in the function 
block view. 
 
! To automatically generate connection lines: 
 

Click the Automatic Line Connection button on the Line Connection toolbar.  The view 
enters the Zoom Page mode.  As the system generates new line connections, the wait 
cursor is displayed.  The system returns to the Line Connection Mode after completing the 
line generation process.  The spool cursor is displayed and the view is updated to show the 
generated connection lines. 
 
Where a line cannot be drawn, a triangle and an alphanumeric identifier appear at the input 
and output connection points. 

6.4.4  Erase Line Connection 

  Clicking on the Erase Line Connection button immediately removes all construction 
lines from the function block loop. Click the Automatic Line Connection button to interconnect 
the function blocks. 
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6.5  Using the Ladder Logic Toolbar 
The Ladder Logic Toolbar, shown below, is active while a ladder logic loop is displayed.  
 

 

6.5.1  New Ladder Logic Element 

  The New Ladder Logic Element button creates ladder logic elements and places them 
in the active ladder logic view 
 
! To place any ladder logic element: 

1. Click the New Ladder Logic Element button on the Line Connection toolbar.  The 
Select Item to Create dialog displays.  See Figure 6-23. 

 

 
 

Figure 6-23  Select Item to Create dialog 
 

2. Select the ladder logic element to create.  Click [OK]. 
 

3. Drag the ladder logic element to a valid location on the ladder and click.  The element 
displays on the ladder logic view. The dotted outline of the element floats with the 
cursor until it is placed. 

 
Note:  If the element is dragged off the page, the view automatically scrolls, 
keeping the element visible within the workspace.  If the cursor displays is a not 
allowed symbol (∅), the placement is not valid. 

 
! To place basic ladder logic elements: 

1. Click the desired element NO Contact, NC Contact, or Coil button on the Line 
Connection toolbar.     

2. Drag the ladder logic element to a valid location on the ladder and click.  The element 
displays on the ladder logic view. 
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6.6  Using the Station Resources Toolbar 
The Station Resources toolbar, shown in Figure 6-24, displays in bargraph form the 
percentage of station (controller) memory available in a configuration.  The color of the bar will 
change as the percentage of available resources decrease.  From 100% to 50% the bar is 
green, from 50% to 35% the bar is yellow, and below 35% the bar is red.  It is good practice to 
leave resources available for future changes.   
 

 
 

Figure 6-24  Station Resources toolbar 

6.6.1  Station Resources 
Station Resource Information can be viewed by selecting the Information button on the Station 
Resources toolbar while in the station view.  
 
! To view station resources: 

1. Click the Information button while in the station view.  The Station Resource 
Information dialog displays.  See Figure 6-25  

 

 
 

Figure 6-25  Station Resource Information 
 

2. Click [OK].  The Station Resource Information dialog closes. 

6.6.2  Station and Loop Resources 
Station and Loop Resource Information can be viewed by selecting the Information button on 
the Station Resources toolbar while in a function block or ladder logic view.  
 
! To view station (controller) and loop resources: 

1. Click the Information button while in a function block or ladder logic view.  The Loop 
Resource Information dialog displays.  See Figure 6-26  
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Figure 6-26  Loop Resource Information 
 

2. Click [OK].  The Loop Resource Information dialog closes. 

6.7  Using the Graphic Primitives Toolbar 
The Graphic Primitives toolbar, shown in Figure 6-27, adds shapes and text to the 
configuration for documentation purposes.  Graphic items can be cut, copied, and pasted, into 
the same or other function block or ladder logic views.  See Chapter 8 for more information on 
cutting, copying, and pasting. 
 

 
 

Figure 6-27  Graphic Primitives toolbar 
 
Graphic items can be created and moved anywhere within the workspace of a view.  The 
creation of each item is explained in the appropriate button selection to follow.  Moving, copying, 
and resizing an item, in general, are the same for all graphic items. 
 
! To move a graphic item: 
 

Select a graphic item, drag to a new location, and release the mouse button.  The item 
displays in the new location. 

 
! To copy a graphic item: 
 

Hold <Ctrl>, select a graphic item, drag it to a new location, and release the mouse button.  
A copy of the selected item displays in the new location. 

 
Note:  The <Ctrl> key must be held down until after the mouse button is released. 

 
! To size a graphic item: 

1. Select a graphic item. 

2. Click a selection handle, drag the cursor in any direction, and release the mouse 
button.   
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The cursor displays with a directional arrow when the handle point is clicked.  The 
selected graphic item is sized when the cursor is dragged and the mouse button is 
released. 

 
Note: Certain size boxes only size in particular directions.  Pressing the <Ctrl> and 
<Shift> keys while sizing a graphic item, sizes the item differently.  See the 
appropriate section for each item button for more information on sizing. 

6.7.1  Multiple Create 

  The Multiple Create button creates multiple graphic items without clicking on the item 
button multiple times.  This option is available in the function block and ladder logic views.  
 
! To create graphic items multiple time consecutively: 

1. Click the Multiple Create button on the Graphic Primitives toolbar.  The button 
appears pressed in.  

2. Click a graphic item button on the Graphic Primitives toolbar. 

3. Click the workspace, drag the cursor to create the selected item, and release the 
mouse button.   

 
The selected graphic item is created.  The cursor remains prepared to create that 
same item until the user clicks the Multiple Create button again or the user selects 
another graphic tool. 

 
Note: To stop placing the selected item any time during the procedure, press <ESC> 
or click the Multiple Create button. 

6.7.2  Reshape 

  The Reshape button changes individual points of a line, freeform item, or polygon.  This 
option is available in the function block and ladder logic views. 
 
! To reshape a line, freeform item, or polygon: 

1. Click the Reshape button on the Graphic Primitives toolbar. 

2. Select a line, freeform item, or polygon on the view to reshape 
 

Selection handles display on each point in the item.  They indicate a point to size. 
 

3. Click a selection handle on the item, drag the cursor in any direction, and release the 
mouse button.  The item is reshaped. 
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6.7.3  Selection Mode 

  The Selection Mode button selects one or more graphic items, function blocks, and 
ladder logic elements on which to perform an operation.  This option is available in the function 
block and ladder logic views. 
 
! To select a graphic item to edit: 

1. Click the Selection Mode button on the Graphic Primitives toolbar. 

2. Do one of the following to select workspace items 
 

• Click on an item.  The item is highlighted.  If already highlighted, the item is 
deselected. 

OR 

• <Shift>-click on one or more items.  If the item was not previously selected, it is 
added to the list of selected items.  If previously selected, it will be deselected. 

OR 

• Click an item near where it overlays another item.  The Choose Items to Select 
dialog displays a list of items near the location point.  See Figure 6-28. 

OR 

• <Shift>-click an item near where it overlays another item.  The Choose Items to 
Select dialog displays a list of items near the location point.  See Figure 6-28. 

OR 

• Click items to highlight or Click [Select All] then Click [OK]. 
 

 
 

Figure 6-28  Choose Items to Select dialog 
 

• Click and drag a box across multiple items.  All items within the dragged area are 
selected. 

OR 
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• Select Edit > Select All from the menu.  All items in the workspace are selected.  

OR 

• Right-click on selected items and select [Select All] from the pop-up menu.  All 
items in the workspace are selected. 

OR 

• Press <Ctrl+A> items in the workspace are selected. 
 

3. Do one of the following to edit selected items. 
 

• Select an editing toolbar button or menu option. 

OR 

• Right-click on the selected items and select an edit operation from the pop-up 
menu. 

OR 

• Move the selected item to a new valid location. 

OR 

• <Ctrl>-click on an item where the cursor displays with a “plus” (+) sign and drag 
the item to a new location.  The item is copied and placed in the location. 

OR 

• Select a selection handle on the selected item, drag the cursor in any direction, 
and release the mouse button.  The item is resized according to the movement of 
the cursor.  

6.7.4  Text Edit Mode 

  The Text Edit Mode button adds text to a function block or ladder logic loop and it edits 
previously entered text in a text box.  It is also a pop-up menu option.  This option is available in 
the function block and ladder logic views. 
 
! To add or edit text in a text box: 

1. Do one of the two following: 
 

• Click the [Text Edit Mode] button on the Graphic Primitives toolbar. 

OR 

• Right-click on a text item and, from the pop-up menu, select Edit > Text.  The 
cursor becomes an |-bar when it is over a text item. 

2. Place (click) the cursor in the text item to edit. 

3. Edit the text as you would using any word processing program. 

4. Click outside the item.  The text is deselected. 
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6.7.5  Text 

 The Text button creates a rectangle text item.  This option is available in the function 
block and ladder logic views. 
 
! To create a text item: 
 

1. Click the [Text] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Click on the active view where the text is to begin, drag the cursor to create a text item, 
and release the mouse button.  A text box displays with a blinking cursor. Type the 
desired text. 

 
Note: If the Multiple Create button is active, the user cannot directly enter text 
into the newly created text box. Click the Multiple Create button to turn off the 
feature 

6.7.6  Pencil 

  The Pencil button creates freeform items.  This option is available in the function block 
and ladder logic views. 
 
! To create a freeform item: 

1. Click the [Pencil] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Click on the active view and move the cursor in any direction.  The item displays as a 
dashed line on the screen as you move the cursor. 

3. When finished creating the item, double click.  The item displays as defined by its Item 
Attributes. 

6.7.7  Line 

  The Line button creates a line that may contain line segments.  This option is available 
in the function block and ladder logic views. 
 
! To create a line: 
 

1. Click the [Line] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Click on the active view, release the mouse button, and drag the cursor. 
 

If the workspace is clicked while the cursor is dragged, the click area becomes a point 
in the line, know as a segment. 

 

3. Double-click when you are finished creating the line.  The line segment displays on the 
screen. 
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! To create a straight line segment at a predetermined angle: 
 

1. Click the [Line] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Hold <Shift>, click on the active view, release the mouse button, and drag the cursor. 
The line is drawn as a dashed line. 

 
If the workspace is clicked more than once, each click represents a point added to the 
line. Each line segment may be drawn at any angle or length. 

 

3. Double-click when you are finished creating the line.  The line segments display on the 
screen. 

6.7.8  Arc 

  The Arc button creates an arc.  This option is available in the function block and ladder 
logic views. 
 
! To create an arc: 
 

1. Click the [Arc] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

 
2. Do one of the following: 

 
• Click on the active view, drag the cursor to create an arc, and release the mouse 

button.  The arc displays on the view. 

OR 

• <Shift>-click on the active view, drag the cursor in any direction, and release the 
mouse button. An arc is created from a circle in the direction of the mouse. 

OR 

• <Ctrl>-click on the active view, drag the cursor in any direction, and release the 
mouse button. An arc is created in the direction of the cursor and mirrored in the 
opposite direction. 

OR 

• <Ctrl + Shift>-click on the active view, drag the cursor in any direction, and 
release the mouse button. An arc is proportionately created in the direction of the 
cursor and mirrored in the opposite direction. 
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6.7.9  Rectangle 

  The Rectangle button creates rectangles, including squares.  This option is available in 
the function block and ladder logic views. 
 
! To create an rectangle: 

1. Click the [Rectangle] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Do one of the following: 
 

• Click on the active view, drag the cursor in any direction, and release the mouse 
button.  A rectangle is created. 

OR 

• <Ctrl>-click on the active view, drag the cursor in any direction, and release the 
mouse button. A rectangle is created in the direction of the cursor and mirrored in 
the opposite direction. 

 
! To create an Square: 

1. Click the [Rectangle] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Do one of the following: 
 

• <Shift>-click on the active view, drag the cursor in any direction, and release the 
mouse button.  A square is created. 

OR 

• <Ctrl + Shift>-click on the active view, drag the cursor in any direction, and 
release the mouse button. A square is created in the direction of the cursor and 
mirrored in the opposite direction. 

6.7.10  Round Rectangle 

   The Rounded Rectangle button creates rectangles, including squares that have 
rounded corners.  This option is available in the function block and ladder logic views. 
 
! To create a rounded rectangle: 

1. Click the [Rounded Rectangle] button on the Graphic Primitives toolbar.  The cursor 
becomes crossbars. 

2. Do one of the following: 
 

• Click on the active view, drag the cursor in any direction, and release the mouse 
button.  A rectangle with rounded corners is created. 

OR 
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• <Ctrl>-click on the active view, drag the cursor in any direction, and release the 
mouse button. A rectangle with rounded corners is created in the direction of the 
cursor and mirrored in the opposite direction. 

 
! To create a rounded square: 

 

1. Click the [Rounded Rectangle] button on the Graphic Primitives toolbar.  The cursor 
becomes crossbars. 

2. Do one of the following: 
 

• <Shift>-click on the active view, drag the cursor in any direction, and release the 
mouse button.  A square with rounded corners is created. 

OR 

• <Ctrl + Shift>-click on the active view, drag the cursor in any direction, and 
release the mouse button. A square with rounded corners is created in the 
direction of the cursor and mirrored in the opposite direction. 

6.7.11  Ellipse 

  The Ellipse button creates an ellipse or a circle.  This option is available in the function 
block and ladder logic views. 
 
! To create an ellipse: 
 

1. Click the [Ellipse] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Do one of the following: 
 

• Click on the active view, drag the cursor in any direction, and release the mouse 
button.  An ellipse is created. 

OR 

• <Ctrl>-click on the active view, drag the cursor in any direction, and release the 
mouse button.  An ellipse is created in the direction of the cursor and mirrored in 
the opposite direction.  

 
! To create a circle: 

1. Click the [Ellipse] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Do one of the following: 
 

• <Shift>-click on the active view, drag the cursor in any direction, and release the 
mouse button.  A circle is created. 

OR 

• <Ctrl + Shift>-click on the active view, drag the cursor in any direction, and 
release the mouse button. A circle is created in the direction of the cursor and 
mirrored in the opposite direction. 
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6.7.12  Polygon 

  The Polygon button creates a polygon.  This option is available in the function block 
and ladder logic views. 
 
! To create a polygon: 

1. Click the [Polygon] button on the Graphic Primitives toolbar.  The cursor becomes 
crossbars. 

2. Click on the active view, release the mouse button, and drag the cursor in any direction 
to create the first side of the polygon.  Click to anchor the first side, then drag the 
cursor to create a three sided polygon, click to anchor the point, continue to drag and 
click as required. 

3. Double-click when you are finished creating the polygon.  The polygon displays on the 
screen. 

6.7.13  Button 

   The [Button] button creates a button.  This option is unavailable in this version of the 
software. 

6.7.14  Edit Item Attributes 

  The Edit Item Attributes button displays a dialog of attributes for the Pen, Brush, 
Background, Button, Text, Font, Frame, Selection, Grid Snap, and Paper tabs when no 
items are selected.  When an item is selected, only the tabs specific to that item are displayed.  
Most tabs have either a Preview box or a Sample box.  For items that are selected in the tab, 
the Preview or Sample box displays the result of the selections.  If no items are selected, 
nothing displays in the Preview or Sample box.  
 
The user can change the tab parameters that display on the Item Attributes dialog.  Changes do 
not apply to the configuration until [OK] is clicked.  All changes made in the dialog are cancelled 
if [Cancel] is clicked.  
 
Item Attributes is also an Edit menu option.  This option is available in the function block and 
ladder logic views. 
 
Sections 6.5.14.1 through 6.5.14.11 describe the setting of individual attributes. 
 
! To edit item attributes: 

1. Do one of the following: 
 

• Click the [Edit Item Attributes] button on the Graphic Primitives toolbar.   

OR 

• Right-click on the workspace and select Edit Item Attributes from the pop-up 
menu. 

 
The Item Attributes dialog is displayed.   
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Note: If items (function blocks, ladder logic elements, and connection lines) are 
selected first, the tabs included only those attributes that relate to the item. 

2. Make necessary changes to the tab.  Details on each tab are discussed in the following 
sections.   

3. Click [OK].  The changes for the selected items display in the configuration. 

6.7.14.1 Custom Colors 
Most Item Attributes tabs have color attributes.  This section discusses the Colors dialog 
and provides information on creating custom colors.  See Figure 6-29. 
 

 
Figure 6-29  Colors attribute 

 
The left side of the Colors attribute contains a color cube matrix.  The right side contains 32 
user definable color buttons.  The [Define Custom] colors button is active if the computer’s 
graphic controller is set for a color mode that displays more that 256 colors and supports 
palettes. It is NOT active in a 256 colors mode.  Reconfigure the graphics mode to a mode 
other than 256 colors to enable the [Define Custom] function. 
 

! To create a custom color scheme: 

1. Select [New] in the Color dialog. 

2. Do the following for each custom color button desired. 
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• Select one of the 32 custom color buttons.   

 
• Right-click a color from the color cube matrix or select [Define Custom].  Using 

the Define Custom color function is defined below.  Repeat as needed for each 
user defined color button required.   

3. Click [Save].  The Save Scheme dialog displays. 

4. Enter a name for the new scheme. 

5. Click [OK].  The color scheme is saved. 
 
! To define a custom color as part of a custom color scheme: 

1. Select one of the 32 custom color buttons. 

2. Select [Define Custom] in the Color dialog.  The Define Custom Color dialog displays.  
See Figure 6-30. 

 
 

Figure 6-30  Define Custom Color dialog 
 

3. Select a color using the mouse to position the crosshairs and luminance slider. The 
color displays in the Color|Solid display box. 

4. Click [Add to Custom Colors]. 
5. Click [Close].  The color is added to the selected color button. 

6. Follow previous instructions to save the scheme. 
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6.7.14.2 Pen tab 
Pen refers to the border of user-drawn graphic items.  The user can view and change the 
current pen color, and select the style, weight, end cap, and joints of the pen.  See Figure 6-
31.  The Preview box is inactive. 
 

 
 

Figure 6-31  Item Attributes dialog – Pen tab 
 
! To change the pen color: 

1. Select the Color box 

2. Select a color from the color cube matirix or from a user-defined color button.  The 
color in the Color box will change to match the selection. 

3. Click [OK].  The new Pen color will be saved. 
 
! To change the pen style: 

1. Click the drop down arrow in the Style box 

2. From the drop down list, select a style.  The new style displays in the Style box. 

3. Click [OK].  The new Pen style will be saved. 
 

Note: Pen style refers to the type of line (e.g. solid, dotted etc.) 
 
! To change the pen weight: 

1. Click the drop down arrow in the Weight box 

2. From the drop down list, select a weight.  The new weight displays in the Weight box. 

3. Click [OK].  The new Pen weight will be saved. 
 

Note: Pen Weight refers to the thickness of a line.  
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! To change the end cap shape: 

1. Click the drop down arrow in the End Cap box. 

2. From the drop down list, select an end cap type.  The new end cap type displays in the 
End Cap box. 

3. Click [OK].  The new Pen end cap shape will be saved. 
 

Note: End Caps refer to the shape at the end of a line. End caps are viewed best 
with thick lines. 

 
! To change the joint shape: 

1. Click the drop down arrow in the Joints box. 

2. From the drop down list, select a joint type.  The new joint type displays in the Joints 
box. 

3. Click [OK].  The new Pen joint type will be saved. 
 

Note: Joints refer to the shape of the corners of rectangles and junctions of lines. 

6.7.14.3 Brush tab 
Brush refers to the fill of user-created graphic item.  The user can view and change the 
current brush color, and select a pattern for the brush.  See Figure 6-32. The Preview box is 
inactive. 

 

 
 

Figure 6-32  Item Attributes dialog – Brush tab 
 
! To change the brush color: 

1. Select the Color box. 

2. Select a color from the color cube matrix or from a user-defined color button.  The color 
in the Color box will change to match the selection. 
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3. Click [OK].  The new brush color will be saved. 
 
! To change the pattern style: 

1. Click the drop down arrow in the Patterns box. 

2. From the drop down list, select a pattern type.  The new pattern type displays in the 
Patterns box. 

3. Click [OK].  The new Pattern type will be saved. 
 

Note: Patterns refer to the fill background of a graphic item. 

6.7.14.4 Background tab 
Background refers to the fill of a user-created graphic item whose brush or pen is not solid.  
The user can view and change the current background color, and select an opaque or 
transparent mode.  The Preview box is inactive. See Figure 6-33. 
 

 
 

Figure 6-33  Item Attributes dialog – Background tab 
 
! To change the background color: 

1. Select the Color box. 

2. Select a color from the color cube matrix or from a user-defined color button.  The color 
in the Color box will change to match the selection. 

3. Click [OK].  The new background color will be saved. 
 
! To change the background mode: 

1. Click the appropriate radio button 

2. Click [OK].  The new background mode will be saved. 
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6.7.14.5 Button tab 
This tab is not applicable since the button function is not available 

6.7.14.6 Text tab 
Text refers to the characters used in user-created text items.  The user can view and change 
the current color of a text item, and select a background color and mode, and choose 
horizontal or vertical text alignment.  An example is displayed in the Sample box. See Figure 
6-34.  Changes made will affect all future text items.  To change an existing text item, first 
select the item, and then open the Item Attributes dialog.  Changes will appear in the 
selected item as well as future items.  
 

 
 

Figure 6-34  Item Attributes dialog – Text tab 
 
! To change the text or background color: 

1. Select the appropriate Color box. 

2. Select a color from the color cube matrix or from a user-defined color button.  The color 
in the Color box will change to match the selection. 

3. Click [OK].  The new background color will be saved. 
 

Note: The text color refers to the fill color of a text item.  The background color 
refers to the area behind the text characters. 

 
! To change the background mode: 

1. Click the appropriate radio button. 

2. Click [OK].  The new background mode will be saved. 
 

Note: Background mode refers to the display status of the background color.  It can be 
opaque where the background color is visible or transparent where the background color is 
invisible. 
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! To align text: 
1. Click on the down arrow of the Horizontal box. 

2. From the drop down list select an option.  The selected option displays in the 
Horizontal box. 

3. Click on the down arrow on the Vertical box. 

4. From the drop down list select an option.  The selected option displays in the Vertical 
box. 

 
Note: Text alignment refers to the vertical and horizontal alignment of text within a text 
item. 

6.7.14.7 Font tab 
The user can select the font, font style, size, and effect of text in a text item.  An example is 
displayed in the Sample box. See Figure 6-35. 
 

 
 

Figure 6-35  Item Attributes dialog – Font tab 
 
! To change the font: 

1. Scroll through the Font list box and select the desired font. 

2. Click [OK].  The new font will be saved. 
 
! To change the font style: 

1. Select the desired font style from the Font Style list box 

2. Click [OK].  The new font style will be saved. 
 
! To change the font size: 

1. Select the desired size from the Size list box 

2. Click [OK].  The new font size will be saved. 
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Note: Rotation refers to placing text at an angle.  This option is not available in this 
version of software.  

6.7.14.8 Frame tab 
The user can view and change the current color of the text frame of a text item, and select a 
text frame color, background color, and mode, style and weight of a frame.  An example of 
the output is displayed in the Sample box.  See Figure 6-36. 
 

 
 

Figure 6-36  Item Attributes dialog – Frame tab 
 
! To change the frame or background color: 

1. Select the Appropriate Color box. 

2. Select a color from the color cube matrix or from a user-defined color button.  The color 
in the Color box will change to match the selection. 

3. Click [OK].  The new color will be saved. 
 

Note: The frame color refers to the color of the frame of the text item.  The 
background color refers to the fill color of the text item. 

 
! To change the background mode: 

1. Click the appropriate radio button. 

2. Click [OK].  The new background mode will be saved. 
 

Note: The Background Mode refers to the display status of the fill of the text item.  It 
can be opaque (visible) or transparent (invisible).  
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! To change the frame style: 

1. Click the drop down arrow on the Style list box. 

2. From the drop down list, select a style.  The new style displays in the Style box. 

3. Click [OK].  The new frame style will be saved. 
 

Note: Style refers to the type of line for the outside of the text item.  
 

! To change the frame weight: 
1. Click the drop down arrow on the Weight list box. 

2. From the drop down list, select a line weight.  The new line weight displays in the 
Weight box. 

3. Click [OK].  The new line weight will be saved. 
 

Note: Weight refers to the thickness of the lines that create the frame.  

6.7.14.9 Selection tab 
The user can view and change the current color of the outline that indicates a selected item 
in the Selection tab.  See Figure 6-37. 
 

 
 

Figure 6-37  Item Attributes dialog – Selection tab 
 
! To change the frame or background color: 

1. Select the Color box 

2. Select a color from the color cube matrix or from a user-defined color button.  The color 
in the Color box will change to match the selection. 

3. Click [OK].  The new color will be saved. 
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6.7.14.10 Grid Snap tab 
Grid Snap is the placement of an item when it is created.  The user can place it in one area, but 
if the grid snap is active, the item will snap to the nearest grid point.  The user can select a color 
for the grid, enable grid snap, show the grid points, select spacing and origin of the grid, and 
select a unit of measure for the grid.  See Figure 6-38. 

 

 
 

Figure 6-38  Item Attributes dialog – Grid Snap tab 
 
! To change the grid color: 

1. Select the Color box. 

2. Select a color from the color cube matrix or from a user-defined color button.  The color 
in the Color box will change to match the selection. 

3. Click [OK].  The new color will be saved. 
 

Note: The grid color refers to the color of the grid points when the grid is visible. 
 
! To toggle grid snap on and off: 

1. Click the Snap to Grid check box. 

2. Click [OK].  The change will be saved. 
 
! To toggle the grid on and off: 

1. Click the Show Grid Points check box. 

2. Click [OK].  The change will be saved. 
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! To change horizontal and vertical spacing: 

1. Click the Up or Down arrows to change the number in the list box or enter a number in 
the box. 

2. Click [OK].  The change will be saved. 
 

Note: The horizontal and vertical spacing refers to the spacing between grid points. 
 
! To change horizontal and vertical origin: 

1. Click the Up or Down arrows to change the number in the list box or enter a number in 
the box. 

2. Click [OK].  The change will be saved. 
 

Note: The horizontal and vertical origin refers to the horizontal and vertical offset from 
the top left hand corner of the workspace where the grid starts. 

 
! To change the unit of measure: 

1. Click the radio button next to the appropriate unit. 

2. Click [OK].  The change will be saved. 
 

Note: The unit of measure refers to the units used to describe the horizontal and 
vertical spacing and the horizontal and vertical offset when numbers are entered in the 
relative list boxes. 

6.7.14.11 Paper tab 
The user can select the color of the paper (color of the workspace), the background color, 
and unit of measure for the paper.  A sample of the paper color is shown in the Sample box.  
See Figure 6-39. 
 

 
 

Figure 6-39 Item Attributes dialog – Paper tab 
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! To change paper color: 

1. Select the appropriate Color box. 

2. Select a color from the color cube matrix or from a user-defined color button.  The color 
in the Color box will change to match the selection. 

3. Click [OK].  The new color will be saved. 
 
! To change the unit of measure: 

1. Click the radio button next to the appropriate unit. 

2. The paper width and height will display in the units selected. 

6.7.15  Zoom Page 

  The Zoom Page button toggles between current view and the page view.  This function 
is also an option in the View menu.  See the “Zoom In” section in Chapter 9 Using the View 
Menu.  This option is available in the function block and ladder logic views. 
 
! To zoom in/out: 

1. Click the Zoom Page button on the Graphic Primitives toolbar. 

2. The workspace toggles between the current view and the page view.   

6.7.16  Zoom Area 

  The Zoom Area button zooms in to a selected area of the screen.  This function is also 
an option in the View menu.  See the “Zoom Area” section in Chapter 9 Using the View Menu.  
This option is available in the function block and ladder logic views. 
 
! To zoom an area: 

1. Click the Zoom Area button on the Graphic Primitives toolbar.  The cursor becomes 
a dotted box attached to a magnifying glass. 

2. Do one of the following. 
 

• Click the view at one corner of the workspace area to be enlarged, drag the cursor 
over the area, and release the mouse button.  The view displays the selected area. 

OR 

• Click the left mouse button in the center of the workspace area to be enlarged.  
Each left click will increase the zoom. Each right click will decrease the zoom. 
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6.8  Using the Graphic Operations Toolbar 
 
The Graphic Operations toolbar (i.e. automatic placement), shown in Figure 6-40, is used to 
reposition overlapping graphic items, rotate or flip graphic items, and group and ungroup 
graphic items.   
 

 
 

Figure 6-40  Graphic Operations toolbar 

6.8.1  Send to Front 

  The Send to Front button moves a selected item to the front of two or move 
overlapping graphic symbols/text in the view.  Send to Front is also a pop-up menu option. This 
option is available in the function block and ladder logic views.  
 
! To send an item to the front: 

1. Select an item to send to the front.  

2. Click the [Send to Front] button on the Graphic Operations toolbar or right-click on 
the item, and from the pop-up menu, select Send/Move > Send to Front.  The item 
moves to the front of other items in the view.  

6.8.2  Send to Back 

  The Send to Back button moves a selected item to the back of two or more 
overlapping graphic symbols/text in the view.  Send to Back is also a pop-up menu option. This 
option is available in the function block and ladder logic views.  
 
! To send an item to the back: 

1. Select an item to send to the front.  

2. Click the [Send to Back] button on the Graphic Operations toolbar or right-click on 
the item, and from the pop-up menu, select Send/Move > Send to Back.  The item 
moves to the back of other items in the view.  

6.8.3  Move Forward 

   The Move Forward button moves a selected item forward one level when there are 
two or move overlapping graphic symbols/text in the view.  Move Forward is also a pop-up 
menu option. This option is available in the function block and ladder logic views.  
 
! To move an item forward: 

1. Select an item to move forward.  

2. Click the [Move Forward] button on the Graphic Operations toolbar or right-click on 
the item, and from the pop-up menu, select Send/Move > Move Forward.  The item 
moves forward one level in the view.  
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6.8.4  Move Back 

   The Move Back button moves a selected item back one level when there are two or 
more overlapping graphic symbols/text in the view.  It is also a pop-up menu option. This option 
is available in the function block and ladder logic views.  
 
! To move an item back: 

1. Select an item to move back.  

2. Click the [Move Back] button on the Graphic Operations toolbar or right-click on the 
item, and from the pop-up menu, select Send/Move > Move Back.  The item moves 
back one level in the view.  

6.8.5  Flip Horizontal 

  The Flip Horizontal button flips a selected item from left to right.  Flip Horizontal is also 
a pop-up menu option. This option is available in the function block and ladder logic views.  
 
! To flip an item horizontally: 

1. Select an item to flip horizontally.  

2. Click the [Flip Horizontal] button on the Graphic Operations toolbar or right-click on 
the item, and from the pop-up menu, select Flip/Rotate > Flip Horizontal.  The item 
flips horizontally.  

6.8.6  Flip Vertical 

  The Flip Vertical button flips a selected item from top to bottom.  Flip Vertical is also a 
pop-up menu option. This option is available in the function block and ladder logic views.  
 

! To flip an item vertically: 
1. Select an item to flip vertically.  

2. Click the [Flip Vertical] button on the Graphic Operations toolbar or right-click on the 
item, and from the pop-up menu, select Flip/Rotate > Flip Vertical.  The item flips 
vertically.  

6.8.7  Rotate Left 

  The Rotate Left button rotates a selected item counterclockwise.  Rotate Left is also a 
pop-up menu option. This option is available in the function block and ladder logic views.  
 
! To rotate an item to the left: 

1. Select an item to rotate counterclockwise.  

2. Click the [Rotate Left] button on the Graphic Operations toolbar or right-click on the 
item, and from the pop-up menu, select Flip/Rotate > Rotate Left.  The item rotates 
counterclockwise.  
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6.8.8  Rotate Right 

 The Rotate Right button rotates a selected item clockwise.  Rotate Right is also a pop-
up menu option. This option is available in the function block and ladder logic views.  
 
! To rotate an item to the right: 

1. Select an item to rotate clockwise.  

2. Select the [Rotate Right] button on the Graphic Operations toolbar or right-click on 
the item, and from the pop-up menu, select Flip/Rotate > Rotate Right.  The item 
rotates clockwise.  

6.8.9  Group 

  The Group button groups two or more items into one item.  Group is also a pop-up 
menu option. This option is available in the function block and ladder logic views.  
 
! To group two or more items: 

1. Select the items to group.  

2. Click the [Group] button on the Graphic Operations toolbar or right-click on the item, 
and from the pop-up menu, select Group.  The items are grouped. 

6.8.10  Ungroup 

  The Ungroup button separates a grouped item into one or more individual items.  
Ungroup is also a pop-up menu option. This option is available in the function block and ladder 
logic views.  
 
! To ungroup a grouped item: 

1. Select the grouped item.  

2. Select the [Ungroup] button on the Graphic Operations toolbar or right-click on the 
item, and from the pop-up menu, select Ungroup.  The items are separated into 
individual items. 
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6.9  Using the Alignment Toolbar 
The Alignment toolbar, shown in Figure 6-41, aligns two or more user created graphic items.  
Function blocks and ladder logic symbols cannot be aligned, flipped or rotated using these tools. 
The toolbar also includes grid and snap buttons.  
 

 
 

Figure 6-41  Alignment toolbar 
 
Items are aligned according to the last item selected.  The last item selected is the dominant 
item.  The remaining selected items are non-dominant items.  The dominant item has solid 
selection handles.  Non-dominant items have hollow selection handles. 

6.9.1  Align Left 

  The Align Left button aligns selected items to the left side of the dominant item.  Align 
Left is also a pop-up menu option. This option is available in the function block and ladder logic 
views.  
 
! To align items on their left sides: 

1. Select two or more items to align.  

2. Click the [Align Left] button on the Alignment toolbar or right-click on the item, and 
from the pop-up menu, select Alignment > Align Left.  The items are aligned to the 
left side of the dominant item. 

6.9.2  Align Right 

  The Align Right button aligns selected items to the right side of the dominant item.  
Align Right is also a pop-up menu option. This option is available in the function block and 
ladder logic views.  
 
! To align items on their right sides: 

1. Select two or more items to align.  

2. Click the [Align Right] button on the Alignment toolbar or right-click on the item, and 
from the pop-up menu, select Alignment > Align Right.  The items are aligned to the 
right side of the dominant item. 

6.9.3  Align Top 

   The Align Top button aligns selected items to the top side of the dominant item.  Align 
Top is also a pop-up menu option. This option is available in the function block and ladder logic 
views. 
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! To align items on the top: 

1. Select two or more items to align.  

2. Click the [Align Top] button on the Alignment toolbar or right-click on the item, and 
from the pop-up menu, select Alignment > Align Top.  The items are aligned to the 
top side of the dominant item. 

6.9.4  Align Bottom 

   The Align Bottom button aligns selected items to the bottom side of the dominant 
item.  Align Bottom is also a pop-up menu option. This option is available in the function block 
and ladder logic views.  
 
! To align items on the bottom: 

1. Select two or more items to align.  

2. Click the [Align Bottom] button on the Alignment toolbar or right-click on the item, 
and from the pop-up menu, select Alignment > Align Bottom.  The items are aligned 
to the bottom side of the dominant item. 

6.9.5  Toggle Grid Snap 

   The Toggle Grid Snap button enables or disables the currently configured grid snap 
settings.  This option is also available on the Grid Snap tab of the Item Attributes dialog.   This 
option is available in the function block and ladder logic views.  
 
! To toggle the grid snap on and off: 
 

Click the [Toggle Grid Snap] button on the Alignment toolbar.  Grid snap is active if the 
button appears pressed in. 

6.9.6  Show Grid  

   The Show Grid button toggles the display of grid points in the view.  This option is also 
available on the Grid Snap tab of the Item Attributes dialog.   This option is available in the 
function block and ladder logic views.  
 
! To toggle the grid points on and off: 
 

Click the [Show Grid] button on the Alignment toolbar.  The grid displays if the button 
appears pressed in. 
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6.9.7  Grid Snap Attributes 

   The Grid Snap Attributes button displays the Grid Snap tab of the Item Attributes 
dialog.  The function of this dialog is described in the Item Attributes section.  This option is 
available in the function block and ladder logic views.  
 
! To change grid snap attributes: 
 

Click the [Grid Snap Attributes] button on the Alignment toolbar.  The Grid Snap tab of 
the Item Attributes displays. 
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Chapter 7 - Using the File Menu 
 
Use the File menu, shown in Figure 7-1, to create a new configuration, open an existing 
configuration, save a configuration and print a configuration or an individual loop. It is also used 
to download a configuration to a controller and to upload a configuration from a controller. 
These and other features are discussed in this chapter. 

 

 

 
File Menu, Station View File Menu, Loop View 

 
Figure 7-1  File menus 

7.1  New 
New creates a new configuration.  It starts with a blank station view.  This option is available in 
the station, function block, ladder logic, and all report views. 
 
! To create a new configuration: 

1. Select File > New or <Ctrl+N>.  The Database Revision dialog opens.  See Figure 7-2. 
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Figure 7-2  Database Revision dialog 
 

2. Select the database revision of the controller(s) to which the configuration will be 
downloaded. 

3. Select [OK].  A new station view appears. 

7.2  New FCO 
New FCO creates a new configuration using a preconfigured Factory Configured Option (FCO).  
This option is available in all views. FCOs are described and illustrated in the controller User’s 
Manual. 
 
! To create a new FCO configuration: 

1. Select File > New FCO. The Database Revision dialog opens. 

2. Select the database revision of the controller(s) to which the configuration will be 
downloaded. 

3. Click [OK].  The Factory Configured Options dialog displays. See Figure 7-3. 
 

 
 

Figure 7-3  Factory Configured Options 
 

4. Select a Factory Configured Option.  

5. Click [OK].  A new station workspace appears with the selected preconfigured factory 
option. 
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7.3  Open 
This option opens an existing configuration.  Open is also a Standard toolbar option as 
described in Chapter 6 Using the Toolbars.  A graphical configuration file contains a 
configuration as it existed when it was last edited and saved.  The file will open in the station 
view.  This option is available in the station, function block, ladder logic, and all report views. 
 
! To open a file: 

1. Select File > Open or press <Ctrl+O>. The Select Database File dialog displays for 
opening a configuration.  See Figure 7-4. 

 

 
 

Figure 7-4  Select Database File dialog 
 

2. Select a Configuration (.353) file from the dialog. 

3. Click [Open].  The selected configuration will open at the station view.  You can also 
double click on the file name to open the file.  

7.4  Close 
This option closes the active configuration.  This option is available in the station, function block, 
ladder logic, and all report views. 
 
! To close a configuration: 
 

Select File > Close. If you have saved the configuration, it will close. 
 
If you have not saved the configuration, the dialog in Figure 7-5 appears. Click [Yes] to 
save and close the configuration – see the Note below; click [No] to close the configuration 
without saving it; or click [Cancel] to cancel the Close operation and return to the 
configuration. 
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Figure 7-5  Save file warning message. 
 

Note: If you did not save a new configuration, the Select Database dialog will be 
displayed so that you can save it as different name.  Otherwise the file will be saved 
as the current file name. 

7.5  Delete 
This option deletes a configuration file.  Both the .353 and .V3C files are deleted.  Delete is also 
a key on the keyboard.  This option is available in the station, function block, ladder logic, and 
all report views. 
 
! To delete a file: 

1. Select File > Delete. The Select Database File dialog displays for deleting a 
configuration.  See Figure 7-6. 

 

 
 

Figure 7-6  Select Database File dialog 
 

2. Select a Configuration (.353) file name from the dialog to delete. 

3. Click [Open].  You can also double-click on the file name.   A confirm deletion dialog 
message will display.  See Figure 7-7. 
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Figure 7-7  Confirm deletion message 
 

4. Select [Yes].  Files are deleted. 

7.6  Save 
This option saves the active configuration.  For each configuration, i|config™ saves a graphical 
file (.353) and a database file (.V3C).  Save is also a Standard toolbar button.  This option is 
available in the station, function block, ladder logic, and all report views.  
 
! To save a configuration: 

1. Select File > Save or press <Ctrl+S>. If the configuration was previously saved, it will 
save immediately and the save operation is complete.  If not, i|config will open the 
Select Database File dialog.  See Figure 7-8. 

 

 
 

Figure 7-8  Select Database File dialog 
 

2. Type a new file name in the File name text box. 

3. Click [Save].  The selected configuration will be saved as the name entered in the File 
name text box. 
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7.7  Save As 
This option saves the active configuration with a new file name.  For each configuration, i|config 
saves a graphical file (.353) and a database file (.V3C).  This option is available in all views.  
 
! To save a configuration with a new file name: 

1. Select File > Save As.  The Select Database File dialog will display.  See Figure 7-9. 
 

 
 

Figure 7-9  Select Database File dialog 
 

2. Type a new file name in the File name text box. 

3. Click [Save].  The selected configuration will be saved as the name entered in the File 
name text box. 

7.8  Upload 
Upload transfers a configuration from the controller (station) to the computer.  The computer 
and controller communication ports must be set correctly to upload a configuration.  See 
Chapter 5 Communicating with the Controller for detailed information on Port Configuration and 
for more information on uploading a configuration.  This option is available all views. 
 
! To upload a configuration: 

1. Select File > Upload.  The Station Selection dialog will display to enter or confirm 
communication settings.  See Figure 7-10. 

2. Select the communication port from the Port drop down menu. 

3. Select Configure Port, if necessary, to set communication options. 

4. Click [OK].  The configuration database will upload and merge with the graphical file on 
the computer.  If the database can not merge with a graphic file, i|config will request a 
file name in order to save a new graphic file that will be created. 
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Figure 7-10  Station Selection dialog 

7.9  Download 
Download transfers a configuration from the computer to the controller (station).  The computer 
and controller communication ports must be set correctly to download a configuration.  See 
Chapter 5 Communicating with the Controller for detailed information on Port Configuration and 
for more information on downloading a configuration.  You can download the current (active) 
configuration or download a configuration from a file; see Figure 7-11.  This option is available in 
the station, function block, ladder logic, and all report views. 
 

 
 

Figure 7-11  Download configuration selections 
 
! To download the current configuration: 
 

See Section 5.3 Downloading to the Controller. 
 
! To download from a file: 
 

See Section 5.3.3 Downloading from a File. 



Chapter 7 – Using the File Menu SG15939-64V400 

 7-8

7.10  Compare Files 
Use Compare Files to compare a selected configuration file to a second configuration file. See 
Figure 7-12. 
 

 
 

Figure 7-12  Compare Files Options 
 
! To compare two local9 configurations (File to File): 

1. Select File > Compare Files > File to File. The Select Database File to Compare 
opens. See Figure 7-13. 

 

 
 

Figure 7-13  Select Database File to Compare 
 

2. Select a file to compare and click [Open]. The dialog in Figure 7-13 again appears. 

3. Select the file to compare to and click [Open]. The result of the comparison is 
displayed: The two files are identical! or The two files are different! 

 

                                                 
9 Local refers to a configuration stored on the PC. 
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! To compare a local file to an uploaded file (Upload to File): 

1. Select File > Compare Files > Upload to File. The Station Selection dialog appears. 
See Figure 7-14. 

 

 
 

Figure 7-14  Station Selection dialog 
 

2. Configure the communication ports as described in Chapter 5 Communicating with the 
Controller. 

3. Browse to the station from which the configuration will be uploaded. 

4. Click [OK]. The Select Database File to Compare dialog opens. 

5. Select the file to compare to and click [Open]. The result of the comparison is 
displayed: The two files are identical! or The two files are different! 
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7.11  Upgrade to... 
Use Upgrade to... to change the database revision of a configuration to a higher level, for 
example, from 2.01 to 4.00; see Figure 7-15. When developing a configuration for several 
controllers with different database revisions, create the configuration for the controller with the 
lowest revision and save the file.  
 
 
 

 
 

Figure 7-15  Upgrade to... selections 
 
! To upgrade a database revision: 

1. Open the configuration that is to be downloaded to two or more controllers with 
different database revisions. Close all function block and ladder logic loops to show the 
station view of the configuration. 

2. Select File > Upgrade to.... 
3. Select the database revision of the controller to which the configuration will be 

downloaded. The message in Figure 7-16 will appear when the conversion is finished. 
(All loops will be maximized after conversion.) 

 

 
 

Figure 7-16  Station Database upgraded successfully 
 

4. Save the upgraded file with a different file name. 
 

Note: Incorporating the database revision into the file name can help identify files in the 
future. 
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7.12  Print 
This menu option prints the active view as specified in the Print Option submenu.  Print is also a 
Standard toolbar option and a key combination on the keyboard.  See the Section 6.1.4 Print for 
additional information.  This option is available in the station, function block, ladder logic, and 
report reference views. 
 
! To print a function block or ladder logic view of the active configuration: 

1. Open the view to be printed. 

2. Select File > Print or <Ctrl+P>.  The print dialog displays.  See Figure 7-17.  The Print 
dialog displays the name of the printer and enables setting of printer properties. 

 

 
 

Figure 7-17  Print dialog 
 

3. Select Properties.  See Figure 7-18.  This dialog may be different, depending on the 
computer operating system and the printer selected.   

4. Normally, select Landscape for printing the function block view and Portrait for printing 
the ladder logic views.  A Paper Size can also be selected. 
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Figure 7-18  Printer Properties dialog 
 

5. Click [OK].  The Print dialog returns. 

6. The Print dialog enables you to choose the number of copies and the pages to print if 
the view is ladder logic.  Make the choices as required. 

7. Click [OK].  The view is sent to the printer. 

7.13  Print Preview 
Print Preview displays an accurate image of the view as it will be printed based on the 
selections in the Print Options submenu.  This option is available in the function block and 
ladder logic views. 
 
! To preview a view to be printed: 

1. Select File > Print Preview.  A preview of the printed view is displayed on the screen.  
See Figure 7-19.  The preview page displays several buttons: 

 
[Print] displays the Print dialog as shown in Figure 7-11. 

[Next Page] and [Previous Page] display with multiple ladder logic pages. 

[Two Pages] displays the configuration as two pages when multiple pages are 

available. 

[Zoom In] views the configuration at a closer range. 

[Zoom Out] views the configuration at a wider range. 

[Close] closes the Print Preview mode. 
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Figure 7-19  Print preview mode 
 

2. After viewing the image, click [Print], to send the image to the printer or click [Close] 
to close the Print Preview dialog. 

7.14  Print Setup 
Print Setup displays a preview of the output, the default paper Size, Orientation, and Margins of 
the workspace. See Figure 7-20.  This option is available in the station, function block, ladder 
logic, and reference views. 
 
! To set up a configuration for printing: 

1. Select File > Print Setup.  The Page Setup dialog displays as shown in Figure 7-14. 
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Figure 7-20  Page Setup dialog 
 

2. If the correct paper size is not displayed, click the down arrow button on the Size text 
box and select a paper size from the drop down list. 

3. If the correct paper source is not displayed, click the down arrow button on the Source 
text box and select a source from the drop down list. 

4. If the orientation is not correct, select the other Orientation radio button in the 
Orientation box. 

5. Click [Printer].  The Page Setup dialog for the printer displays.  See Figure 7-21.  This 
permits setting the printer Name and Properties.  See previous Print section for 
additional information. 

 

 
 

Figure 7-21  Page Setup dialog for the printer 
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7.15  Print Options 
Print Options configures the manner in which a file is printed.  The arrowhead to the right of 
this menu option indicates that additional options are available.  See Figure 7-22 for the menu. 
 

 
 

Figure 7-22  Print Options menu selections 
 

Screen – captures the entire display area.  This option is available in the function block, 
ladder logic, and reference views. 
 
Active Window – Current View – captures the currently displayed contents of the 
active view.  This option is available in the function block, ladder logic, and reference 
views. 
 
Active Window – Entire View – captures all the contents of the active view.  This option 
is available in the function block, ladder logic, and reference views. 

 
Active Window – 1 to 1 View – captures all the contents of the active view, including 
multiple pages, if needed.  This option is available in the function block, ladder logic, and 
reference views. 

 
! To configure the printed output: 
 

Select File > Print Options > “Print Option”.  See Figure 7-22. 

7.16  Screen to Clipboard 
Screen to Clipboard copies the entire screen image, including toolbars, the menu bar, and 
status bar, to the Clipboard for use by another program.  This option is available in all views.  
 
! To copy a screen to the Clipboard: 
 

Select File > Screen to Clipboard.  The image is copied to the clipboard. 

7.17  Image to Clipboard 
Image to Clipboard copies the entire current view image to the Clipboard for use by another 
program.  This option is available in all views.  
 
! To copy a image to the Clipboard: 
 

Select File > Image to Clipboard.  The image is copied to the clipboard. 
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7.18  Exit 
This option closes i|config. 
 
! To close i|config: 
 

Select File > Exit.  The program closes. 
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Chapter 8 - Using the Edit Menu 
The Edit menu, shown in Figure 8-1, provides the ability to perform operations on graphic items 
(such as graphic symbols and lines), edit graphic item attributes, and edit user-defined 
references in a configuration 
 

 
 

Figure 8-1  Edit menu, Function Block View 

8.1  Cut 
The Cut menu option moves selected graphic items, function block loops, or ladder logic loops 
to the Clipboard.  It is used in combination with the Paste option to move items from one 
location to another.   
 
Cut is also a Standard toolbar button, pop-up menu option, and key combination on the 
keyboard.  See Section 6.1.5 Cut for more information. 
 
For more information on cutting function block loops, see Section 2.8.1 Cutting Loops.   
 
This option is available in the station view for cutting loops and in the function block and ladder 
logic views for cutting graphic items.   
 
Note: Function blocks and ladder logic elements cannot be cut. 
 
! To cut a graphic item or a loop: 

1. Select the item(s) you want to cut. 

2. Select Edit >Cut or <Ctrl+X>. The selected item is removed from the configuration and 
placed in the clipboard. 

3. To place the item in another location, use the Paste function. 

8.2  Copy 
The Copy menu option copies selected items to the Clipboard.  It can be used in combination 
with the Paste option to duplicate items. 
 
Copy is also a Standard toolbar button, pop-up menu option, and key combination on the 
keyboard.  See the Section 6.1.6 Copy for more information. 
 
This option is available in the station view for copying loops and in the function block and ladder 
logic views for copying graphic items.   
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Note: Function blocks and ladder logic elements cannot be copied. 
 
! To copy a graphic item or a loop: 

1. Select the item you want to copy. 

2. Select Edit >Copy or <Ctrl+C>. The selected item is copied and placed in the 
clipboard. 

3. To place the item in another location, use the Paste function. 

8.3  Paste 
The Paste menu option moves the contents of the Clipboard to the active view.  This option is 
used with the Cut and Copy options to move items to a different location or to duplicate items. 
 
Paste will insert the most recently cut or copied item into a view.  Paste is also a Standard 
toolbar button, pop-up menu option, and a key combination on the keyboard.  See Section 6.1.7 
Paste for more information.   
 
This option is available in the station view to paste function block or ladder logic loops and in the 
function block and ladder logic views to paste graphic items.  For more information on pasting, 
see Section 2.8.3 Pasting Loops.  
 
! To paste a graphic item or a loop: 

1. Cut or copy the items from the configuration. 

2. Click on the new location. 

3. Select Edit >Paste or <Ctrl+V>. The selected item is placed in the selected location. 

8.4  Delete 
The Delete menu option deletes (erases) a portion or all of a loop.  
 
! To delete all or part of a loop: 

1. If deleting a loop, close all loops to display the station view. Select the loop to be 
removed. 

 
If deleting a portion of a loop, open the loop and select the portion (or items) to be 
deleted. 

2. Select Edit > Delete or press <Delete>.   If deleting a loop, the message in Figure 8-2 
will appear.  If deleting a function block or ladder logic element, the message in Figure 
8-3 will appear. 

 

 
 

Figure 8-2  Loop deletion confirmation message 
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Figure 8-3  Function block or ladder logic element deletion confirmation 
 

Note: No confirmation message appears when deleting a user-created graphic item. 
 

3. Click [Yes].  The selected items are deleted. 

8.5  Select All 
This option selects all the items associated with the current selection mode.  This option is 
available in the function block and ladder logic views. 

If the Item Selection Mode is active, all the following items are selected:   

• Connection Lines 

• Function Blocks 

• Ladder Logic Elements 

If the Graphics Selection Mode is active, all items on the page are selected.   
 
! To select all items associated with the selection mode: 
 

Select Edit >Select All.  All items, associated with the current selection mode, are 
selected. 

8.6  Item Attributes 
Item Attributes allows the editing of attributes pertaining to the selected item(s).  This option is 
also a Graphic Primitives toolbar button.  It is available in the function block and ladder logic 
views.  Refer to Section 6.7.14 Edit Item Attributes for details. 
 
! To edit item attributes: 

1. Select Edit > Item Attributes or right-click on the workspace and select Edit Item 
Attributes for the pop-up menu. 

 
The Item Attributes dialog displays tabs specific to the selected items.  See Figure 8-4 
for the Item Attributes dialog when graphic items are selected and Figure 8-5 when 
station, function blocks, or ladder logic elements and/or connection lines are selected. 
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Figure 8-4  Item Attributes dialog with graphic items selected 
 

 
 

Figure 8-5  Item Attributes dialog with function blocks selected 
 

2. Select the tab desired.  Make changes as necessary. 

3. Click [OK].  The changes are stored in the configuration. 
 

Note: Graphic item attribute changes are reflected in newly created items.  
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8.7  References 
There are two types of References: function block references, which are user-defined 
references, and coil references, which are fixed references (see Section 2.16 Creating and 
Editing References and Section 4.1.2 Ladder Logic Configuration).  References are the names 
assigned to the digital outputs of function blocks and ladder logic elements.  References are 
automatically created for coils in ladder logic.  References can be created manually for digital 
function block outputs.   
 
When a connection is made to a reference, a connection identifier is not automatically created.  
If the reference has a value, an off screen connection symbol (a triangle) is displayed to show 
that there is a connection.  See Figure 8-6. 
 

 
Figure 8-6  Triangle representing a connection 

 
Note: When downloading a configuration that includes ladder logic, unconfigured 
references may cause the configuration to function improperly in the controller. 
Configure unconfigured references (Edit > References) before downloading. 

 
! To create a configured reference: 

1. Select Edit > References. The Edit References dialog displays a list of references for 
the active configuration.  See figure 8-7. 

 

 
 

Figure 8-7  Edit References dialog 
 

2. Click [Create].  The Create/Modify dialog displays.  See Figure 8-8. 
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Figure 8-8  Create/Modify References dialog 

 

3. Enter a meaningful name in the Reference name text box.  The name must be unique 
and have no more than 16 characters. 

4. Select a loop name from the Loop list text box.  A list of blocks within the selected loop 
is displayed in the Block list text box. 

5. Select a block from the Block list text box.  A list of outputs within the selected block is 
displayed in the Output list text box. 

6. Click [OK].   
 

The new reference name and value appear on the Edit References dialog.  The 
connection line is configured.  A percent sign (%) displays before the name to indicate 
that the reference is for a physical I/O point. 

 

7. Select [Close] to close the Edit References dialog. 
 
! To unconfigure a reference: 

1. Select Edit >References. The Edit References dialog displays a list of references for 
the active configuration.  See figure 8-7. 

2. Select a reference name. 

3. Click [Modify].  The Create/Modify dialog displays.  See Figure 8-8. 

4. The Loop/Block/Output for the selected reference is displayed.  

5. Check the Unconfigure box. 

6. Click [OK].  The reference is unconfigured.  The reference name is not removed from 
the reference list.  

7. Click [Close] to close the Edit References dialog. 
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! To modify a reference: 

1. Select Edit >References. The Edit References dialog displays a list of references for 
the active configuration.  See figure 8-7. 

2. Select a reference name. 

3. Click [Modify].  The Create/Modify dialog displays, including the Name and Value (if 
any).  See Figure 8-8. 

4. Modify the Reference Name or Loop/Block/Output as desired.  

5. Click [OK].  The reference is changed, and the Edit Reference dialog is displayed. 

6. Click [Close] to close the Edit References dialog. 
 

! To show the uses of a reference 

1. Select Edit >References. The Edit References dialog displays a list of references for 
the active configuration.  See figure 8-7. 

2. Select a reference name. 

3. Click [Show Uses].  The Show Uses of Reference dialog displays.  See Figure 8-9. 
 

 
 

Figure 8-9  Show Uses of Reference dialog 
 

4. Modify the Reference Name or Loop/Block/Output as desired.  

5. Click [Close].  The Show Uses of Reference dialog is closed and the Edit Reference 
dialog is displayed.   

6. Click [Close] to close the Edit References dialog. 
 
! To delete a reference: 
 

Important: Only references that were created manually can be deleted.  Deleting a 
reference unconfigures all inputs using that reference. 

 

1. Select Edit >References. The Edit References dialog displays a list of references for 
the active configuration.  See figure 8-7. 
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2. Select a reference name or <Shift>-click to select more continuous references, or 
<Ctrl>-click to select multiple random references. 

3. Click [Delete].  The deletion message displays.  See Figure 8-10. 
 

 
 

Figure 8-10  Deletion confirmation message 
 

4. Click [Yes].  The reference is deleted.  

5. Click [Close] to close the Edit References dialog. 
 

8.8  Find Block 
The Find Block entry in the View Menu appears when a Function Block Loop is displayed. 
 
! To find a function block: 

1. Select Edit >Find Block. The Select a block to find dialog contains a list of the function 
blocks used in the presently open function block loop.  See figure 8-11. 

2. Select a function block type and, as appropriate, instance number. 

3. Click [Find] to highlight the sought function block or click [Parameter] to highlight the 
sought function block and display the Item Attributes dialog (refer to Section 2.6 Editing 
the Station or Loop Attributes and Section 8.6 Item Attributes). 

 

 
 

Figure 8-11  Select a block to find dialog 
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Chapter 9 - Using the View Menu 
The View menus are shown in Figure 9-1. View menus display selections needed to develop a 
configuration.  Note that the selections vary with the previous selection: function block loop, 
ladder logic loop or references. 
 

  

 

Function Block Loop Ladder Logic Loop Report/References 
 

Figure 9-1  View menus 

9.1  Grid 
Grid toggles the display of grid points over the entire view.  Grid is also an option of the 
Alignment toolbar and in the Grid Snap tab of the Item Attributes dialog.  Refer to Section 6.9 
Using the Alignment Toolbar for more information.  This option is available in the function block 
and ladder logic views. 
 
! To display the grid: 
 

Select View > Grid. The grid displays in the active view. 

9.2  Zoom 
Zoom toggles the amount of information displayed in the view.  Zoom has four options and 16 
levels.  This option and its submenu options are available in the function block and ladder logic 
views. Refer to Section 9.2 Zoom for more information. 

9.2.1  Zoom In 
Zoom In displays a closer view of a portion of the configuration on the screen.  This is also a 
Graphic Primitives toolbar option.   
 
! To  zoom in: 
 

Select View >Zoom > In or click <Alt+I>.  A closer view of a portion of the configuration is 
displayed. 

 
Note: Repeating the above steps will zoom in until the desired viewing size is reached. 
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9.2.2  Zoom Out 
Zoom Out reduces the size of the configuration on the screen to the point whole the entire view 
is displayed.  This is also a Graphic Primitives toolbar option. 
 
! To zoom out: 
 

Select View >Zoom > Out or click <Alt+O>.  A wider view of the configuration is displayed. 
 

Note: Repeating the above steps will zoom out until the desired viewing size is reached or 
the entire view displays on the screen. 

9.2.3  Zoom Area 
Zoom Area enlarges a selected area of the configuration.  This is also a Graphic Primitives 
toolbar option.   
 
! To enlarge an area of the configuration: 

1. Select View >Zoom > Area or click <Alt+A>.  The cursor turns into a magnifying glass 
with a dotted line. 

2. Click and drag on an area of the configuration, release the mouse button. 

9.2.4  Zoom Level 
Zoom has up to 16 levels.  The user can select the appropriate level using the View menu. 
 
! To select a zoom level: 
 

Select View > Zoom > Level #.  The view zooms to the level number selected. 

9.3  Toolbars 
The toolbars are used to perform most i|config™ operations.  The toolbars automatically display 
when the software is installed.  A menu option allows the user to toggle the toolbars on and off.  
This option is available in all views.  Refer to Chapter 6 Using the Toolbars for more information 
on toolbars. 
 
! To toggle the display of the toolbars: 

1. Select View > Toolbars.  The Toolbars dialog displays.  See Figure 9-2. 
 

 
 

Figure 9-2  Toolbars dialog 
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2. Click the check box for the toolbar to toggle on or off.  If an X displays in the check box, 
the corresponding toolbar will display. 

3. Click [Close].  The Toolbar dialog closes. 
 
! To move a toolbar: 
 

Click on the gray area surrounding a toolbar and drag it to a new location. 

9.3.1  The Standard Toolbar 
The Standard toolbar contains buttons for manipulating a configuration file. These buttons 
include New, Open, Save, Print, Cut, Copy, Paste, About, and Help.   Refer to Section 6.1 Using 
the Standard Toolbar for more information. 

9.3.2  The 353 Objects Toolbar 
The 353 Objects Toolbar contains buttons that are used to create loops in a configuration or 
create a new configuration from a factory configured option.  These buttons include Function 
Block Loop, Ladder Logic Loop, and New FCO. Refer to Section 6.2 Using the 353 Objects 
Toolbar for more information. 

9.3.3  The Line Connection Toolbar 
The Line Connection tools are used to connect inputs and outputs in a loop.  These buttons 
include Multiple Create, Line Connection Mode, Item Selection Mode, and Line Connection 
Attributes. For more information, refer to Section 6.3 Using the Line Connection Toolbar. 

9.3.4  The Function Block Toolbar 
The Function Block Toolbar provides tools to select new function blocks and place them in a 
function block view. A tool is provided to find a specific function block type and instance in an 
existing function block loop. In addition, a line connect tool and a line erase tool are included. 
Refer to Chapter 3 Working with Function Block Loops and Section 6.4 Using the Function 
Block Toolbar for details. 

9.3.5  The Ladder Logic Toolbar 
The Ladder Logic Toolbar provides tools to select new ladder logic elements and place them in 
a ladder logic view. Tools in the Line Connection Toolbar are used to interconnect contacts and 
coils. Refer to Chapter 4 Working with Ladder Logic Loops and Section 6.5 Using the Ladder 
Logic Toolbar for details. 

9.3.6  The Station Resources Toolbar 
This toolbar displays the total number of function blocks available to place.  The Available Block 
Information button displays resource information in the dialog.  Refer to Section 6.6 Using the 
Station Resources Toolbar for more information. 

9.3.7  The Graphic Primitives Toolbar 
The Graphic Primitives tools are used to create graphic items.  These buttons include: Multiple 
Create, Reshape, Selection Mode, Text Edit Mode, Text, Pencil, Line, Arc, Rectangle, Round 
Rectangle, Ellipse, Polygon, Button, Item Attributes, Zoom Mode, and Zoom Page Mode.  Refer 
to Section 6.7 Using the Graphic Primitives Toolbar for more information. 
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9.3.8  The Graphic Operations Toolbar 
The Graphic Operations (i.e. automatic placement) tools are used to manipulate graphic items.  
These buttons include: Send to Front, Send to Back, Move Forward, Move Backward, Flip 
Horizontal, Flip Vertical, Flip Left, Flip Right, Group, and Ungroup.  Refer to Section 6.8 Using 
the Graphic Operations Toolbar for more information. 

9.3.9  The Alignment Toolbar 
The Alignment tools are used to align items with each other.  These buttons include: Align Left, 
Align Right, Align Top, Align Bottom, Toggle Grid Snap, Show Grid, and Grid Snap Properties.  
Refer to Section 6.9 Using the Alignment Toolbar for more information. 

9.4  Status Bar 
The Status Bar displays messages in the bottom left corner of the screen, above the Windows® 
Start button.  If the cursor is over a button, it displays the function of that button.  The bottom 
right corner displays whether the number, caps, and scroll lock are on or off. 
 
The Status Bar menu option toggles the display of the status bar.  The status bar automatically 
displays when the software is installed.  This option is available in all views. 
 
! To toggle the status bar: 

1. Select View > Status Bar.   A checkmark next to the menu option indicates that the 
status bar is displayed. 

2. Click to toggle the display of the status bar. 

9.5  Ladder Logic Page 
Ladder Logic Page is used to view each page of a ladder logic loop.  Four pages are available 
for each ladder logic loop.  Each page contains a power rail with up to 38 connection points.  A 
ladder logic loop uses function blocks to implement the ladder logic.  This option is available in 
the ladder logic view.  For more information on ladder logic, see Chapter 4 Working with Ladder 
Logic Loops. 
 
! To view ladder logic pages: 

1. Select View > Ladder Logic Pages.  The Ladder Logic Pages submenu is displayed. 

2. Select the page you wish to view. 
 
! To print the pages of a ladder logic loop: 

1. Open the ladder logic loop to print. 

2. Select the appropriate print option. 

3. Select File > Print.  The Print dialog displays. 
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9.6  Function Block Parameters 
This option displays the function block parameters report view.  The report view displays a list of 
the function block parameters for the active configuration.  This option is available in all views.  
For more information, see Chapter 2 Working with the Station View. 
 
! To view function block parameters: 
 

Select View > Function Block Parameters.  The Function Block Parameters report view is 
displayed in Notepad. 

 
! To print the function block parameters: 

1. Display the report view. 

2. Select File > Print.  The Print dialog is displayed. 

3. Make any necessary changes to the Print dialog. 

4. Click [Print].  The report is sent to the selected printer. 

9.7  Connection Identifiers 
When connections are made between inputs and outputs in a function block loop, connection 
identifiers are created.  This option allows a user to view these identifiers for the active 
configuration.  This option is available in all views.  
 
! To view the connection identifiers report: 
 

Select View > Connection Identifiers.  The Connection Identifiers report view is displayed 
in Windows Notepad. 

 
! To print the function block parameters: 

1. Display the report view. 

2. In Notepad, select File > Print.  The Print dialog is displayed. 

3. Make any necessary changes to the Print dialog. 

4. Click [Print].  The report is sent to the selected printer. 

9.8  References 
References include the names and values for user defined and fixed value references for the 
active configuration.  This option allows the user to view a list of references in a single report.  
This option is available in all views. 
 
! To view the references report: 
 

Select View > References.  The References report view is displayed in i|config.  See 
Figure 9-3. 
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Figure 9-3  References report view 
 
! To print the references report view: 

1. Display the report view. 

2. Select File > Print.  The Print dialog is displayed. 

3. Make any necessary changes to the Print dialog. 

4. Click [OK].  The report is sent to the selected printer. 

9.9  Refresh 
Refresh updates the References report view.  This option is available in References report view. 
 
! To refresh the references report view: 
 

Select View > Refresh.  The References report view is updated.   

9.10  Analog Connection Lines 
Analog Connection Lines are lines that connect analog inputs and outputs.  This option toggles 
the display of these connection lines in a function block loop.  They are on as the default setting.  
This option is available in the function block view. 
 
! To toggle analog connection lines on and off: 

1. Select View > Analog Connection Lines.  A checkmark next to the menu item 
indicates that the connection lines are displayed. 

2. Repeat step 1 to toggle the display of the analog connection lines. 
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9.11  Digital Connection Lines 
Digital Connection Lines are lines that connect digital inputs and outputs.  This option toggles 
the display of these connection lines in a function block loop.  They are on as the default setting.  
This option is available in the function block view. 
 
! To toggle digital connection lines on and off: 

1. Select View > Digital Connection Lines.  A checkmark next to the menu item 
indicates that the connection lines are displayed. 

2. Repeat step 1 to toggle the display of the digital connection lines. 

9.12  Scaling Connection Lines 
Digital Connection Lines are lines that connect scaling inputs and outputs.  This option toggles 
the display of these connection lines in a function block loop.  They are on as the default setting.  
This option is available in the function block view. 
 
! To toggle scaling connection lines on and off: 

1. Select View > Scaling Connection Lines.  A checkmark next to the menu item 
indicates that the connection lines are displayed. 

2. Repeat step 1 to toggle the display of the scaling connection lines. 

9.13  Operator Display Connection Lines 
Operator Display Connection Lines are lines that connect signals to the operator display block.  
This option toggles the display of these connection lines in a function block loop.  They are on 
as the default setting.  This option is available in the function block view. 
 
! To toggle operator display connection lines on and off: 

1. Select View > Operator Display Connection Lines.  A checkmark next to the menu 
item indicates that the connection lines are displayed. 

2. Repeat step 1 to toggle the display of the operator display connection lines. 
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Chapter 10 - Using the Loop Menu 
This chapter discusses the options on the Loop menu.  Figure 10-1 displays the Loop menu 
options.  The user can develop two types of loops: a function block loop or a ladder logic loop.  
Either loop type is accessed from the station view.  For more information on the station view, 
see Chapter 2 Working with the Station View. 
 

 
 

Figure 10-1   Loop menu 

10.1  New 
The New option allows the user to create a new function block loop or ladder logic loop.  
Function Block and Ladder Logic are submenus of New.  
 
New is also a 353 Objects Toolbar option.  Refer to Chapter 6 Using the Toolbars for more 
information. This option is available in the station view.   
 
! To create a new loop: 

1. Go to the station view. 

2. Select Loop > New > Function Block or Ladder Logic.  The Enter Loop Name dialog 
displays.  See Figure 10-2. 

 

 
 

Figure 10-2  Loop Name dialog 
 

3. Enter a meaningful, unique loop name, up to a maximum of 12 characters, in the Enter 
Loop Name text box. 

4. Click [OK].  An icon representing the loop is placed in the station tree. 
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10.1.1  Creating Function Block Loops 
Creating a function block loop involves placing and connecting function blocks.  Function blocks 
can be placed only in a function block view.  For more information on function block loops, refer 
to Chapter 3 Working with Function Block Loops. 

10.1.2  Creating Ladder Logic Loops 
Creating a ladder logic loop involves placing and connecting ladder logic elements.  Ladder 
logic elements can be placed only in a ladder logic view.  For more information on ladder logic 
loops, refer to Chapter 4 Working with Ladder Logic Loops. 

10.2  Open 
This option opens the view of a selected loop in the station view and is only available in the 
station view.  See Chapter 2 Working with the Station View for more information.  
 
! To open a function block or ladder logic loop: 

1. Select a ladder logic or function block loop in the station tree. 

2. Select Loop > Open or right-click on the loop in the tree and from the pop-up menu 
select Open, or double-click on the loop.  The loop view opens. 
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Chapter 11 - Using the Communications Menu 
The Communications menu enables you to configure the communication ports on the 
computer.  See Figure 11-1.  For more information on communications, refer to Chapter 5 
Communicating with the Controller. 
 

 
 

Figure 11-1  Communications menu 

11.1  Configure 
The Communication Configuration dialog is used to configure the communication ports.  This 
option is available in all views.  For more information on communicating with the controller, refer 
to Chapter 5 Communicating with the Controller. 
 
! To configure the communication ports: 
 

1. Select Communications > Configure.  The Communication Configuration dialog is 
displayed.  See Figure 11-2. 

 

 
 

Figure 11-2  Communication Configuration dialog 
 

2. Select the Port, Protocol, Baud Rate, Data Bits, Start/Stop Bits, and Parity as required.  
The Ethernet Port Protocol is fixed as Modbus TCP/IP.  Modbus has fixed settings for 
Data Bits, Start/Stop Bits, and Parity.  Fixed settings appear grayed out. 
 
Note: The above communication configuration values must agree with equivalent values 
in the STATN - Station Parameters function block in the controller. 

3. Click [OK].  The communication settings are saved and used for all future 
communications 
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Chapter 12 - Using the Tools Menu 
The Tools menu provides access to the Upload File Path dialog where the File path can be set. 
The Loop Resources dialog enables viewing the available station and loop resources. Active 
process data uploaded from a controller can be viewed in Monitor Mode. See Figure 12-1. 
 

 
 

Program or Station View Function Block or Ladder Logic Loop View 
 

Figure 12-1  Tool menu 

12.1  Upload File Path 
The Upload File Path dialog enables you to configure the Default Configuration File Upload 
Path.  The path precedes the file name stored in the database when uploaded.   
 
The default upload path may need to be set manually if the configuration was saved to a 
different directory than was set using the install program.  For more information, refer to Chapter 
5 Communicating with the Controller. 
 
! To configure a new default path: 
 

1. Select Tools > Upload File Path.  The Options dialog is displayed.  See Figure 12-2. 
 

 
 

Figure 12-2  Options dialog 
 

2. Click Browse.  The Select a Directory dialog displays.  See Figure 12-3 
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Figure 12-3  Select a Directory dialog 
 

3. Select a file path. 

4. Click [OK].  The Select a Directory dialog closes. 

5. Click [OK].  The Options dialog closes and the upload path is saved. 

12.2  Loop Resources 
The Loop Resource dialog shows the maximum number of blocks available and the number 
used in the selected loop as well as the total amount of memory being used by the controller 
configuration and the cycle time of the controller.  For additional information, refer to Section 6.6 
Using the Station Resources Toolbar. 
 
! To  view loop resources: 

1. Select Tools > Loop Resources.  The iCONFIG dialog is displayed showing the loop, 
if in a loop view, and the station resources.  See Figure 12-4. 

 

 
 

Figure 12-4  i|config resource dialog 
 

2. View the information 

3. Click [OK].  The dialog closes. 
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12.3  Monitor Mode 
When a function block loop or ladder logic loop is displayed in i|config™ and Monitor Mode is 
then selected, active process data can be uploaded from the controller in which that loop is 
operating. The active data is highlighted and shown in the loop display.  
 
! To monitor live variables: 

1. Open the function block or ladder logic loop that is to be monitored.  

2. Click View > Monitor Mode to display the dialog in Figure 12-5. Select the Station and 
Port as described in Chapter 5 Communicating with the Controller. 

 

 
 

Figure 12-5  Station Selection dialog 
 

3. As needed, zoom in on the loop to allow the live variables to appear. Variables will 
appear when the display is zoomed to a size that permits reading the variables. 
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Chapter 13 - Using the Window Menu 
The Window menu, shown in Figure 13-1, provides options for opening a new window, closing 
an open window, and arranging windows or icons on the screen.  It also provides access to any 
open window.  These options are standard in most Windows compatible programs.   
 

 
 

Figure 13-1  Window menu 

13.1  New Window 
The New Window menu makes a duplicate of the active view.  This option is available in the 
function block and ladder logic views. 
 
! To  open a new window: 
 

Select Window > New Window.  A copy of the active view is displayed. See Figure 13-2. 
 

 
 

Figure 13-2  Duplicate of active view 

13.2  Cascade 
The Cascade option arranges windows in a fan like order with the title bars visible.  The active 
view is always layered on top.  This option is available in all views. 
 
! To cascade the windows: 
 

Select Window > Cascade.  All open views will cascade as shown in Figure 13-3. 
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Figure 13-3  Cascaded views 

13.3  Tile Horizontally 
The Tile Horizontally option resizes and arranges windows from top to bottom so that all are 
completely visible on the screen.  This option is available in all views. 
 
! To tile the windows horizontally: 
 

Select Window > Tile Horizontal.  All open views will tile horizontally as shown in Figure 
13-4. 

 

 
 

Figure 13-4  Windows tiled horizontally 
 

13.4  Tile Vertically 
The Tile Vertically option resizes and arranges windows from left to right so that all are 
completely visible on the screen.  This option is available in all views. 
 
! To tile the windows vertically: 
 

Select Window > Tile Vertically.  All open views will tile vertically as shown in Figure 13-5. 
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Figure 13-5  Windows tiled vertically 
 

13.5  Arrange Icons 
The Arrange Icons option reorganizes a group of loop icons on the background screen. This 
option is available in all views. 
 
! To arrange the icons: 
 

Select Window > Arrange Icons.  The Window Icons are reorganized.  See Figure 13-6. 
 

 
 

Figure 13-6  Arranged window icons 

13.6  Close 
The Close option closes the active window. This option is available in all views. 
 
! To close a window: 
 

Select Window > Close.  The active window closes. 

13.7  Open Window List 
The names of all open windows are displayed at the bottom of the Window menu.  A checkmark 
displays next to the name of the active window.  This option is available in all views. 
 
! To access a particular open window: 
 

Select Window > “Window Name”.  The selected window becomes the active window.  
See Figure 13-7. 

 
 



Chapter 13 – Using the Window Menu SG15939-64V400 

 13-4

 
 

Figure 13-7  Open Window List 
 
 



Chapter 14 – Using the Help Menu SG15939-64V400 

 14-1

Chapter 14 - Using the Help Menu 
Help for i|config™ is available in the form of an online manual accessible through Adobe 
Reader.  The Help menu may also provide additional information in the form of release notes, 
etc. 
 

 
 

Figure 14-1  Help menu 

14.1  Online Manual 
The online manual is SG15939-64V400 and is in Portable Document Format (PDF). The current 
version of the manual is available for download from the Siemens Internet site.  Refer to Section 
1-10 Customer/Product Support for the URL. 
 

14.2  About i|config 
The About i|config option displays a dialog box containing information about i|config software 
including copyright notice, software version number, and part number.  The part number and 
software version number are necessary when contacting technical support. 
 
! To view information about i|config: 
 

1. Select Help > About i|config.  The About i|config dialog is displayed.  See Figure 14-
2. The software version number is located in the center of the dialog. 

 

 
 

Figure 14-2  About i|config dialog 
 

2. Click [OK].  The dialog closes. 
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0i|config Graphical Configuration Utility, version 4.00, for creating and editing 
configurations for Procidia™ controller Models 352P, 353, 353R, 354, 354N 
and i|pac™; product part numbers are: 

TGX:iConfigV4.00 – Single installation (node) license1

TGX:15939-79V4.00 – Site license for multiple installations (nodes) 
TGX:15939-88V4.00 – Upgrade from previous i|config version 

Introduction 
This Software Release Memo discusses the enhancements in i|config version 4.00.  Enhancements include 
new features and resolutions to several operational considerations in earlier versions. Known V4.00 
operational considerations are described. i|config is supplied on CD-ROM. 

Software Compatibility 
i|config V4.00 is compatible with the following MPU Controller board firmware versions. 
 

Controller Model MPU Controller Board Firmware 
Procidia i|pac 2.01 through 3.00 
353R 3.00 
352P, 353 Design Level A, 
354, and 354N 1.20 through 3.00 

353 Design Level B 4.00 
 
The i|config database revision number, shown in the Station view, must match the MPU Controller board 
firmware revision number of the controller to which that configuration will be downloaded.2  
Compatibility is checked during a configuration download.  i|config will display an "Incompatible 
database revision" error message when an incompatible database is encountered.  To insure compatibility 
between controllers and configurations: 
 
• Create a new configuration by selecting File > New or File > New FCO from the menu bar.  A dialog 

box will appear requesting the database revision number (i.e. 4.00, 3.00, 2.40, 2.31, 2.20, 2.01, 1.3x 
or 1.2x).  Select the database revision of the MPU Controller board firmware.  The configuration 
database revision appears in the title bar of the Station View. 

• When a configuration is uploaded from a controller, the database revision is automatically determined 
by i|config, which shows the revision number in the title bar in the Station View. 

                                                      
1 Refer to the Siemens Software License Agreement for additional information. 
2 The firmware revision of a controller’s MPU Controller board can be viewed on the controller faceplate. Enter configuration 
and navigate to the STATN – Station Parameters function block. Select the HardWare PRESent parameter. Refer to the 
appropriate controller User’s Manual. 
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• When the controller's MPU Controller board firmware revision is upgraded, the configuration 
resident in the controller is automatically converted.  Use i|config to upgrade the graphical 
configuration(s) for that controller by opening a configuration and selecting the File > Upgrade to... 
feature. 

Personal Computer Requirements 
Install i|config on a personal computer that meets the following minimum requirements. 
 
• Microsoft® Windows® 95, 98, 2000, NT 4.0 Service Pack 5, or XP Professional operating system 

• 600 MHz or better microprocessor 

• 256 MB of RAM minimum; 512 MB or more will improve performance 

• Mouse or other pointing device 

• 1 GB of available hard disk space for the program 

• CD-ROM drive 

• VGA (800x600) or higher display capability 

• Windows supported printer (optional) 

• MultiMediaCard slot or external MMC card reader (optional) 

Software Installation 
If upgrading an installed earlier version of i|config, perform steps 1 through 6. If this is a new installation, 
perform steps 3, 4 and 6. 
 
1. Uninstall the earlier i|config version. Perform either A or B below. 

A. V2.31 or earlier: 
 

During the uninstall process you may be asked about removing .dll and .ocx files. Answer those 
questions as follows: 

 
• Answer No to any question concerning removal of .dll files 

• Answer Yes to any question concerning removal of .ocx files 

To uninstall, click Start and select Programs > Moore Products > uninstallShield. Respond to 
the displayed prompts. 

 
B. V3.0 and later: 
 

To uninstall, click Start and select Settings > Control Panel > Add or Remove programs and 
Windows Components > i|config > Change/Remove. Respond to the displayed prompts. 

 
2. If V2.31 or earlier was uninstalled, after running the uninstall program, start Windows Explorer and 

go to C:\iCONFIG. Verify that the OCX folder with its contents has been deleted. 

Do not delete the Configs folder because it contains your controller configurations. 
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3. Install i|config V4.00 by inserting the i|config CD-ROM in the PC's CD drive. If Windows autorun is 
enabled, the welcome screen will appear. 

 
Otherwise, in the Start menu, select Run and in the Run dialog box type the path to the CD-ROM 
and "setup." For example, D:\setup. Click OK. 

 
4. Follow the instructions displayed on the screen to complete the installation of i|config and Adobe® 

Reader®. 

5. If updating from i|config V2.31 or earlier: 

Start Windows Explorer. 
 
Copy the configuration files stored in the earlier version's default Configs folder to the new Configs 
folder in the new directory. Default directories are: 
 

• V2.31 and earlier - C:\iCONFIG 

• V3.00 and later - C:\Program Files\Siemens\iCONFIG 

After transferring the configuration files, delete the V2.31 or earlier iConfig folder and subfolders. 
 
6. Complete and mail the Software Registration Form to register your software. Alternatively, i|config can 

be registered online at http://www.sea.siemens.com/instrbu/support/swregistration2.htm. 
 
To run i|config, select Start > Programs > Siemens > i|config or double-click the i|config icon            on 
the desktop. 
 
i|config toolbars can be located in a row across the top of the screen or in a column on the right side of the 
screen. Move a toolbar by simply dragging it to the desired location.  

Hardware Compatibility 
Each controller model supports certain I/O expansion and communication boards. The controller model 
designation (on the controller case) indicates the options installed. Listed below is the hardware supported 
for each base controller model. Refer to the Configuration Overview section of the controller’s User’s 
Manual for the function blocks associated with each circuit board option and communication option listed 
in the table below.  
 

Option → 
Model ↓ 

I/O Expander Ubus i/o LonWorks LIL Ethernet RTC/CB 

i|pac ! ! --- ! ! ! 
352P ! --- ! ! --- ! 

353 Design 
Level A ! --- ! ! ! ! 

353 Design 
Level B ! --- --- --- ! !* 

353R ! ! --- ! ! ! 
354/354N ! --- ! ! --- ! 

* Configuration backup on MultiMediaCard 
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Hardware Compatibility Notes 
 
• When the first Ubus block or LonWorks block is selected, a message identifying the controller 

model(s) is displayed and the other function block type is no longer available for that configuration. 

• Downloading a configuration to a controller that lacks the necessary hardware to support that 
configuration will cause an error message to be displayed. The message identifies the missing 
hardware by name. 

Enhancements 
• i|config V4.00 features compatibility with Model 353 Design Level B firmware revision 4.00. 

• In the Tools menu, the ‘Options’ selection has been changed to ‘Upload File Path.’ 

• In the Tools menu, a ‘Monitor Mode’ selection has been added. 

• When controller memory resources are low, a Station Resource Indicator alarm message is now 
displayed. 

• After performing a configuration Upgrade, a ‘Select Database File’ dialog will be displayed to prompt 
saving the upgraded configuration. 

• Upon successful completion of a configuration download, a confirming ‘Successful Download’ 
message is now displayed. 

Operational Considerations 
• The Button (create) button is inactive. 

• The RTT block now includes Clock Status (CS) and Battery Status (BS) outputs. When upgrading a 
configuration to V4.00, the CS and BS outputs will not appear in the RTT graphic, although they are 
present and can be connected to other blocks as described in online Help (SG15939-64V400) Section 
3.7 Connecting Function Blocks without Connection Lines. To correct the graphic, open the affected 
loop, delete the RTT block, click the New Function Block button, select RTT, and place the new RTT 
block in the configuration. Add needed connections to the block. 

• During the installation of the Graphical Configuration utility, if insufficient hard drive space is 
available the install program may go into an infinite loop. 

• The ladder logic reference name is preceded by a % symbol if the reference is connected to the output 
of a discrete input function block. The symbol is missing from the reference name when connected to 
a DIE, DIS, UDI, or UEI block. The coil reference is preceded by a % symbol if it is connected to a 
discrete output block. The symbol is missing from the coil reference when connected to a DOE, DOS, 
UDO, or UDS block. 

• Changing a loop name when Ethernet function blocks AWE, CWE, or DWE are configured in the 
loop will cause all block inputs to be set to “unconfigured.” However, input graphic lines are not 
deleted. 
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i|config user notes 
• Specify the number of PRSEQ and ODS function block parameters that will scale the block size (e.g. 

"STEPS", "GROUPS"...) about 20% larger than required to leave room for future configuration 
revisions. The number of input parameters available in a PRSEQ or ODS function block is variable 
depending on the number of steps, groups and conditional messages specified. The database can be 
corrupted if the size of the variable data structure is changed after inputs have been configured. 

• Limit ladder logic loops to two pages per loop and leave sufficient contacts free for future 
configuration revisions. Ladder logic is a graphical representation of the function block logic in a 
controller. Contact symbols become AND blocks when the configuration is downloaded to the 
controller. There is a limit of 95 AND blocks available per converted ladder logic loop. In a complex 
ladder logic application, it is easy to use all available AND blocks. 

• Ladder logic configurations should be uploaded to the folder in which the ladder logic configuration 
is stored. The uploaded database will then be MERGED with the graphical database. If this is not 
done, auto-draw will not reconstruct ladder logic loops.  The loops are instead reconstructed as 
function block loops. 

• Uploading and auto-drawing a configuration with a ladder logic loop that contains more function 
blocks that can physically be laid on a single sheet will cause the upload to be aborted. Ladder logic 
configurations should be uploaded to the folder in which the ladder logic configuration is stored. The 
uploaded database will then be MERGED with the graphical database. 

• On-line monitoring over the LIL experiences frequent time outs.  For controllers on a LIL network, it 
is recommended to do on-line monitoring through the front port. 

• When upgrading a configuration to a higher version and that configuration contains function blocks 
not supported by the higher version, the configuration will be updated to the highest possible version 
and the message shown below displayed. Delete the incompatible block(s) and update the 
configuration to the desired version. For example, if a V2.01 configuration containing Local 
Instrument Link (LIL) function blocks is to be updated to V4.00, the configuration will be updated to 
V3.01 and a prompt to remove the LIL function blocks will be displayed. Once the blocks are 
removed, the configuration can be updated to version 4. 
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Customer/Product Support 
For the location of your local Siemens representative, visit the Siemens Process Instrumentation product 
support page at http://www2.sea.siemens.com/Products/Process-Instrumentation/Support/Customer-
Support.htm. 
 
For technical support refer to the following table and click the appropriate link. 

Technical Support 
 Online Support Request http://www.siemens.com/automation/support-request
 Telephone 1 800 333 7421 
 Hours of Operation 8 a.m. to 4:45 p.m. eastern time, Monday through Friday (except holidays) 
 Technical Publications 

in PDF 
http://www2.sea.siemens.com/Products/Process-Instrumentation/Support/PI-User-
Manuals.htm then click the product line (e.g. Control Solutions) 

Public Internet Site http://www2.sea.siemens.com/Products/Process-Instrumentation
Repair Service 1 800 365 8766 extension 3187 (for warranty and non-warranty service) 
 
 
 

! 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Procidia, i|pac, i|o and i|config are trademarks of Siemens Energy & Automation, Inc. Other trademarks are the property of their respective 
owners. All product designations may be trademarks or product names of Siemens Energy & Automation, Inc. or other supplier companies whose 
use by third parties for their own purposes could violate the rights of the owners. 
 
Siemens Energy & Automation, Inc. assumes no liability for errors or omissions in this document or for the application and use of information 
included in this document. The information herein is subject to change without notice. 
 
Procedures in this document have been reviewed for compliance with applicable approval agency requirements and are considered sound 
practice. Neither Siemens Energy & Automation, Inc. nor these agencies are responsible for repairs made by the user. 
 
© Copyright 2007, Siemens Energy & Automaton, Inc. All rights reserved. 
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