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i|config™ Graphical Configuration Utility, Version 4.00 

Product Involved 
i|config Graphical Configuration Utility, version 4.00, for creating and editing 
configurations for Procidia™ controller Models 352P, 353, 353R, 354, 354N 
and i|pac™; product part numbers are: 

TGX:iConfigV4.00 – Single installation (node) license1 
TGX:15939-79V4.00 – Site license for multiple installations (nodes) 
TGX:15939-88V4.00 – Upgrade from previous i|config version 

Introduction 
This Software Release Memo discusses the enhancements in i|config version 4.00.  Enhancements include 
new features and resolutions to several operational considerations in earlier versions. Known V4.00 
operational considerations are described. i|config is supplied on CD-ROM. 

Software Compatibility 
i|config V4.00 is compatible with the following MPU Controller board firmware versions. 
 

Controller Model MPU Controller Board Firmware 
Procidia i|pac 2.01 through 3.00 
353R 3.00 
352P, 353 Design Level A, 
354, and 354N 1.20 through 3.00 

353 Design Level B 4.00 
 
The i|config database revision number, shown in the Station view, must match the MPU Controller board 
firmware revision number of the controller to which that configuration will be downloaded.2  
Compatibility is checked during a configuration download.  i|config will display an "Incompatible 
database revision" error message when an incompatible database is encountered.  To insure compatibility 
between controllers and configurations: 
 
• Create a new configuration by selecting File > New or File > New FCO from the menu bar.  A dialog 

box will appear requesting the database revision number (i.e. 4.00, 3.00, 2.40, 2.31, 2.20, 2.01, 1.3x 
or 1.2x).  Select the database revision of the MPU Controller board firmware.  The configuration 
database revision appears in the title bar of the Station View. 

                                                      
1 Refer to the Siemens Software License Agreement for additional information. 
2 The firmware revision of a controller’s MPU Controller board can be viewed on the controller faceplate. Enter configuration 
and navigate to the STATN – Station Parameters function block. Select the HardWare PRESent parameter. Refer to the 
appropriate controller User’s Manual. 
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• When a configuration is uploaded from a controller, the database revision is automatically determined 
by i|config, which shows the revision number in the title bar in the Station View. 

• When the controller's MPU Controller board firmware revision is upgraded, the configuration 
resident in the controller is automatically converted.  Use i|config to upgrade the graphical 
configuration(s) for that controller by opening a configuration and selecting the File > Upgrade to... 
feature. 

Personal Computer Requirements 
Install i|config on a personal computer that meets the following minimum requirements. 
 
• Microsoft® Windows® 95, 98, 2000, NT 4.0 Service Pack 5, or XP Professional operating system 

• 600 MHz or better microprocessor 

• 256 MB of RAM minimum; 512 MB or more will improve performance 

• Mouse or other pointing device 

• 1 GB of available hard disk space for the program 

• CD-ROM drive 

• VGA (800x600) or higher display capability 

• Windows supported printer (optional) 

• MultiMediaCard slot or external MMC card reader (optional) 

Software Installation 
If upgrading an installed earlier version of i|config, perform steps 1 through 6. If this is a new installation, 
perform steps 3, 4 and 6. 
 
1. Uninstall the earlier i|config version. Perform either A or B below. 

A. V2.31 or earlier: 
 

During the uninstall process you may be asked about removing .dll and .ocx files. Answer those 
questions as follows: 

 
• Answer No to any question concerning removal of .dll files 

• Answer Yes to any question concerning removal of .ocx files 

To uninstall, click Start and select Programs > Moore Products > uninstallShield. Respond to 
the displayed prompts. 

 
B. V3.0 and later: 
 

To uninstall, click Start and select Settings > Control Panel > Add or Remove programs and 
Windows Components > i|config > Change/Remove. Respond to the displayed prompts. 
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2. If V2.31 or earlier was uninstalled, after running the uninstall program, start Windows Explorer and 

go to C:\iCONFIG. Verify that the OCX folder with its contents has been deleted. Do not delete the 
Configs folder because it contains your controller configurations. 

 
3. Install i|config V4.00 by inserting the i|config CD-ROM in the PC's CD drive. If Windows autorun is 

enabled, the welcome screen will appear.  

Otherwise, in the Start menu, select Run and in the Run dialog box type the path to the CD-ROM 
and "setup." For example, D:\setup. Click OK. 

 
4. Follow the instructions displayed on the screen to complete the installation of i|config and Adobe® 

Reader®. 

5. If updating from i|config V2.31 or earlier: 

Start Windows Explorer. Copy the configuration files stored in the earlier version's default Configs 
folder to the new Configs folder in the new directory. Default directories are: 

• V2.31 and earlier - C:\iCONFIG 

• V3.00 and later - C:\Program Files\Siemens\iCONFIG 

After transferring the configuration files, delete the V2.31 or earlier iConfig folder and subfolders. 
 
6. Complete and mail the Software Registration Form to register your software. Alternatively, i|config can 

be registered online at http://www.sea.siemens.com/us/Products/Process-
Instrumentation/Support/Pages/Software-Registration.aspx. 

 
To run i|config, select Start > Programs > Siemens > i|config or double-click the i|config icon            on 
the desktop. 
 
i|config toolbars can be located in a row across the top of the screen or in a column on the right side of the 
screen. Move a toolbar by simply dragging it to the desired location.  

Hardware Compatibility 
Each controller model supports certain I/O expansion and communication boards. The controller model 
designation (on the controller case) indicates the options installed. Listed below is the hardware supported 
for each base controller model. Refer to the Configuration Overview section of the controller’s User’s 
Manual for the function blocks associated with each circuit board option and communication option listed 
in the table below.  
 

Option → 
Model ↓ 

I/O Expander Ubus i/o LonWorks LIL Ethernet RTC/CB 

i|pac ! ! --- ! ! ! 
352P ! --- ! ! --- ! 

353 Design 
Level A ! --- ! ! ! ! 

353 Design 
Level B ! --- --- --- ! !* 

353R ! ! --- ! ! ! 
354/354N ! --- ! ! --- ! 

* Configuration backup on MultiMediaCard 

http://www.sea.siemens.com/us/Products/Process-Instrumentation/Support/Pages/Software-Registration.aspx
http://www.sea.siemens.com/us/Products/Process-Instrumentation/Support/Pages/Software-Registration.aspx
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Hardware Compatibility Notes 
 
• When the first Ubus block or LonWorks block is selected, a message identifying the controller 

model(s) is displayed and the other function block type is no longer available for that configuration. 

• Downloading a configuration to a controller that lacks the necessary hardware to support that 
configuration will cause an error message to be displayed. The message identifies the missing 
hardware by name. 

Enhancements 
• i|config V4.00 features compatibility with Model 353 Design Level B firmware revision 4.00. 

• In the Tools menu, the ‘Options’ selection has been changed to ‘Upload File Path.’ 

• In the Tools menu, a ‘Monitor Mode’ selection has been added. 

• When controller memory resources are low, a Station Resource Indicator alarm message is now 
displayed. 

• After performing a configuration Upgrade, a ‘Select Database File’ dialog will be displayed to prompt 
saving the upgraded configuration. 

• Upon successful completion of a configuration download, a confirming ‘Successful Download’ 
message is now displayed. 

Operational Considerations 
• The Button (create) button is inactive. 

• The RTT block now includes Clock Status (CS) and Battery Status (BS) outputs. When upgrading a 
configuration to V4.00, the CS and BS outputs will not appear in the RTT graphic, although they are 
present and can be connected to other blocks as described in online Help (SG15939-64V400) Section 
3.7 Connecting Function Blocks without Connection Lines. To correct the graphic, open the affected 
loop, delete the RTT block, click the New Function Block button, select RTT, and place the new RTT 
block in the configuration. Add needed connections to the block. 

• During the installation of the Graphical Configuration utility, if insufficient hard drive space is 
available the install program may go into an infinite loop. 

• The ladder logic reference name is preceded by a % symbol if the reference is connected to the output 
of a discrete input function block. The symbol is missing from the reference name when connected to 
a DIE, DIS, UDI, or UEI block. The coil reference is preceded by a % symbol if it is connected to a 
discrete output block. The symbol is missing from the coil reference when connected to a DOE, DOS, 
UDO, or UDS block. 

• Changing a loop name when Ethernet function blocks AWE, CWE, or DWE are configured in the 
loop will cause all block inputs to be set to “unconfigured.” However, input graphic lines are not 
deleted. 

• AIE function block – When Data Type is set to Signed Integer format, the following scaling 
parameters are not available for configuration: MINSCALE, MAXSCALE, DPP, and ENGUNITS. 

To configure scaling, change Data Type to Floating Point (FP) and enter scaling parameter values. 
Change the Data Type back to Signed Integer; scaling parameters will not be visible but will be 
downloaded to the controller. 
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i|config user notes 
• Specify the number of PRSEQ and ODS function block parameters that will scale the block size (e.g. 

"STEPS", "GROUPS"...) about 20% larger than required to leave room for future configuration 
revisions. The number of input parameters available in a PRSEQ or ODS function block is variable 
depending on the number of steps, groups and conditional messages specified. The database can be 
corrupted if the size of the variable data structure is changed after inputs have been configured. 

• Limit ladder logic loops to two pages per loop and leave sufficient contacts free for future 
configuration revisions. Ladder logic is a graphical representation of the function block logic in a 
controller. Contact symbols become AND blocks when the configuration is downloaded to the 
controller. There is a limit of 95 AND blocks available per converted ladder logic loop. In a complex 
ladder logic application, it is easy to use all available AND blocks. 

• Ladder logic configurations should be uploaded to the folder in which the ladder logic configuration 
is stored. The uploaded database will then be MERGED with the graphical database. If this is not 
done, auto-draw will not reconstruct ladder logic loops.  The loops are instead reconstructed as 
function block loops. 

• Uploading and auto-drawing a configuration with a ladder logic loop that contains more function 
blocks that can physically be laid on a single sheet will cause the upload to be aborted. Ladder logic 
configurations should be uploaded to the folder in which the ladder logic configuration is stored. The 
uploaded database will then be MERGED with the graphical database. 

• On-line monitoring over the LIL experiences frequent time outs.  For controllers on a LIL network, it 
is recommended to do on-line monitoring through the front port. 

• When upgrading a configuration to a higher version and that configuration contains function blocks 
not supported by the higher version, the configuration will be updated to the highest possible version 
and the message shown below displayed. Delete the incompatible block(s) and update the 
configuration to the desired version. For example, if a V2.01 configuration containing Local 
Instrument Link (LIL) function blocks is to be updated to V4.00, the configuration will be updated to 
V3.01 and a prompt to remove the LIL function blocks will be displayed. Once the blocks are 
removed, the configuration can be updated to version 4. 

 
 



SR15939-80-7 

 6

Customer/Product Support 
For support and the location of your local Siemens representative, refer to the table below for the URL of 
the Process Instrumentation (PI) portion of the Siemens public Internet site. Once at the site, click 
Support in the right column and then Product Support. Next select the type of support desired: sales, 
technical (see the table below), documentation, or software. 
 

Online Support Request http://www.siemens.com/automation/support-request 

Technical Support 1-800-333-7421; 8 a.m. to 4:45 p.m. eastern time, Monday through Friday (except 
holidays) 

Customer Service & Returns 1-800-365-8766 (warranty and non-warranty) 

Public Internet Site http://www.usa.siemens.com/pi 

Technical Publications 
in PDF 

Click the above link to go to the PI home page. Click Support and then Manuals 
and then, under “Additional Manuals,” select the product line (e.g. Control 
Solutions) 
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